ZendOptimizer-Installations-Problem

Apache, Lighttpd, nginx, Cherokee
Anonymous

ZendOptimizer-Installations-Problem

Post by Anonymous » 2009-08-14 13:44

Hallo

Ich versuche gerade den ZendOptimizer auf meinem VirtualServer zu installieren.
Bis zum Start des Installationsprogramm ist soweit klar...

Im Eingabefeld für "Confirm the location of your php.ini-file" wurde /etc vorgeschlagen und übernommen.
Da es sich um einen Apache Webserver handelt, habe ich den Vorschlag für "Specify the full path oft the apache control utility (apachectl)" usr/sbin/apache2tl übernommen.
Als Meldung erhalte ich dann jedoch immer:
Zend Optimizer Installation was NOT complete successfully.
Installation component: '5_2_X_com/TS/ZendOptimizer.so' was not found.

Ich habe die aktuelle version direkt von Zend runtergeladen und auf dem server entpackt.
Hat jemand eine Ahnung woran es liegt?

System Linux s15330375 2.6.9-023stab048.6-smp #1 SMP Mon Nov 17 18:41:14 MSK 2008 x86_64
Build Date Aug 20 2008 17:23:10
Configure Command '../configure' '--prefix=/usr' '--datadir=/usr/share/php5' '--mandir=/usr/share/man' '--bindir=/usr/bin' '--with-libdir=lib64' '--includedir=/usr/include' '--sysconfdir=/etc/php5/apache2' '--with-config-file-path=/etc/php5/apache2' '--with-config-file-scan-dir=/etc/php5/conf.d' '--enable-libxml' '--enable-session' '--with-mm' '--with-pcre-regex=/usr' '--enable-xml' '--enable-simplexml' '--enable-spl' '--enable-filter' '--disable-debug' '--enable-inline-optimization' '--disable-rpath' '--disable-static' '--enable-shared' '--program-suffix=5' '--with-pic' '--with-gnu-ld' '--with-system-tzdata=/usr/share/zoneinfo' '--with-apxs2=/usr/sbin/apxs2' '--disable-all' '--disable-cli'
Server API Apache 2.0 Handler
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php5/apache2
Loaded Configuration File /etc/php5/apache2/php.ini
Scan this dir for additional .ini files /etc/php5/conf.d
additional .ini files parsed /etc/php5/conf.d/ctype.ini, /etc/php5/conf.d/curl.ini, /etc/php5/conf.d/dom.ini, /etc/php5/conf.d/ftp.ini, /etc/php5/conf.d/gd.ini, /etc/php5/conf.d/gettext.ini, /etc/php5/conf.d/iconv.ini, /etc/php5/conf.d/imap.ini, /etc/php5/conf.d/mbstring.ini, /etc/php5/conf.d/mcrypt.ini, /etc/php5/conf.d/mysql.ini, /etc/php5/conf.d/mysqli.ini, /etc/php5/conf.d/openssl.ini, /etc/php5/conf.d/pdo.ini, /etc/php5/conf.d/pdo_mysql.ini, /etc/php5/conf.d/xsl.ini, /etc/php5/conf.d/zlib.ini
PHP API 20041225
PHP Extension 20060613
Zend Extension 220060519
Debug Build no
Thread Safety disabled
Zend Memory Manager enabled
IPv6 Support enabled
Registered PHP Streams php, file, data, http, ftp, https, ftps, compress.zlib
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
Registered Stream Filters string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, convert.iconv.*, zlib.*

User avatar
rudelgurke
Posts: 405
Joined: 2008-03-12 05:36

Re: ZendOptimizer-Installations-Problem

Post by rudelgurke » 2009-08-15 00:23

Existiert die bemängelte Datei im entpackten Archiv überhaupt ?

Und zur php.ini - sicher dass die in /etc liegt da dort:

...
Loaded Configuration File /etc/php5/apache2/php.ini
...

aufgeführt ist.

andy30031978
Posts: 5
Joined: 2009-11-02 10:35

Re: ZendOptimizer-Installations-Problem

Post by andy30031978 » 2009-11-02 11:39

Du hast die Anwort bereits mitgeschickt :-D
Configuration File (php.ini) Path /etc/php5/apache2

die php.ini ist nicht in /etc [-X sondern in /etc/php5/apache2 :D/

:!: Wenn Du Plesk als Adminoberfläche laufen hast, kommt bald das nächste Problem...
Um es vorweg zu nehmen: nachdem Du Zend installiert hast, musst Du die Datei /usr/local/Zend/etc/php.ini öffnen und die Zeilen die Zend eingefügt hat in die
/etc/php5/conf.d/ioncube-loader-5.2.ini
einfügen. Sie sollte dann im ungefähren so aussehen.

zend_extension=/usr/lib64/php5/extensions/php_ioncube_loader_lin_5.2_x86_64.so
[Zend]
zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.3.3
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.3.3
zend_optimizer.version=3.3.3
zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so


Danach die von Zend eingefügten Zeilen aus der php.ini löschen, alles speichern und den Apachen neu starten.

beste Grüße
Andy