KVM auf Hetzner EQ

VirtualBox, VMWare, KVM, XEN, OpenVZ, Virtuozzo, etc.
terrorfrosch
Posts: 2
Joined: 2009-07-02 13:00

KVM auf Hetzner EQ

Post by terrorfrosch » 2009-07-02 17:47

Hallo Alle,

Meine Frage ist die folgende:

Ich möchte auf einem Heztner EQ Server mit den zusätzlichen drei IP Adressen (Hetzner hat hier leider gewaltig gekürzt) drei KVM Maschinen aufbauen. Leider bekomme ich die Maschinen nicht ins Netz.

Folgende Konfiguration benutze ich zur Zeit auf dem Server (Ip Adressen geändert)

Code: Select all

# Bridged for virtuals
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual

auto virbr0
iface virbr0 inet static
      address 244.196.44.67
      network 244.196.44.64
      netmask 255.255.255.192
      broadcast 244.196.44.127
      gateway 244.196.44.65
      pointopoint 244.196.44.65
      bridge_ports eth0
      bridge_fd 9
      bridge_hello 2
      bridge_maxage 12
      bridge_stp off

Zum Erstellen der virtuellen Maschinen nutze ich die libvirt. libvirt nutzt die virbr0 und legt das interface vnet0 (vnet1, vnet2 für die weiteren virtuellen Maschinen) an.

Die Netzwerkconfiguration der virtuellen Maschinen (die zusätzlichen Adressen befinden sich im gleichen Netz wie die Hauptadresse) sieht wiederum folgendermaßen aus:

Code: Select all

iface eth0 inet static
       address 244.196.44.118
       network 244.196.44.64
       netmask 255.255.255.192
       broadcast 244.196.44.127
       gateway 244.196.44.65


In der Firma habe ich einen VHost genauso aufgebaut stehen, mit dem einzigen Unterschied, dass das Netzwerk ein anderes (192.168.0.0/24) ist. Hier läuft alles problemlos, nur bei Hetzner komme ich nicht von Aussen an die vServer und ebenfalls mit den vservern nicht nach aussen. Lediglich der Host kann den vserver und der vserver den host pingen.

Muss ich irgendwelche Routen setzen, damit das ganze funzt?

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: KVM auf Hetzner EQ

Post by Roger Wilco » 2009-07-02 17:56


terrorfrosch
Posts: 2
Joined: 2009-07-02 13:00

Re: KVM auf Hetzner EQ

Post by terrorfrosch » 2009-07-04 14:47