PHP als CGI wwwrun

Apache, Lighttpd, nginx, Cherokee
speedysurf
Posts: 16
Joined: 2009-05-30 08:46

PHP als CGI wwwrun

Post by speedysurf » 2009-05-30 08:54

Es gibt ja schon hunderte Beiträge über das wwwrun-Problem, aber so richtig einleuchtend ist die Sache noch nicht. Ich teste momentan ein bisschen mit einem Suse 10.3 und Plesk 9. Beim FTP Upload wird mir die Gruppe psacln angzeigt. In den Beiträgen habe ich gelesen, dass es reicht, wenn ich PHP als CGI laufen lassen.
Im Punkt PHP-Unterstützung der Domain bei Plesk habe ich statt Apache-Modul auf FastCGI oder CGI umgeschalten. Aber das Problem ist immer noch das gleiche, dass es Probleme mit Schreibrechten gibt. Was gilt es noch zu tun um eine ordentliche lauffähige Installation hinzubekommen.
Ich habe auch schon gelesen, dass ich erst in ein Temp-Verzeichnis uploaden soll und über SSH dann verschieben. Dies ist allerdings doch ziemlich umständlich.

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: PHP als CGI wwwrun

Post by Roger Wilco » 2009-05-30 10:26

Speedysurf wrote:In den Beiträgen habe ich gelesen, dass es reicht, wenn ich PHP als CGI laufen lassen.

Nein. Der Punkt ist nicht PHP via CGI einzubinden, sondern SuExec zu nutzen. Und SuExec greift nur bei CGI-Skripten.

speedysurf
Posts: 16
Joined: 2009-05-30 08:46

Re: PHP als CGI wwwrun

Post by speedysurf » 2009-05-30 11:42

Vielen Dank.
Ich habe gelesen, dass SuExec schon im Apache Paket dabei ist. Müsste es dann nicht schon laufen oder muss separat noch eine Installation erfolgen?

speedysurf
Posts: 16
Joined: 2009-05-30 08:46

Re: PHP als CGI wwwrun

Post by speedysurf » 2009-05-30 14:52

Ich glaube, dass ich das Problem durch das hinzufügen des Benutzers wwwrun zu der psacln Gruppe lösen konnte. Dies habe ich über Yast gemacht. Ich muss jetzt allerdings erstmal weiter testen, ob vielleicht bei anderen Sachen noch Probleme auftauchen. Letztlich soll eine Joomlainstallation ordnetlich laufen und Komponenten nachträglich installiert werden können ohne irgendwelche Fehlfunktionen.

tobi1908
Posts: 5
Joined: 2009-10-13 17:17

Re: PHP als CGI wwwrun

Post by tobi1908 » 2009-11-16 16:08

Konntest du das Problem schon Lösen?!

Ich verzweifel eben an diesem Problem.

Wenn ich PHP normal laufen lasse, habe ich keinerlei Rechte auf den Verzeichnissen.

Wenn ich in Plesk jedoch auf fastCGI umstelle, kann ich Joomla nicht einmal noch mehr installieren, und es kommt die Meldung:

"....Ihr Browser scheint keine Cookies zu unterstützen!..."