CentOS RootServer mit Plesk FastCGI Probs

Apache, Lighttpd, nginx, Cherokee
phoenyx
Posts: 6
Joined: 2009-05-01 21:57
Location: Landau

CentOS RootServer mit Plesk FastCGI Probs

Post by phoenyx » 2009-05-21 20:50

Hallo,

bevor sich hier alle denken was für ein Noob ja ich bin einer ;)

Und nun zu meinem Prob:

Folgende Situation liegt an.

Ich habe eine ganz normale Domain per Plesk eingerichtet diese läuft mit Php als Modul und funktioniert auch bis auf den Faktor das ich sie einfach nicht dazu bringe die im Verzeichnis abgelegte PHP.ini auszulesen. Es werden immer die Daten der in /etc abgelegten php.ini ausgelesen.

Wer mir hierzu einen Tip geben kann wie ich die httpd.include oder vhost.conf berabeiten muss darf sich gerne melden.

doch für mich ein viel größeres Prob ist das ich die Subdomain die ich mit FastCGI eingerichtet habe und die laut info.php auch als ServerAPI CGI/FastCGI verwendet nicht das macht was ich will.

Wenn ich unter dieser ein Joomla installieren will bekomme ich ständig die Meldung keine Cookies zugelassen. Meine Suche bei Google hat zwar vieles erbracht so auch das ich den Session.Save_path auf ein verzeichnis auf welches der Zugriff möglich ist setzen soll doch gebracht haben diese Tips alle nicht.

da auch hier nicht die php.ini gelesen wird was glaube ich bei Fast CGI normal ist (wenn ich mich recht erinnere) aber auch ein Eintrag in einer .htaccess brachte nicht den gewünschten erfolg.

Kurz zum überblick hier mal meine http.include

Code: Select all

# ATTENTION!
# DO NOT MODIFY THIS FILE OR ANY PART OF IT. THIS CAN RESULT IN IMPROPER PLESK
# FUNCTIONING OR FAILURE, CAUSE DAMAGE AND LOSS OF DATA. IF YOU REQUIRE CUSTOM
# MODIFICATIONS TO BE APPLIED TO THE CONFIGURATION, PLEASE, PERFORM THEM IN THE
# FOLLOWING FILE(S):
# /var/www/vhosts/ph0enyx.de/conf/vhost.conf
# /var/www/vhosts/ph0enyx.de/conf/vhost_ssl.conf
# /var/www/vhosts/ph0enyx.de/subdomains/<subdomain-name>/conf/vhost.conf

<IfModule mod_ssl.c>

<VirtualHost XXX.xxx.xxx.xxx:443>
   ServerName   ph0enyx.de:443
   ServerAlias  www.ph0enyx.de
   UseCanonicalName Off
      SuexecUserGroup         phoenyx psacln
   DocumentRoot /var/www/vhosts/ph0enyx.de/httpdocs/joomla
   CustomLog  /var/www/vhosts/ph0enyx.de/statistics/logs/access_ssl_log plesklog
   ErrorLog  /var/www/vhosts/ph0enyx.de/statistics/logs/error_log
<IfModule mod_userdir.c>
   UserDir /var/www/vhosts/ph0enyx.de/web_users
</IfModule>
   ScriptAlias  /cgi-bin/ /var/www/vhosts/ph0enyx.de/cgi-bin/
   Alias  /plesk-stat /var/www/vhosts/ph0enyx.de/statistics/
   <Location  /plesk-stat/>
      Options +Indexes
   </Location>
   <Location  /plesk-stat/logs/>
      Require valid-user
   </Location>
   Alias  /webstat /var/www/vhosts/ph0enyx.de/statistics/webstat
   Alias  /webstat-ssl /var/www/vhosts/ph0enyx.de/statistics/webstat-ssl
   Alias  /ftpstat /var/www/vhosts/ph0enyx.de/statistics/ftpstat
   Alias  /anon_ftpstat /var/www/vhosts/ph0enyx.de/statistics/anon_ftpstat
   Alias  /awstats-icon /var/www/html/awstats/icon
   SSLEngine on
   SSLVerifyClient none
   SSLCertificateFile /usr/local/psa/var/certificates/certZOd5265
   <Directory /var/www/vhosts/ph0enyx.de/httpdocs>
   <IfModule mod_perl.c>
   <Files ~ (.pl$)>
      SetHandler perl-script
      PerlHandler ModPerl::Registry
      Options ExecCGI
      allow from all
      PerlSendHeader On
   </Files>
   </IfModule>
   <IfModule sapi_apache2.c>
      php_admin_flag engine on
      php_admin_flag safe_mode off
      php_admin_value open_basedir "/var/www/vhosts/ph0enyx.de/httpdocs:/tmp"
   </IfModule>
   <IfModule mod_php5.c>
      php_admin_flag engine on
      php_admin_flag safe_mode off
      php_admin_value open_basedir "/var/www/vhosts/ph0enyx.de/httpdocs:/tmp"
   </IfModule>
   <IfModule mod_fcgid.c>
      <Files ~ (.fcgi)>
         SetHandler fcgid-script
         Options +FollowSymLinks +ExecCGI
      </Files>
   </IfModule>
      SSLRequireSSL
      Options -Includes +ExecCGI
   </Directory>
   <Directory /var/www/vhosts/ph0enyx.de/web_users>
   <IfModule sapi_apache2.c>
      php_admin_flag engine off
   </IfModule>
   <IfModule mod_php5.c>
      php_admin_flag engine off
   </IfModule>
   </Directory>
</VirtualHost>

</IfModule>

<VirtualHost xxx.xxx.xxx.xxx:80>
   ServerName   ph0enyx.de:80
   ServerAlias  www.ph0enyx.de
   UseCanonicalName Off
   SuexecUserGroup         phoenyx psacln
   DocumentRoot /var/www/vhosts/ph0enyx.de/httpdocs/joomla
   CustomLog  /var/www/vhosts/ph0enyx.de/statistics/logs/access_log plesklog
   ErrorLog  /var/www/vhosts/ph0enyx.de/statistics/logs/error_log
<IfModule mod_userdir.c>
   UserDir /var/www/vhosts/ph0enyx.de/web_users
</IfModule>
   ScriptAlias  /cgi-bin/ /var/www/vhosts/ph0enyx.de/cgi-bin/
   Redirect permanent /plesk-stat https://ph0enyx.de/plesk-stat
   Redirect permanent /webstat https://ph0enyx.de/webstat
   Redirect permanent /webstat-ssl https://ph0enyx.de/webstat-ssl
   Redirect permanent /ftpstat https://ph0enyx.de/ftpstat
   Redirect permanent /anon_ftpstat https://ph0enyx.de/anon_ftpstat
   Redirect permanent /awstats-icon https://ph0enyx.de/awstats-icon
   <IfModule mod_ssl.c>
      SSLEngine off
   </IfModule>
   <Directory /var/www/vhosts/ph0enyx.de/httpdocs>
   <IfModule mod_perl.c>
   <Files ~ (.pl$)>
      SetHandler perl-script
      PerlHandler ModPerl::Registry
      Options ExecCGI
      allow from all
      PerlSendHeader On
   </Files>
   </IfModule>
   <IfModule sapi_apache2.c>
      php_admin_flag engine on
      php_admin_flag safe_mode off
      php_admin_value open_basedir "/var/www/vhosts/ph0enyx.de/httpdocs:/tmp"
   </IfModule>
   <IfModule mod_php5.c>
      php_admin_flag engine on
      php_admin_flag safe_mode off
      php_admin_value open_basedir "/var/www/vhosts/ph0enyx.de/httpdocs:/tmp"
   </IfModule>
   <IfModule mod_fcgid.c>
      <Files ~ (.fcgi)>
         SetHandler fcgid-script
         Options +FollowSymLinks +ExecCGI
      </Files>
   </IfModule>
      Options -Includes +ExecCGI
   </Directory>
   <Directory /var/www/vhosts/ph0enyx.de/web_users>
   <IfModule sapi_apache2.c>
      php_admin_flag engine off
   </IfModule>
   <IfModule mod_php5.c>
      php_admin_flag engine off
   </IfModule>
   </Directory>
</VirtualHost>

<VirtualHost xxx.xxx.xxx.xxx:80>
   ServerName   joomla2.ph0enyx.de:80
   SuexecUserGroup         phoenyx psacln
   DocumentRoot /var/www/vhosts/ph0enyx.de/subdomains/joomla2/httpdocs
   CustomLog  /var/www/vhosts/ph0enyx.de/statistics/logs/access_log plesklog
   ErrorLog  /var/www/vhosts/ph0enyx.de/statistics/logs/error_log
   ScriptAlias  /cgi-bin/ /var/www/vhosts/ph0enyx.de/subdomains/joomla2/cgi-bin/
   <IfModule mod_ssl.c>
      SSLEngine off
   </IfModule>
   <Directory  /var/www/vhosts/ph0enyx.de/subdomains/joomla2/httpdocs>
   <IfModule mod_perl.c>
   <Files ~ (.pl$)>
      SetHandler perl-script
      PerlHandler ModPerl::Registry
      Options ExecCGI
      allow from all
      PerlSendHeader On
   </Files>
   </IfModule>
   <IfModule mod_fcgid.c>
      <Files ~ (.fcgi)>
         SetHandler fcgid-script
         Options +FollowSymLinks +ExecCGI
      </Files>
   </IfModule>
   <IfModule mod_fcgid.c>
   <Files ~ (.php)>
      SetHandler fcgid-script
      FCGIWrapper /usr/bin/php-cgi .php
      Options +ExecCGI
      allow from all
   </Files>
   </IfModule>
      Options -Includes +ExecCGI
   </Directory>
</VirtualHost>



die beiden info.php ausgaben findet ihr hier

http://ph0enyx.de/info.php

http://joomla2.ph0enyx.de/info.php

Ich hoffe einer von euch kann was mit meinem Wirrwarr anfangen und mir helfen.

Schon mal Danke im Vorhinein

Phoenyx aka Martin

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: CentOS RootServer mit Plesk FastCGI Probs

Post by Roger Wilco » 2009-05-21 22:09

Phoenyx wrote:Wer mir hierzu einen Tip geben kann wie ich die httpd.include oder vhost.conf berabeiten muss darf sich gerne melden.

Das geht mit der PHPINIDir Direktive.

Phoenyx wrote:da auch hier nicht die php.ini gelesen wird was glaube ich bei Fast CGI normal ist (wenn ich mich recht erinnere) aber auch ein Eintrag in einer .htaccess brachte nicht den gewünschten erfolg.

Setze den Pfad zum Verzeichnis mit der gewünschten php.ini durch die Umgebungsvariable PHPRC (http://httpd.apache.org/docs/2.2/mod/mod_env.html).

phoenyx
Posts: 6
Joined: 2009-05-01 21:57
Location: Landau

Re: CentOS RootServer mit Plesk FastCGI Probs

Post by phoenyx » 2009-05-21 22:21

Danke für die schnelle Antwort.

Doch das ist für meine bescheidenen RootServer kenntnisse zu viel.

Wo genau muss ich die Variablen einsetzen.
Kann ich damit dann jeder Sub/Domain eine eigene PHP.ini zuweisen ????

Und warum wird meine .htaccess die ja per

Code: Select all

php_value session.save_path "/var/www/vhosts/ph0enyx.de/subdomains/joomla2/httpd
ocs/tmp"


auf das zu nutzende tmp Verzeichnis für die Session Cookie Speicherung verweist nicht ausgelesen.

Danke nochmal Phoenyx aka Martin

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: CentOS RootServer mit Plesk FastCGI Probs

Post by Roger Wilco » 2009-05-21 22:58

Phoenyx wrote:Kann ich damit dann jeder Sub/Domain eine eigene PHP.ini zuweisen ????

Würde funktionieren.

Phoenyx wrote:auf das zu nutzende tmp Verzeichnis für die Session Cookie Speicherung verweist nicht ausgelesen.

Weil diese Direktive nur mit mod_php funktioniert.

phoenyx
Posts: 6
Joined: 2009-05-01 21:57
Location: Landau

Re: CentOS RootServer mit Plesk FastCGI Probs

Post by phoenyx » 2009-05-22 10:18

Wenn ich dich jetzt richtig verstanden habe und das richtig gelesen habe setzte ich diese Variablen in der Vhost.conf die ich wenn noch nicht vorhanden anlegen muss.

dann würde meine vhost.conf im jeweiligen Verzeichnis so aussehen

Code: Select all

phpinidir "/var/www/vhost/ph0enyx.de/subdomains/joomla2"


und dann eine php.ini in diesem verzeichnis mit

Code: Select all

session.save_path = "/var/www/vhost/ph0enyx.de/subdomains/joomla/tmp"


ist das soweit richtig ???

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: CentOS RootServer mit Plesk FastCGI Probs

Post by Roger Wilco » 2009-05-22 10:22

Sofern du mod_php einsetzt: Ja.

phoenyx
Posts: 6
Joined: 2009-05-01 21:57
Location: Landau

Re: CentOS RootServer mit Plesk FastCGI Probs

Post by phoenyx » 2009-05-22 10:56

Roger Wilco wrote:Sofern du mod_php einsetzt: Ja.


So nun hast du es geschafft mich vollkommen zu verwirren!!!!!

Also ich versuchs einfach nochmal.

Die Subdomains um die es mir geht joomla.ph0enyx.de liegt im von Plesk angelegten Ordner "/var/www/vhost/ph0enyx.de/subdomains/joomla2/httpdocs/"
diese läuft läuft nach Einstellung und Ausgabe meiner "info.php" auf "Server API CGI/FastCGI". Hier will ich dem Sessionpath auf "/var/www/vhost/ph0enyx.de/subdomains/joomla2/httpdocs/tmp" umstellen.

Dafür nutze ich in der vhost.conf im Verzeichnis "/var/www/vhost/ph0enyx.de/subdomains/joomla2/conf" den Eintrag Phpinidir ""/var/www/vhost/ph0enyx.de/subdomains/joomla2/httpdocs/"" und dann in der php.ini den Eintrag "session.save_path = "/var/www/vhost/ph0enyx.de/subdomains/joomla/tmp"".

RICHTIG :-k :-k :-k :-k

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: CentOS RootServer mit Plesk FastCGI Probs

Post by Roger Wilco » 2009-05-22 11:03

Phoenyx wrote:RICHTIG :-k :-k :-k :-k

Nein. Wenn du kein mod_php einsetzt, kannst du auch keine Direktiven von mod_php benutzen. Logisch, oder?
Stattdessen musst du die Variante mit der Umgebungsvariablen PHPRC nutzen, wenn du eine andere php.ini für eine Domain benutzen willst.

Das kannst du übrigens alles in der Dokumentation unter http://php.net/ nachlesen...

phoenyx
Posts: 6
Joined: 2009-05-01 21:57
Location: Landau

Re: CentOS RootServer mit Plesk FastCGI Probs

Post by phoenyx » 2009-06-24 18:24

SO ich habe mir nun ein bischen Zeit genommen um all das was du hier geschrieben hast mal sacken zu lassen und mich ein bisschen mit der Materie zu beschäftigen.

Herrausgekommen ist dabei diese vhost.conf

Code: Select all

<Directory /var/www/vhosts/ph0enyx.de/subdomains/test/httpdocs>
  <Files ~ (.php)>
    FCGIWrapper /usr/bin/php-cgi -c /var/www/vhosts/ph0enyx.de/subdomains/test/httpdocs  .php
    Options All
  </Files>
</Directory>


wenn ich alle Anleitungen richtig verstanden habe sollte es hiermit möglich sein eine php.ini pro Domain und Subdomain anzulegen

Ja ich weis du hast gesagt es geht nicht aber laut vielen anderen seiten die ich so in letzter Zeit gelesen habe soll es doch gehen.

Also bitte sag mir das es wenigstens im Ansatz richtig ist

Danke Phoenyx aka Martin

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: CentOS RootServer mit Plesk FastCGI Probs

Post by Roger Wilco » 2009-06-24 19:13

Phoenyx wrote:wenn ich alle Anleitungen richtig verstanden habe sollte es hiermit möglich sein eine php.ini pro Domain und Subdomain anzulegen

Ja.

Phoenyx wrote:Ja ich weis du hast gesagt es geht nicht aber laut vielen anderen seiten die ich so in letzter Zeit gelesen habe soll es doch gehen.

Wo habe ich das geschrieben?

phoenyx
Posts: 6
Joined: 2009-05-01 21:57
Location: Landau

Re: CentOS RootServer mit Plesk FastCGI Probs

Post by phoenyx » 2009-06-24 19:18

dann habe ich das wohl falsch verstanden ;) entschuldige

so nun muss ich nur noch rausbekommen wie ich den appache dazu zwinge die vhost.conf aus der subdomain/conf verzeichnis zu includieren

über tips bin ich dankbar ;)

nicht das ich wieder wochen brauche

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: CentOS RootServer mit Plesk FastCGI Probs

Post by Roger Wilco » 2009-06-24 19:28

Indem du websrvmng von Plesk sagst, dass es die Konfigurationsdateien neu erstellen soll.