Apache2 + mod_vhs

Apache, Lighttpd, nginx, Cherokee
ttp
Posts: 1
Joined: 2009-05-21 14:16

Apache2 + mod_vhs

Post by ttp » 2009-05-21 14:21

Ich hab Probleme das mod_vhs so zu compilieren, dass es auch läuft. Jemand schon mal versucht das unter Debian zu compilieren, so das es auch läuft? Link zu mod_vhs

Ich krieg es compiliert, allerdings wenn ich den Apache dann starte, dann findet er ne Biliothek nicht, das nutzten der Mailingliste von dem Projekt hat mir auch nichts gebracht, hab zwar ne Antwort bekommen, aber die hat mir nicht geholfen.

> line 16 of /etc/apache2/httpd.conf: Cannot load
> /usr/lib/apache2/modules/mod_vhs.so into server: libhome.so.1: cannot
> open shared object file: No such file or directory failed!
>
> Why isn´t find the libhome.so? It´s located on my Debian in
> /usr/local/lib/libhome.so
> /usr/local/lib/libhome.so.1
> /usr/local/lib/libhome.so.1.0.0
>
> must i create a symlink?
> Thanks for supporting me...

Hi

You may create a symlink or configure the library loader to search in /usr/local/lib/ .
This is configured in /etc/ld.so.conf but on Debian you'd better leave this file intact and create a .conf file in /etc/ld.so.conf.d/ with a single line in it : « /usr/local/lib ».
On my Debian server, I already have /etc/ld.so.conf.d/libc.conf that include this path.

Cheers


Bei mir gibt es die Datei /etc/ld.so.conf.d/libc.conf auch und die hat auch den besagten Eintrag, deswegen hilft mir das leider nicht weiter....

*need professional help*

(Sorry beschäftigte mich noch nicht solange mit Debian und Linux im Allgemeinen)

oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Apache2 + mod_vhs

Post by oxygen » 2009-05-21 14:29

Wenn der Linker richtig konfiguriert ist (wie du sagst) könnte es vielleicht dran liegen, dass der cache nicht aktuell ist. mal
ldconfig
ausführen.