[error] server reached MaxClients setting

Apache, Lighttpd, nginx, Cherokee
Anonymous

[error] server reached MaxClients setting

Post by Anonymous » 2009-05-10 19:16

Hallo,

ich habe seit einigen Tagen einen VServer bei der Fa.ovh
Intel Atom Dual
2x 1.6 Ghz
L2: 2x 512KB, FSB: 533MHz
Dual Core
Arbeitsspeicher 1 GB DDR 2

Ich musste aufgrund der hohen Besucherzahlen einen eigenen Server mieten obwohl ich keinerlei Ahnung vom Servern habe.
Der Server geht in die Knie wenn ich gleichzeitige Besucher 50 abwärts habe.
Ich habe mir den httpd error log angeschaut, es ist immer ein Fehlermeldung vorhanden zum Zeitpunkt wenn der Server nicht erreichbar ist.
[error] server reached MaxClients setting, consider raising the MaxClients setting

Ich habe zwar einiges über diesen Fehlermeldung gelesen bin mir nicht sicher wie ich eine Änderung vornehmen sollte um es zu optimieren.

Zur zeit habe ich folgende Einträge:

<IfModule prefork.c>
StartServers 5
MinSpareServers 5
MaxSpareServers 10
MaxClients 150
MaxRequestsPerChild 0
</IfModule>

<IfModule worker.c>
StartServers 2
MaxClients 150
MinSpareThreads 25
MaxSpareThreads 75
ThreadsPerChild 25
MaxRequestsPerChild 0
</IfModule>

<IfModule beos.c>
StartThreads 10
MaxClients 50
MaxRequestsPerThread 10000
</IfModule>


Wäre für jede Hilfe sehr dankbar.

MfG

Kurthan

User avatar
rudelgurke
Systemtester
Systemtester
Posts: 407
Joined: 2008-03-12 05:36

Re: [error] server reached MaxClients setting

Post by rudelgurke » 2009-05-10 21:15

Vielleicht keine gute Vorraussetzung sich dann einen Server zu mieten. Welches MPM kommt denn zum Einsatz ? Worker oder Prefork ? Es sein denn auf der Kiste ist BeOS oder ein Be Ableger installiert ;)
Und sind sonst noch Module geladen, läuft evtl. ein Script dass verrückt spielt ?

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: [error] server reached MaxClients setting

Post by daemotron » 2009-05-10 23:13

  • Eine Atom-CPU ist nicht gerade eine gute Voraussetzung für einen Server mit hoher Last - und vServer schon gleich dreimal nicht.
  • Welches Betriebssystem / Distribution, welche Webanwendungen setzt Du ein?
  • Die Tuning-Parameter sind Default-Werte und möchten angepasst werden (Doku dazu schon gelesen und verstanden?)
  • Bitte mal mod_status (vorübergehend) mitlaufen lassen und ein bisschen beobachten - das hilft beim Bottleneck suchen ungemein...
  • Schon mal die Forensuche angeworfen? Zu Apache Performance Tuning gab's hier schon eine Menge Threads... vielleicht ist ja was hilfreiches dabei.
“Some humans would do anything to see if it was possible to do it. If you put a large switch in some cave somewhere, with a sign on it saying 'End-of-the-World Switch. PLEASE DO NOT TOUCH', the paint wouldn't even have time to dry.” — Terry Pratchett, Thief of Time

Anonymous

Re: [error] server reached MaxClients setting

Post by Anonymous » 2009-05-11 11:17

Hallo,

ich habe den Server mit Atom wegen dem Kostenfaktor genommen.
Als Betriebssystem ist Gentoo mit folgenden Anwendungen:
Webmin
Qmail
PHP 5
Mysql 5
CMS Joomla 1.5.10

Wie aktiviere ich den mod_status ?
Im httpd.conf ?
<Location /server-status>
SetHandler server-status
Order Deny,Allow
Deny from all
Allow from .goztepelist.org
</Location>

Ich habe im Foren zwar einiges gelesen, traue mich nicht wirklich etwas zu verändern da ich nicht möchte dass auf einmal nichts mehr läuft :cry:

MfG

Kurthan

User avatar
rudelgurke
Systemtester
Systemtester
Posts: 407
Joined: 2008-03-12 05:36

Re: [error] server reached MaxClients setting

Post by rudelgurke » 2009-05-11 13:10

Siehe die Apache Dokumentation - LoadModule und dann die jeweiligen Anweisungen.

Bitte nicht falsch verstehen, aber ist es nicht vielleicht besser auf Shared Hosting bzw. einen Managed Server umzusteigen ? Dann ist man solche Sorgen los.
Lokal kann dann immer noch ein Rechner in die Ecke gestellt werden, Tastatur, Monitor usw. abziehen und da kann man in aller Ruhe alles testen ohne dass was passiert.