XENServer bei Hetzner / IP Setup

VirtualBox, VMWare, KVM, XEN, OpenVZ, Virtuozzo, etc.
drramazzotti
Posts: 7
Joined: 2009-03-14 21:43

XENServer bei Hetzner / IP Setup

Post by drramazzotti » 2009-03-14 21:48

Hallo

ich wohl zu doof und moechte es nicht verstehen...

Moechte fuer die DomU's die IP-Adressen des Subnetzes verwenden. DAfuer muss man ja bei Hetzner das routed-setup verwenden. Ich finde allerdings nicht, wie es konfigurien muss, da ich in /etc/xen keine xend-config.sxp sonder nur eine qemu-ifup...

Was muss ich nun tun.. Die IP's sind ueber das Hetzer Beispiel mit ifcfg-etho-range eingefuegt...

Was muss ich nun tun?

Danke fuer jeden verstaendlichen Hinweis

Bernhard

aquajo
RSAC
Posts: 167
Joined: 2003-02-25 21:07

Re: XENServer bei Hetzner / IP Setup

Post by aquajo » 2009-03-15 02:43

Erzähl mehr über dein Setup, welche Distribution usw.
Bei Debilian müsste eigentlich alles da sein, du hast aber auch schon ein funktionierendes System, (also der hypervisor läuft)?

drramazzotti
Posts: 7
Joined: 2009-03-14 21:43

Re: XENServer bei Hetzner / IP Setup

Post by drramazzotti » 2009-03-15 10:08

Hallo Aqua-Joe.
Keine Distribution: Der gerade freigegeben XenServer 5.0 als OS. Der Xen ist NICHT als Paket von einer Distri installiert sondern vom ISO von Citrix.

Ansicht XenServer laueft. Ueber die Haupt-IP des Servers kann ich mich per SSH verbinden oder mit der Management-Konsole von Xen-Server.
Es geht jetzr darum die zusaetzlichen IPs von HEtzer einzubinden...

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: XENServer bei Hetzner / IP Setup

Post by Roger Wilco » 2009-03-15 10:28

Nächstes mal selbst auf Multiposting hinweisen:
http://serversupportforum.de/forum/virt ... tzner.html

aquajo
RSAC
Posts: 167
Joined: 2003-02-25 21:07

Re: XENServer bei Hetzner / IP Setup

Post by aquajo » 2009-03-15 10:43

Und als Hinweis noch: die OSS-Xen Version ist wohl Konfigurationstechnisch deutlich anders, (keine eigene Erfahrung), da helfen die HowTos vermutlich nicht wirklich, schau in Die Doku.

drramazzotti
Posts: 7
Joined: 2009-03-14 21:43

Re: XENServer bei Hetzner / IP Setup

Post by drramazzotti » 2009-03-15 11:10

Danke Aqua-Joe..

RTFM habe ich schon durch ;-).

Allerdings finde ich dort keinerlei Hinweise auf ein routed-Setup...

Gruss

drramazzotti
Posts: 7
Joined: 2009-03-14 21:43

Re: XENServer bei Hetzner / IP Setup

Post by drramazzotti » 2009-03-16 17:14

Hallo,

habe jetzt die Loesung... Es gibt kein routed-Setup.. Man fuegt tataechlich eine IP des Subnetz der xenbr0 hinzu und schon klappt es... Ein CLient bekommt dann eine der restlichen IP's und als Gateeway die dem xenbr0 hinzugefuegte... Das wars...

DomU voll erreichbar... Allerdings hatte meine Testmaschine jetzt Problem bei der DNS-Aufloesung...

Bernhard

danu
Posts: 263
Joined: 2005-02-02 11:15

Re: XENServer bei Hetzner / IP Setup

Post by danu » 2009-03-17 02:47

DrRamazzotti wrote:DomU voll erreichbar... Allerdings hatte meine Testmaschine jetzt Problem bei der DNS-Aufloesung...


Mit einem kleinen Nameserverchen (dnsmasq) wäre das auch noch in den Griff zu kriegen.

drramazzotti
Posts: 7
Joined: 2009-03-14 21:43

Re: XENServer bei Hetzner / IP Setup

Post by drramazzotti » 2009-03-17 12:21

Hallo,

habe die DNS-Server des RZ in /etc/resolv.conf geschrieben....
Moechte eigentlich keinen eigenen DNS...

Anpingen kann ich die DNS-Server...

Gruss

aquajo
RSAC
Posts: 167
Joined: 2003-02-25 21:07

Re: XENServer bei Hetzner / IP Setup

Post by aquajo » 2009-03-18 01:06

Das klingt nach nem Fall für Wireshark und Konsorten, viel Spaß ;)

drramazzotti
Posts: 7
Joined: 2009-03-14 21:43

Re: XENServer bei Hetzner / IP Setup

Post by drramazzotti » 2009-03-18 19:24

Hallo,

habe jetzt folgendes "Ergebnis":

Wenn ich den DNS von der Dom0 anpinge erhalte ich folgendes Result:
64 bytes from 213.133.98.98: icmp_seq=6 ttl=61 time=1.30 ms
RR: 78.46.91.39
213.239.244.249
213.239.240.140
213.133.115.145
213.133.98.98
213.133.98.98
213.239.240.133
213.239.244.129
78.46.91.33

Tue ich das gleiche von einer DomU dann folgendes:

64 bytes from 213.133.98.98: icmp_seq=7 ttl=60 time=1.35 ms(same route)
From 85.10.218.121: icmp_seq=8 Redirect Host(New nexthop: 78.46.91.33)
64 bytes from 213.133.98.98: icmp_seq=8 ttl=60 time=1.46 ms
RR: 85.10.218.122
78.46.91.39
213.239.244.121
213.239.240.140
213.133.115.145
213.133.98.98
213.133.98.98
213.239.240.133
213.239.244.1

Hat dazu jemand eine Idee, denn ich leider nicht ;-)

Gruesse

drramazzotti
Posts: 7
Joined: 2009-03-14 21:43

Re: XENServer bei Hetzner / IP Setup

Post by drramazzotti » 2009-03-18 19:50

Ich glaube so im nachhin betrachet, kann es das doch nicht sein, dann ansich gehen ja die Pings durch...

cirox
Posts: 212
Joined: 2006-05-08 23:20
Location: Berlin

Re: XENServer bei Hetzner / IP Setup

Post by cirox » 2009-03-20 00:33

Ich habe bei mir routed-setup eingestellt in der conf. Eine Möglichkeit ist, Du definierst neben der Haupt-IP in der dom0 eine IP des Subnetztes als Gateway.

up ip addr add 192.168.2.1/24 dev eth0

Dieses Gateway trägst Du zu der normalen domu-IP in der domu ein.

So muss es doch auch bei dem xen-server gehen im Prinzip?