ftp backupspace reoback uploadproblem

Alles rund um Netzwerktechnik und Protokolle
danu
Posts: 264
Joined: 2005-02-02 11:15

ftp backupspace reoback uploadproblem

Post by danu »

Ich habe einen VM SusE 10.3 auf XEN aufgesetzt (bei Strato). Wenn ich jetzt per
# ftp backup.serverkompetenz.de

einlogge, sieht das so aus:

Code: Select all

smh-1:/ # ftp backup.serverkompetenz.de
Trying 81.169.163.180...
Connected to backup.serverkompetenz.de (81.169.163.180).
220 FTP-Backupspace
Name (backup.serverkompetenz.de:user): bxxxxxx
331 Password required for bxxxxxx
Password:
230 User bxxxxxx logged in
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls -l
521 PORT <öffentliche IP> mismatch 10.10.1.101
ftp: bind: Address already in use
ftp> quit
221 Goodbye.
erhalte ich bei eingabe des ls -l Befehls

Code: Select all

521 PORT <öffentliche IP> mismatch 10.10.1.101
ftp: bind: Address already in use
so kann ich nicht auf die Verzeichnisse zugreifen.

gebe ich aber
# pftp backup.serverkompetenz.de ein, tritt das Problem
nicht auf.

reoback kommt damit allerdings nicht klar (benötigt Perl CPAN Net::Ftp)

Der Server 10.10.1.101 ist eine VM und eine Originaldistri von Strato mit SusE 10.3 und Plesk 8.6
und alles was dazu gehört. von der Dom0 aus funktioniert alles "normal". Die Netzwerktopologie
auf dem XEN Server habe ich mit bridges aufgebaut.

die iptables im Wirtesystem für 10.10.1.101:

Code: Select all

iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
iptables -t nat -A PREROUTING -d <öfffentliche IP> -i eth0 -j DNAT --to-destination 10.10.1.101
iptables -t nat -A POSTROUTING -s 10.10.1.101 -o eth0 -j SNAT --to <öffentliche IP>
Ich vermute, dass hier wieder das NAT-ftp Problem eine Rolle spielt. Um von einem
Micro$oft Client auf den ProFTPd auf 10.10.1.101 zugreifen zu können musste ich auch ein wenig
tricksen.
Aber hierzu fällt mir echt nichts ein ...

Gruss, danu
User avatar
daemotron
Administrator
Administrator
Posts: 2639
Joined: 2004-01-21 17:44

Re: ftp backupspace reoback uploadproblem

Post by daemotron »

Ich tippe mal darauf, dass ReoBack nicht im Passive Mode auf den FTP-Server zugreift. Wenn Du das nicht über die Konfiguration erzwingen kannst, bleibt Dir wohl nur, das Perl-Skript selbst zu patchen (ReoBack ist seit 7 Jahren tot). Oder Du schaust Dich nach einem anderen Backup-Tool um; recht nett ist z. B. ftplicity...
“Some humans would do anything to see if it was possible to do it. If you put a large switch in some cave somewhere, with a sign on it saying 'End-of-the-World Switch. PLEASE DO NOT TOUCH', the paint wouldn't even have time to dry.” — Terry Pratchett, Thief of Time