User hat keinen Zugriff per SSH

Serverdienste ohne eigene Kategorie
dudemeister
Posts: 12
Joined: 2009-02-17 17:27

User hat keinen Zugriff per SSH

Post by dudemeister »

Hallo,

ich habe per useradd einen Benutzer erstellt und ihm ein home directory zugewiesen. Der neue Benutzer kann nicht per SSH einloggen. Ich habe mich umgeguckt, scheinbar sollte die Standard /etc/ssh/ssh_config es jedem ermoeglichen, sich einzuloggen. Woran kann es liegen? Welchen Gruppen muss der Benutzer moeglicherweise angehoeren? Passwort ist gesetzt, hab ich per /etc/shadow geguckt. Ich kann die config Datei auch posten. Ich wollte bloss nicht mit der Datei so viel rumachen, auf die Gefahr hin, dass der root auch noch SSH Zugang verliert...

Server ist ein 3000DS bei Hetzner, wenn das jemandem was sagt, Debian Etch mit "LAMP"

Danke,

/David

Roger Wilco
Administrator
Administrator
Posts: 5923
Joined: 2004-05-23 12:53

Re: User hat keinen Zugriff per SSH

Post by Roger Wilco »

3. Was hat das mit Webservern zu tun?
4. Logs, Logs, Logs!

dudemeister
Posts: 12
Joined: 2009-02-17 17:27

Re: User hat keinen Zugriff per SSH

Post by dudemeister »

Alright,

Danke fuer die Antworten. Ich habe einen Blick auf die logfiles geworfen und bin dabei recht blass geworden. Ist es normal, dass auf einem Server, der erst eine Woche steht gleich mal hunderte LogIn Versuche gestarted werden?

Wie auch immer, mein eigener log-in Versuch wird mit folgender Meldung abgeblockt:

Code: Select all

/var/log/auth.log:Feb 18 00:35:18 Debian-40-etch-64-LAMP sshd[32308]: Failed password for ftpuser from XXX.XXX.XXX.XX port 62345 ssh2
Wie gesagt, ich habe in der /etc/shadow geguckt, ob das Passwort stimmt also irgendwas mache ich falsch. :? Ich benutze Putty, falls das relevant ist.

Danke,

/David

Die /etc/ssh/sshd_config sieht so aus:

Code: Select all

# Package generated configuration file
# See the sshd(8) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile     %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

Roger Wilco
Administrator
Administrator
Posts: 5923
Joined: 2004-05-23 12:53

Re: User hat keinen Zugriff per SSH

Post by Roger Wilco »

Dudemeister wrote:Ist es normal, dass auf einem Server, der erst eine Woche steht gleich mal hunderte LogIn Versuche gestarted werden?
Ja. Willkommen im Internet.
Dudemeister wrote:n der /etc/shadow geguckt, ob das Passwort stimmt also irgendwas mache ich falsch.
Moment. Du kannst den Hash des Passworts, der in der /etc/shadow steht wieder zurückrechnen auf dein Passwort? Respekt...

Weise das Passwort dem Benutzer via `passwd` zu und stelle sicher, dass das Benutzerkonto nicht deaktiviert ist und eine gültige Shell zugewiesen hat.

dudemeister
Posts: 12
Joined: 2009-02-17 17:27

Re: User hat keinen Zugriff per SSH

Post by dudemeister »

Sauber, funktioniert!

Ich habe jetzt mit passwd das Passwort gesetzt. Ich hatte vorher usermod -p benutzt, bis ich mal genauer auf die man geguckt habe:

Code: Select all

-p, --password PASSWORD 
The encrypted password, as returned by crypt(3). 
Also scheinbar ist das was anders. Kann mir kurz wer sagen, was es damit auf sich hat?

Danke.