SUSE 11.0 Installation findet keine Harddisk

VirtualBox, VMWare, KVM, XEN, OpenVZ, Virtuozzo, etc.
danu
Posts: 263
Joined: 2005-02-02 11:15

SUSE 11.0 Installation findet keine Harddisk

Post by danu » 2009-02-11 23:16

Hier die domU Config

Code: Select all

# Kernel ist der HVM-Loader
kernel  = '/usr/lib/xen-3.3.0/boot/hvmloader'
builder = 'hvm'
memory  = '1024'

device_model = '/usr/lib/xen-3.3.0/bin/qemu-dm'
# Laufwerke

disk   = [ 'phy:vg1/suse-11-disk,sda1,w',
       'phy:vg1/suse-11-swap,sda2,w',   
       'file:/home/vservers/work/openSUSE-11.0-GNOME-LiveCD-x86_64.iso,ioemu:hdc:cdrom,r', ]
 
# Hostname
name    = 'smh-suse-11'
vcpus   = '2'

#  Networking
dhcp = 'dhcp'
vif = ['type=ioemu,mac=00:16:3e:15:8d:ea,bridge=xen-br0,vifname=suse-11']
# Behaviour
boot='cd'

#vfb = ['type=vnc,vnclisten=0.0.0.0']

sdl=0
vnc=1
#monitor=1
vncviewer=1

acpi=0
apic=0


Xen Version 3.3 auf Debian
die domU's laufen auf LVM

Die SUSE bootet von openSUSE-11.0-GNOME-LiveCD-x86_64.iso,
was ich mit dem VNC Viewer sehen kann. Wenn ich mit dem Live Installer (Yast)
die Installation starte, ist da keine LVM Device, obwohl in der Config eingetragen.

Damit scheitert die Installation.

Klar habe ich noch nicht alle denkbaren Möglichkeiten durchgecheckt,
wäre aber trotzdem für einen Tip dankbar.

Gruss, danu

danu
Posts: 263
Joined: 2005-02-02 11:15

Re: SUSE 11.0 Installation findet keine Harddisk

Post by danu » 2009-02-12 08:10

Ja, das ist wahrscheinlich das Dilemma. Fürd das erste booten,
um dann mit Yast das Betriebsystem installieren zu können, muss die LiveCD
openSUSE-11.0-GNOME-LiveCD-x86_64.iso

mit
kernel = '/usr/lib/xen-3.3.0/boot/hvmloader'

gebootet werden. Das fertig installierte System sollte dann mit
kernel = '/boot/vmlinuz-2.6.18-6-xen-amd64'
ramdisk = '/boot/initrd.img-2.6.18-6-xen-amd64'

gebootet werden.
Mir ist da wohl ein Denkfehler unterlaufen. Danke für den Tip

Gruss, danu

danu
Posts: 263
Joined: 2005-02-02 11:15

Re: SUSE 11.0 Installation findet keine Harddisk

Post by danu » 2009-02-25 01:31

Hat schliesslich noch geklappt

mit dem hvmloader und funktionierendem Netzwerk

Code: Select all

disk   = [ 'file:/vservers/hda,ioemu:hda,w',
        'file:/home/vservers/work/openSUSE-11.0-NET-x86_64.iso,ioemu:hdc:cdrom,r', ]


Die /vservers/hda ist eine

Code: Select all

dd if=/dev/zero of=/vservers/hda bs=1024k count=4000

Da drauf installiert SUSE die Root und die Swap Partition.

Über einen VNC Client im Textmodus kann man die Installation steuern.
Die fertige Grundinstallation habe ich dann mit rsync auf eine LVM Platte
transferiert und konnte dann diese Installation mit dem Xen Kernel booten.

Lieber Gruss, danu