Virtuelle Netzwerkadapter nicht vollständig gelöscht

Alles rund um Netzwerktechnik und Protokolle
danu
Posts: 264
Joined: 2005-02-02 11:15

Virtuelle Netzwerkadapter nicht vollständig gelöscht

Post by danu »

Ich experimentiere mit einem System Debian 2.6.18.8-xen (Xen 3.3).

Problem:
# /etc/init.d/xend stop
# ifconfig xen-br0 down
# brctl delbr xen-br0 xxx.xxx.xxx.xxx
dann bleiben unter /proc/net/dev_snmp6 und /sys/class/net die Einträge xen-br0 stehen und beim neu starten
# /etc/init.d/xend start
kommt die Fehlermeldung, dass xen-br0 existiert, hat aber keine weiteren negativen Folgen.

Das selbe Problem habe ich mit openvpn mit den adaptern tap0 ...tapn.
Hier jedoch lässt sich dann openvpn nicht mehr starten, sobald ich in der conf
einem tap Adapter einsetze bei welchen unter /proc~ und /sys~ noch entsprechende Einträge existieren.
Mit dem Befehl rm lässt sich der Eintrag unter /proc nicht löschen. Nach einem reboot sind diese
Einträge natürlich weg.
Ich denke doch, dass es einen Weg geben muss, ohne den Rechner neu zu starten.

Gruss, danu
danu
Posts: 264
Joined: 2005-02-02 11:15

Re: Virtuelle Netzwerkadapter nicht vollständig gelöscht

Post by danu »

puh, Fehler teilweise behoben. Dank einem Xen-Scripts eines Drittanbieters bin ich auf meinen Irrtum
aufmerksam geworden.
anstatt
# ifconfig xen-br0 down
habe ich jetzt
# ifconfig xen-br0 10.10.1.1 netmask 255.255.255.0 down
eingegeben. So hat es geklappt.

noch einen schönen Tag, danu
User avatar
Joe User
Project Manager
Project Manager
Posts: 11174
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Virtuelle Netzwerkadapter nicht vollständig gelöscht

Post by Joe User »

danu wrote:# brctl delbr xen-br0 xxx.xxx.xxx.xxx
dann bleiben unter /proc/net/dev_snmp6
IPv4 vs IPv6
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
danu
Posts: 264
Joined: 2005-02-02 11:15

Re: Virtuelle Netzwerkadapter nicht vollständig gelöscht

Post by danu »

Einen entsprechenden Eintrag für ipv4 habe ich unter /proc~ nicht gefunden.
Ich habe aber ipv6 nicht deaktiviert (warum sollte ich ?)

# ifconfig
gibt u.a folgendes aus

Code: Select all

tap0      Protokoll:Ethernet  Hardware Adresse 4A:94:DE:0E:03:2E
          inet6 Adresse: fe80::4894:deff:fe0e:32e/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:100
          RX bytes:0 (0.0 b)  TX bytes:9016 (8.8 KiB)

xen-br0   Protokoll:Ethernet  Hardware Adresse 4A:94:DE:0E:03:2E
          inet Adresse:10.10.1.1  Bcast:10.10.1.255  Maske:255.255.255.0
          inet6 Adresse: fe80::200:ff:fe00:0/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:58 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:7962 (7.7 KiB)  TX bytes:1394 (1.3 KiB)
openvpn muss ja mit tap0 auf die xen-br0 verlinkt sein, wodurch ich auf alle domU's
zugreifen kann, was soweit funktioniert (noch ohne Zertifikat und Verschlüsselung).

Inzwischen habe ich auch festgestellt, dass wenn ich Xen nicht sauber runterfahren konnte,
also die xen-br0 noch stehen blieb, beim Neustart von Xen in 50% der Versuche Xen nicht
mehr korrekt startete.
Weiter hatte ich beim booten noch ein Problem in den runlevels von Xen und openvpn bezüglich
der Startreihenfolge.

Ich wünsche noch ein schönes Wochenende
Gruss, danu
User avatar
Joe User
Project Manager
Project Manager
Posts: 11174
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Virtuelle Netzwerkadapter nicht vollständig gelöscht

Post by Joe User »

Wenn Du nur die IPv4-Sockets schliesst und die IPv6-Sockets offen lässt, knallt es irgendwann...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
danu
Posts: 264
Joined: 2005-02-02 11:15

Re: Virtuelle Netzwerkadapter nicht vollständig gelöscht

Post by danu »

ich erwähnte doch schon
# ifconfig xen-br0 10.10.1.1 netmask 255.255.255.0 down
eingegeben. So hat es geklappt.
damit sind doch die ipv4 UND ipv6 Sockets weg. Oder täusche ich mich da ?
User avatar
Joe User
Project Manager
Project Manager
Posts: 11174
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Virtuelle Netzwerkadapter nicht vollständig gelöscht

Post by Joe User »

Code: Select all

ifconfig xen-br0 down
Sollte alle xen-br0-Sockets schliessen...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.