Spamassassin Scoring

alexnbg
Posts: 60
Joined: 2004-03-16 11:21

Spamassassin Scoring

Post by alexnbg »

Hallo liebe Experten,

Spamassassin bringt mich noch um den Verstand. Jetzt hab ich endlich geschafft, dass nicht mehr soviel Spam durchkommt und nun
filtert er meine eigenen Mails aus. Ich werde noch wahnsinnig.

Ich hatte bisher alle gültigen Mailadressen in der Whitelist mit whitelist_from eingetragen. Resultat dürfte ja jedem klar sein. Ich habe
Spammails von meiner eigenen Emailadresse bekommen. Dies hab ich nun wieder rückgängig gemacht.

Jetzt hab ich das Problem, dass meine Mails die Score übersteigen. Zum einen weil die Score für TVD_SPACE_RATIO BODY zu hoch ist und
zum anderen weil ich sie immer über eine dynamische IP verschicke.

Frage 1:
Wie kann ich die Score für TVD_SPACE_RATIO BODY ändern?

Frage 2:
Warum mault Spamassassin immer wenn ich Mails verschicke, dass sie angeblich von einen dynamischen IP kommen? Ich muss mich doch
mit Benutzernamen und Passwort anmelden. => SMTP_AUTH ist aktiv oder??
Interessant ist auch, dass wenn ich sich an eine Mailadresse auf dem gleichen Server schicke, sie als SPAM eingestuft wird, wenn ich sie
aber "extern" schicke, dies nicht passiert. Laut Logfile ist der User auch in der Whitelist wenn er die Mail von meinem Outlook annimmt.

Code: Select all

ipx00000 amavis[6758]: (06758-07) white_black_list: whitelisted sender <alex@xxx.com>



Hier die Serverdaten. Suse Linux 8.2 (ich weiß, ist total veraltet), Confixx 2.x

postconf -n

Code: Select all

alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = smtp-amavis:[127.0.0.1]:10024
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
defer_transports =
disable_dns_lookups = no
inet_interfaces = all
mail_owner = postfix
mail_spool_directory = /var/mail
mailbox_command = /usr/bin/procmail -a "$EXTENSION"
mailbox_size_limit = 151200000
mailbox_transport =
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains =
masquerade_exceptions = root
message_size_limit = 50240000
mydestination = $myhostname, localhost.$mydomain
myhostname = ipx00000.ipxserver.de
mynetworks_style = host
newaliases_path = /usr/bin/newaliases
program_directory = /usr/lib/postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix/README_FILES
relayhost =
relocated_maps = hash:/etc/postfix/relocated
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_sasl_auth_enable = no
smtpd_client_restrictions = permit_sasl_authenticated
smtpd_helo_required = no
smtpd_helo_restrictions =
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = ipx00000
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_use_tls = no
strict_rfc821_envelopes = no
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 450


Spam Mailheader

Code: Select all

X-Spam-Flag: YES
X-Spam-Checker-Version: SpamAssassin 3.2.4 (2008-01-01) on server.de
X-Spam-Level: *****
X-Spam-Status: Yes, score=5.1 required=3.5 tests=HTML_MESSAGE,RCVD_IN_PBL,
   RCVD_IN_SORBS_DUL,RDNS_DYNAMIC,TVD_SPACE_RATIO autolearn=disabled
   version=3.2.4
X-Spam-Report:
   *  0.5 RCVD_IN_PBL RBL: Received via a relay in Spamhaus PBL
   *      [91.11.201.157 listed in zen.spamhaus.org]
   *  1.6 RCVD_IN_SORBS_DUL RBL: SORBS: sent directly from dynamic IP address
   *      [91.11.201.157 listed in dnsbl.sorbs.net]
   *  0.0 HTML_MESSAGE BODY: HTML included in message
   *  2.9 TVD_SPACE_RATIO BODY: TVD_SPACE_RATIO
   *  0.1 RDNS_DYNAMIC Delivered to trusted network by host with
   *      dynamic-looking rDNS



Vielen Dank an alle die versuchen mir zu helfen!!!

Gruß


Alex
Top

danton
Posts: 47
Joined: 2006-01-10 17:45

Re: Spamassassin Scoring

Post by danton »

Konfigurier in Postfix den Submission-Port 587 und verschicke darüber deine Mails. Auf Port 587 deaktivierst du Spamassassin und nimmst nur Mails an, die per SMTP-Auth reinkommen. Sofern du auf Port 465 SMTP over SSL laufen hast (wobei mittlerweile die Empfehlung ist, Post 25/587 mit STARTTLS zu nutzen), könntest du das auf diesem Port auch so kondigurieren - andere Mailserver liefern normalerweise ja immer auf Port 25 ab. Positiver Nebeneffekt: Bei authentifizierten Users wird Spamassassin gar nicht bemüht, was u.U. Resourcen schont.
Top

alexnbg
Posts: 60
Joined: 2004-03-16 11:21

Re: Spamassassin Scoring

Post by alexnbg »

Aber das bedeutet doch, dass ich alle Clients umkonfigurieren muss oder nicht?
Top

franki
Posts: 60
Joined: 2005-05-31 16:23
Location: Dresden

Re: Spamassassin Scoring

Post by franki »

Frage 1:
Wie kann ich die Score für TVD_SPACE_RATIO BODY ändern?

Das sollte doch einfach in der Datei 50_scores.cf in /usr/share/spamassassin gehen. Dort einfach als Punktwert 0 eintragen. Zu Frage 2 weiß ich aber auch keine Antwort.

Insgesamt würde ich den Wert von 3.5, ab der die Mail als Spam eingestuft wird, etwas höher setzen (auf 5).

Gruß von Franki.
Top

danton
Posts: 47
Joined: 2006-01-10 17:45

Re: Spamassassin Scoring

Post by danton »

AlexNbg wrote:Aber das bedeutet doch, dass ich alle Clients umkonfigurieren muss oder nicht?


Wenn deine Clients kein SSL verwenden oder per STARTTLS verschlüsseln, dann ja. Sofern nicht mal STARTTLS verwendet wird, würde ich bei der Anpassung des Servers an deiner Stelle gleich zwei Fliegen mit einer Klappe schlagen und die Clients auch direkt umkonfigurieren, so das auch verschlüsselt wird.
Top