nix geht *heul*

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

nix geht *heul*

Post by kolibri250 »

hallo zusammen...

habe postfix und dovecot installiert.. jedoch ist der server weder über smtp noch über pop zu erreichen..

meine main.cf in /etc/postfix

Code: Select all

allow_percent_hack = no
biff = no
broken_sasl_auth_clients = yes
disable_vrfy_command = yes
home_mailbox = Maildir/
mailbox_size_limit = 102400000
masquerade_exceptions = root
message_size_limit = 20480000
mydestination = $myhostname, $mydomain, localhost
mydomain = blue-media-content.de
myhostname = mail.hierstehtmeinedomain.de
mynetworks_style = host
myorigin = $mydomain
#receive_override_options = no_address_mappings
smtpd_client_restrictions =
  permit_mynetworks,
  permit_sasl_authenticated,
#  reject_unknown_client_hostname,
  reject_unknown_reverse_client_hostname,
  permit
smtpd_data_restrictions =
  permit_mynetworks,
  permit_sasl_authenticated,
  reject_unauth_pipelining,
  permit
smtpd_delay_reject = yes
smtpd_helo_required = yes
smtpd_helo_restrictions =
  permit_mynetworks,
  permit_sasl_authenticated,
  reject_invalid_helo_hostname,
  reject_non_fqdn_helo_hostname,
#  reject_unknown_helo_hostname,
  permit
smtpd_recipient_restrictions =
  permit_mynetworks,
  permit_sasl_authenticated,
  reject_invalid_hostname,
  reject_non_fqdn_hostname,
  reject_non_fqdn_recipient,
  reject_unknown_recipient_domain,
  check_recipient_mx_access cidr:/etc/postfix/mx_access,
  reject_unauth_destination,
  check_recipient_access pcre:/etc/postfix/recipient_checks.pcre,
###  check_policy_service inet:127.0.0.1:12525,
  permit
smtpd_sasl_auth_enable = yes
#smtpd_sasl_local_domain = $myhostname
smtpd_sender_restrictions =
  permit_mynetworks,
  permit_sasl_authenticated,
  reject_non_fqdn_sender,
  reject_unknown_sender_domain,
  permit
smtpd_tls_auth_only = yes
smtpd_tls_CAfile = /etc/postfix/ssl/demoCA/cacert.pem
smtpd_tls_cert_file = /etc/postfix/ssl/server-crt.pem
smtpd_tls_dh1024_param_file = /etc/postfix/ssl/dh_1024.pem
smtpd_tls_dh512_param_file = /etc/postfix/ssl/dh_512.pem
smtpd_tls_key_file = /etc/postfix/ssl/server-key.pem
smtpd_tls_session_cache_database = btree:/var/run/smtpd_tls_session_cache
smtpd_tls_security_level = may
smtpd_use_tls = yes


inhalt von /etc/dovecot/dovecot.conf

Code: Select all

protocols = imap pop3
listen = [::]
ssl_listen = [::]
ssl_disable = yes
mail_location = maildir:~/Maildir
protocol imap {
 mail_plugin_dir = /usr/lib64/dovecot/modules/imap
}

protocol pop3 {
pop3_uidl_format = %08Xu%08Xv
mail_plugin_dir = /usr/lib64/dovecot/modules/pop3
}

protocol lda {
postmaster_address = postmaster@example.com
 mail_plugin_dir = /usr/lib64/dovecot/modules/lda
}
auth default {
 mechanisms = plain login
 passdb pam {
  }
  userdb passwd {
  }
user = root
}

dict {
}

plugin {
}


was hab ich falsch gemacht???
firewall hab ich im moment keine laufen..
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: nix geht *heul*

Post by Roger Wilco »

Die Dienste laufen (-> `ps`) und haben sich an die entsprechenden Sockets gebunden (-> `netstat`, `lsof`)?
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: nix geht *heul*

Post by Joe User »

Logs? Certs erstellt und passend abgelegt?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

Roger Wilco wrote:Die Dienste laufen (-> `ps`) und haben sich an die entsprechenden Sockets gebunden (-> `netstat`, `lsof`)?



ergebnis von ps aux | grep postfix:

Code: Select all

root     22916  0.0  0.0  43092  2280 ?        Ss   Jan05   0:00 /usr/lib/postfix/master


ergebnis von ps aux | grep dovecot:

Code: Select all

dovecot   3642  0.0  0.0  14012  1252 ?        S    Jan06   0:00 pop3-login
dovecot   7224  0.0  0.0  14016  1256 ?        S    05:41   0:00 pop3-login
root      9984  0.0  0.0  12312   652 ?        Ss   Jan04   0:00 /usr/sbin/dovecot
root      9985  0.0  0.0  63704  2464 ?        S    Jan04   0:00 dovecot-auth
dovecot   9995  0.0  0.0  14016  1264 ?        S    Jan04   0:00 imap-login
dovecot   9997  0.0  0.0  14020  1264 ?        S    Jan04   0:00 imap-login
dovecot  11568  0.0  0.0  14012  1252 ?        S    15:26   0:00 pop3-login
root     12035  0.0  0.0   4184   740 pts/0    S+   16:44   0:00 grep dovecot
dovecot  24776  0.0  0.0  14016  1260 ?        S    Jan06   0:00 imap-login


ergebnis von netstat -tulpen:

Code: Select all

tcp        0      0 0.0.0.0:3306            0.0.0.0:*               LISTEN      60         353503     23408/mysqld
tcp        0      0 0.0.0.0:110             0.0.0.0:*               LISTEN      0          48828      3642/pop3-login
tcp        0      0 0.0.0.0:143             0.0.0.0:*               LISTEN      0          48824      9984/dovecot
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      0          37627      5669/httpd2-prefork
tcp        0      0 0.0.0.0:10000           0.0.0.0:*               LISTEN      0          36449      5149/perl
tcp        0      0 xx.xxx.xxx.xxx:53       0.0.0.0:*               LISTEN      44         37512      5601/named
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      44         37510      5601/named
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      0          10543      2974/sshd
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      0          145675     22916/master
tcp        0      0 127.0.0.1:953           0.0.0.0:*               LISTEN      44         37514      5601/named
udp        0      0 0.0.0.0:32768           0.0.0.0:*                           44         37513      5601/named
udp        0      0 0.0.0.0:10000           0.0.0.0:*                           0          36450      5149/perl
udp        0      0 x.xxx.xxx.xxx:53       0.0.0.0:*                           44         37511      5601/named
udp        0      0 127.0.0.1:53            0.0.0.0:*                           44         37509      5601/named
udp        0      0 0.0.0.0:68              0.0.0.0:*                           0          10467      3014/dhclient
udp        0      0 xx.xx.xx.xx:123      0.0.0.0:*                           0          10688      3032/ntpd
udp        0      0 127.0.0.1:123           0.0.0.0:*                           0          10687      3032/ntpd
udp        0      0 0.0.0.0:123             0.0.0.0:*                           0          10685      3032/ntpd



"lsof" sagt mir nicht wirklich was :)
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

Joe User wrote:Logs? Certs erstellt und passend abgelegt?


zertifikate sind korrekt erstellt und abgelegt..
logs gibts auch.. ja...

mail.err
Jan 7 16:48:51 h1445814 postfix/pickup[12120]: fatal: file /etc/postfix/main.cf: parameter setgid_group: unknown group name: postdrop

reicht das, wenn ich einfach ne gruppe "postdrop" anlege??? oder muss mehr getan werden?


mail.info
Jan 7 15:26:26 h1445814 dovecot: pop3-login: Disconnected: rip=193.34.91.45, lip=xx.xx.xx.xx

das sind fehlerhafte pop-logins.. ich bekomme rückmeldung vom mailprogramm:
Plaintext authentication disallowed on non-secure connections.

mail.warn
Jan 7 16:52:00 h1445814 postfix/master[22916]: warning: process /usr/lib/postfix/flush pid 12138 exit status 1
Jan 7 16:52:00 h1445814 postfix/master[22916]: warning: /usr/lib/postfix/flush: bad command startup -- throttling

ich denke mal, der eintrag hier liegt am fehlender gruppe...
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

matzewe01 wrote:Wenn mich nicht alles täuscht, sollte doch der smtp auch auf die externe IP lausche und nicht nur auf localhost:

tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 0 145675 22916/master



und wie ändert mandas???
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: nix geht *heul*

Post by Joe User »

Hast Du die Dienste nach den Konfigurationsänderungen neu gestartet?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

matzewe01 wrote:Ich habe leider nur eine qmail Kiste als Vergleichsystem.
Dort werden eingehende Anfragen auf Port 25 per xinet.d gesteuert.

Vielleicht hilft es ja schon, wenn Du den startest.


inet_interfaces
setzt die Netzwerkadresse von der dieses Mailsystem Mails empfangen kann.
Standart ist inet_interfaces = all.



xinetd hab ich auch schon dran gedacht und dann nicht schlecht gestaunt, als er überhaupt nicht installiert war!! *lol*
hab ihn nachinstalliert aber von pop oder smtp keine spur


Die anderen Fehler sind jedoch nachvolziehbar. Du musst schon eine SSL Verbdindugn zu Deinem Pop Dienst aufbauen und über den Secure Port mit Ihm sprechen.


??? sorry, daß ich mich nen bischen dämlich anstelle, nur email war nie wirklich so richtig mein thema.. *lol*
aber wie komm ich nun an den secure port?? ich baue ganz normal die verbindung zum server auf über den host..
muss ich die mx-einträge im dns verändern?
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

Joe User wrote:Hast Du die Dienste nach den Konfigurationsänderungen neu gestartet?


ja klar.. das mache ich grundsätzlich nach jeder änderung.
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

ahh habs gefunden..

antwort des servers: "sorry.. TLS support isn´t enabled"
Top

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: nix geht *heul*

Post by daemotron »

Weder Postfix noch Dovecot benötigen (x)inetd. An welchem Interface Postfix lauscht, wird normalerweise in der master.cf festgelegt. Wenn da irgendwas von 127.0.0.1:smtp steht, liegt da der Fehler. Ansonsten könnte noch in der main.cf inet_interfaces verschraubt sein (siehe http://www.postfix.org/BASIC_CONFIGURAT ... interfaces)
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

auszug aus master.cf

Code: Select all

maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
cyrus     unix  -       n       n       -       -       pipe
  user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
procmail  unix  -       n       n       -       -       pipe
  flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}


ich kann mich sicher auch irren, aber muss hier nich auch was von "dovecot" stehen???
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: nix geht *heul*

Post by Joe User »

Code: Select all

postconf -n
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

habe jetzt erstmal setgid_group auf den default "maildrop" anstatt postdrop gestellt.. diese fehlermeldung ist nun weg.. dafür kommt die nächste....

Code: Select all

Jan  7 20:47:24 h1445814 postfix[13656]: fatal: chdir(/usr/libexec/postfix): No such file or directory
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

ausgabe von postconf -n

Code: Select all

allow_percent_hack = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
disable_vrfy_command = yes
home_mailbox = Maildir/
inet_interfaces = xx.xx.xx.xxx, 127.0.0.1
mailbox_size_limit = 102400000
masquerade_exceptions = root
message_size_limit = 20480000
mydestination = $myhostname, $mydomain, localhost
mydomain = meinedomain.de
myhostname = meinedomain.de
mynetworks_style = host
myorigin = $mydomain
setgid_group = maildrop
smtp_bind_address = xx.xx.xx.xx
smtpd_client_restrictions = permit_mynetworks,  permit_sasl_authenticated,  reject_unknown_reverse_client_hostname,  permit
smtpd_data_restrictions = permit_mynetworks,  permit_sasl_authenticated,  reject_unauth_pipelining,  permit
smtpd_delay_reject = yes
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks,  permit_sasl_authenticated,  reject_invalid_helo_hostname,  reject_non_fqdn_helo_hostname,  permit
smtpd_recipient_restrictions = permit_mynetworks,  permit_sasl_authenticated,  reject_invalid_hostname,  reject_non_fqdn_hostname,  reject_non_fqdn_recipient,  reject_unknown_recipient_domain,  check_recipient_mx_access cidr:/etc/postfix/mx_access,  reject_unauth_destination,  check_recipient_access pcre:/etc/postfix/recipient_checks.pcre,  permit
smtpd_sasl_auth_enable = yes
smtpd_sender_restrictions = permit_mynetworks,  permit_sasl_authenticated,  reject_non_fqdn_sender,  reject_unknown_sender_domain,  permit
smtpd_tls_CAfile = /etc/postfix/ssl/demoCA/cacert.pem
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/postfix/ssl/server-crt.pem
smtpd_tls_dh1024_param_file = /etc/postfix/ssl/dh_1024.pem
smtpd_tls_dh512_param_file = /etc/postfix/ssl/dh_512.pem
smtpd_tls_key_file = /etc/postfix/ssl/server-key.pem
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:/var/run/smtpd_tls_session_cache
smtpd_use_tls = yes
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: nix geht *heul*

Post by Joe User »

Bitte folgendes aus der main.cf schmeissen:

Code: Select all

config_directory = /etc/postfix
inet_interfaces = xx.xx.xx.xxx, 127.0.0.1
setgid_group = maildrop
smtp_bind_address = xx.xx.xx.xx

Und hier bitte den FQDN eintragen:

Code: Select all

myhostname = meinedomain.de
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: nix geht *heul*

Post by daemotron »

kolibri250 wrote:ich kann mich sicher auch irren, aber muss hier nich auch was von "dovecot" stehen???

Nein. Dovecot ist ein IMAPv4/POP3-Daemon, der zusätzlich noch einen SASL-Dienst mitbringt. Die master.cf ist die Steuerdatei für Postfix. Postfix ist ein MTA, Dovecot ein MRA. Beide sind gegen beliebige andere MTAs/MRAs austauschbar (die natürlich jeweils anders zu konfigurieren sind und eventuell andere Datenformate für die Postfächer verwenden). Postfix ist (mit Ausnahme von SASL) nicht von Dovecot abhängig, und Dovecot (ohne Ausnahme) nicht von Postfix; beides sind völlig eigenständige Programme mit einer eigenständigen Konfiguration.

P. S. wenn das oben wirklich deine komplette master.cf ist, dann ist sie kaputt (es fehlen die Zeilen für smtp, smtps und ggf. submission)
Last edited by daemotron on 2009-01-07 22:25, edited 1 time in total.
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

diese drei dinge hab ich aufgrund der fehler hier eingebaut!!!

der server lauscht net auf der korrekten ip.. wurde mir gesagt.. also setz ich en inet-interfaces und smtp-bind-address auf meine ip..
setgid_group.. wenn ich das net auf maildrop stehenlasse krieg ich wieder ne fehlermeldung, daß der gruppe "postdrop" nicht kennt!
FQDN ist natürlich die korrekte eingetragen..
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

jfreund wrote:
kolibri250 wrote:ich kann mich sicher auch irren, aber muss hier nich auch was von "dovecot" stehen???

Nein. Dovecot ist ein IMAPv4/POP3-Daemon, der zusätzlich noch einen SASL-Dienst mitbringt. Die master.cf ist die Steuerdatei für Postfix. Postfix ist ein MTA, Dovecot ein MRA. Beide sind gegen beliebige andere MTAs/MRAs austauschbar (die natürlich jeweils anders zu konfigurieren sind und eventuell andere Datenformate für die Postfächer verwenden). Postfix ist (mit Ausnahme von SASL) nicht von Dovecot abhängig, und Dovecot (ohne Ausnahme) nicht von Postfix; beides sind völlig eigenständige Programme mit einer eigenständigen Konfiguration.

P. S. wenn das oben wirklich deine komplette master.cf ist, dann ist sie kaputt (es fehlen die Zeilen für smtp, smtps und ggf. submission)


nein das ist nicht die komplette...
nicht auskommentierter inhalt meiner master.cf:

Code: Select all

smtp      inet  n       -       n       -       -       smtpd
pickup    fifo  n       -       n       60      1       pickup
cleanup   unix  n       -       n       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
rewrite   unix  -       -       n       -       -       trivial-rewrite
bounce    unix  -       -       n       -       0       bounce
defer     unix  -       -       n       -       0       bounce
trace     unix  -       -       n       -       0       bounce
verify    unix  -       -       n       -       1       verify
flush     unix  n       -       n       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       n       -       -       smtp
relay     unix  -       -       n       -       -       smtp
showq     unix  n       -       n       -       -       showq
error     unix  -       -       n       -       -       error
discard   unix  -       -       n       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       n       -       -       lmtp
anvil     unix  -       -       n       -       1       anvil
scache    unix  -       -       n       -       1       scache
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
cyrus     unix  -       n       n       -       -       pipe
  user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
procmail  unix  -       n       n       -       -       pipe
  flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}
retry     unix  -       -       n       -       -       error
Top

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: nix geht *heul*

Post by daemotron »

Noch mal, in Deiner master.cf fehlen folgende Einträge (oder so ähnlich, bitte entsprechend anpassen):

Code: Select all

smtp      inet  n       -       n       -       -       smtpd
submission inet n       -       n       -       -       smtpd
  -o smtpd_tls_security_level=encrypt
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
smtps     inet  n       -       n       -       -       smtpd
  -o smtpd_tls_wrappermode=yes
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_sasl_authenticated,reject

kolibri250 wrote:diese drei dinge hab ich aufgrund der fehler hier eingebaut!!!

Woooozaah! Wir haben Dir hier vorgekaut, womit man das falsche Verhalten von Postfix (lauschen nur auf 127.0.0.1) provozieren kann. Da stand nirgends, dass Du sowas in Deine Konfiguration reinfummeln sollst. Eigentlich war es implizit die Aufforderung, mal nachzusehen, wie diese Dinge bei Dir gesetzt sind...

P. S. OK, jetzt überholen wir uns hier gegenseitig... der (wichtige) smtp-Eintrag ist doch drin (die anderen wären aber ebenfalls nützlich).
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: nix geht *heul*

Post by Joe User »

kolibri250 wrote:der server lauscht net auf der korrekten ip.. wurde mir gesagt.. also setz ich en inet-interfaces und smtp-bind-address auf meine ip..

inet_interfaces ist per Default auf all gesetzt (siehe postconf -d) und smtp_bind_address hat nix mit dem SMTPd zu tun. Ausschlaggebend und richtig ist hier mynetworks_style=host

kolibri250 wrote:setgid_group.. wenn ich das net auf maildrop stehenlasse krieg ich wieder ne fehlermeldung, daß der gruppe "postdrop" nicht kennt!

OK, dann setze es wieder auf maildrop, manche Distris kompilieren manche Pakete halt seltsam...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

bin jezze schon nen grossen schritt weiter.. *lol*

jetzt läuft er wenigstens..
habe den inhalt von /usr/lib/postfix nach /usr/libexec/postfix kopiert..

nur krieg ich ihn net mehr gestoppt..
ein rcpostfix stop oder /etc/init.d/postfix stop bringt mir zwar eine "done" meldung..
jedoch beim nächsten start bekomme ich in mail.err gemeldet:

Jan 7 23:07:20 h1445814 postfix/postfix-script[15768]: fatal: the Postfix mail system is already running


ps aux | grep post sagt:
root 15472 0.0 0.0 43096 2272 ? Ss 22:35 0:00 /usr/libexec/postfix/master
postfix 15479 0.0 0.0 45152 2196 ? S 22:35 0:00 pickup -l -t fifo -u
postfix 15480 0.0 0.0 45196 2328 ? S 22:35 0:00 qmgr -l -t fifo -u
root 15804 0.0 0.0 4184 732 pts/1 S+ 23:07 0:00 grep post


netstat -tulpen:
tcp 0 0 xx.xx.xxx.xx:25 0.0.0.0:* LISTEN 0 502498 15472/master
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 0 502497 15472/master


ich glaub hier stimmt grundsätzlich was nicht.. : ](*,)
hab den prozess 15472 mal von hand gekillt um zu sehen ob der server dann durch rcpostfix start gestartet wird..

/var/log/mail.err sagt nach ausführung rcpostfix start
postfix/postfix-script[15810]: fatal: usage: postfix start (or stop, reload, abort, flush, check, set-permissions, upgrade-configuration)


rcpostfix status sagt "dead"

/etc/init.d/postfix start sagt:
postfix/postfix-script[15908]: fatal: the Postfix mail system is already running
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: nix geht *heul*

Post by Joe User »

kolibri250 wrote:habe den inhalt von /usr/lib/postfix nach /usr/libexec/postfix kopiert..

Fataler Fehler. Beide Verzeichnisse löschen und Postfix reinstallieren.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

Joe User wrote:
kolibri250 wrote:habe den inhalt von /usr/lib/postfix nach /usr/libexec/postfix kopiert..

Fataler Fehler. Beide Verzeichnisse löschen und Postfix reinstallieren.



dann hab ich den selben mist doch wieder...
der installiert per default nach "usr/libexec...." anstatt nach "usr/lib..."
Top

kolibri250
Posts: 37
Joined: 2009-01-03 03:29

Re: nix geht *heul*

Post by kolibri250 »

matzewe01 wrote:du verwemdest doch eine suse distribution oder?


ja korrekt.. hab postfix und dovecot auch übers yast installiert..
Top