apache2 start error!

Apache, Lighttpd, nginx, Cherokee
User avatar
michi
Posts: 56
Joined: 2008-04-24 00:36
Location: Steyr

apache2 start error!

Post by michi » 2008-12-25 12:52

guten tag! erstma fröhliche weihnachten @all! + schöne feiertage!

ich habn kleines problem mit apache2 jetzt! irgendwie lässt sich der nämlich nicht mehr starten!

Code: Select all

Starting web server (apache2)...(98)Address already in use: make_sock: could not bind to address [::]:80
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
 failed!


lsof:

Code: Select all

lsof -i:80
COMMAND  PID USER   FD   TYPE    DEVICE SIZE NODE NAME
apache2 9612 root    3u  IPv6 226837354       TCP *:www (LISTEN)


was kannsn da haben??? system = debian etch... in den apache2 error logs sieht man auch nix!!! danke schonmal für eure hilfe!!! mfg Michi
Last edited by michi on 2008-12-25 13:19, edited 1 time in total.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: apache2 start error!

Post by Joe User » 2008-12-25 13:11

man lsof
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

User avatar
michi
Posts: 56
Joined: 2008-04-24 00:36
Location: Steyr

Re: apache2 start error!

Post by michi » 2008-12-25 13:20

hab scho! hab auch geglaubt das sich da nen 2tes prog auf 80 verschoben hat oder so! aba auch net! hab vor dem clamav installiert, und alles was dazu gehört, die libs und so! und imagemagic auch... mehr hab ich net gemacht!
wenn ich apache versuche zu starten, läuft dann auch nen prozess!

Code: Select all

root      9936 81.7  0.4 127524 17628 ?        Rs   13:21   0:12 /usr/sbin/apache2 -k start

nur beim start sagta ma halt:

Code: Select all

/etc/init.d/apache2 restart
Forcing reload of web server (apache2)...httpd (no pid file) not running
.


komische sache!!!

im error log steht nur das jetzt!

Code: Select all

[Thu Dec 25 12:37:47 2008] [notice] caught SIGTERM, shutting down

User avatar
michi
Posts: 56
Joined: 2008-04-24 00:36
Location: Steyr

Re: apache2 start error!

Post by michi » 2008-12-25 13:53

ok, des macht doch clamav! aba warum! des steht bezüglich dazu in der php.ini:

Code: Select all

extension=clamav.so
[clamav]
clamav.dbpath=/var/lib/clamav
clamav.maxreclevel=0
clamav.maxfiles=0
clamav.archivememlim=0
clamav.maxfilesize=0
clamav.maxratio=0


warum lässt sich dann apache2 net starten wenn ich des modul mitlade???

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: apache2 start error!

Post by Roger Wilco » 2008-12-25 15:04

michi wrote:warum lässt sich dann apache2 net starten wenn ich des modul mitlade???

Vermutlich weil du PHP als Apache-Modul nutzt und die ClamAV-Erweiterung eben inkompatibel zu deiner PHP-Version oder anderweitig kaputt ist.

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: apache2 start error!

Post by EdRoxter » 2008-12-25 15:53

Wozu genau benötigst du denn ClamAV?

User avatar
cpedv
Posts: 15
Joined: 2008-12-25 15:56
Location: Köln

Re: apache2 start error!

Post by cpedv » 2008-12-25 21:53

ClamAV ist ein Virusscanner.
http://de.wikipedia.org/wiki/ClamAV

Durch Eingabe von

Code: Select all

clamscan -r -v --remove /
kann man einen komplett scann des Systems machen und Viren gleich löscht, wenn keine Viren gelöscht werden sollen ohne --remove den Befehl ausführen.

Ich bin zwar nicht der Experte, aber ich glaube nicht das es am ClamAV liegt.

Dein Problem ist das der Apache nicht an Port 80 verbinden kann, hier solltest du mal testen ob dieser schon benutzt wird.

Code: Select all

netstat -lnp |grep ":80" 
oder mit
netstat -lnp


Ich hatte mal so was ähnlichen, da hatte ich einen Update des Apachen gemacht, hier wurde aber nicht die alte Vision überschrieben, sondern eine neu angelegt.

Port 80 wurde dann mit mit dem Update besetzt und mein alter Apache konnte nicht mehr starten und bekam die selbe Fehlermeldung.

Teil2

Code: Select all

/etc/init.d/apache2 restart
Forcing reload of web server (apache2)...httpd (no pid file) not running

Sagt ja das kein Pid in /var/run bzw. /var/run/apache2 angelegt wurde oder existiert, dadurch läuft der Apache nicht.

was machte wenn du nach /etc/init.d/apache2 restart dann /etc/init.d/apache2 start verwendest?

Denn das hatte ich auch mal und nach start oder bei Verwendung von stop und start immer der Pid richtig angelegt worden ist, nur mit restart hatte ich das selbe Problem.

Bei mir waren es aber zwei verschiedene Fälle, beide zusammen hatte ich nicht wie bei dir.

Ich habe dieses Problem aber behoben, da ich auf einen neuen Server gewechselt habe und dadurch die Möglichkeit wahr genommen habe alles neu einzurichten, dadurch habe ich den Fehler nicht mehr gesucht.

gruss Gero

User avatar
michi
Posts: 56
Joined: 2008-04-24 00:36
Location: Steyr

Re: apache2 start error!

Post by michi » 2008-12-26 13:13

sry für sooo späte antwort! ich braucht clamav für das vbulletin plugin "antivir"... da werden alle uploads vom forum (anhänge), mit clamav überprüft, und falls ein virus in einer datei gefunden wird, wird der benutzer gebannt und mir ne mail geschickt! sollte, falls ich clamav mal endlich hinbekomm! danke für eure zahlreichen antworten die werd ich mir jetzt ma durchlesen :D!

doch! ist an clamav gelegen! wegen was weiss ich auch nicht! aba ich denke mal, weil clamav versucht, sich selbst zu updaten, über anscheinend port 80! und dadurch des update script anscheinend mit apache mitstartet, geht keins von beiden! denn wenn ich apache gestartet hab, ist der prozess auch zu sehen gewesen (ps aux)...
deshalb denk ich das roger recht haben könnte! extension=clamav.so was macht des in der php.ini ?!

ohne dem clamav code in der php.ini:

Code: Select all

/etc/init.d/apache2 reload
Reloading web server config...11963
.

also kein probleme mehr! aba clamav läuft auch noch net :(!
Last edited by michi on 2008-12-26 13:20, edited 1 time in total.

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: apache2 start error!

Post by EdRoxter » 2008-12-26 13:18

ClamAV wird sicher nicht mit Source Port 80 versuchen sich zu updaten.

Gib mal bitte die Ausgabe von

Code: Select all

netstat -tulpen

wenn Apache definitiv nicht gestartet ist (also vorher ps aux | grep apache).

User avatar
michi
Posts: 56
Joined: 2008-04-24 00:36
Location: Steyr

Re: apache2 start error!

Post by michi » 2008-12-26 13:22

also soll ich apache ma schliessn und den cmd ausführen?

User avatar
michi
Posts: 56
Joined: 2008-04-24 00:36
Location: Steyr

Re: apache2 start error!

Post by michi » 2008-12-26 14:16

hier ma die ausgabe von netstat -tulpen:

Code: Select all

netstat -tulpen
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       User       Inode      PID/Program name
tcp        0      0 0.0.0.0:51234           0.0.0.0:*               LISTEN     1005       7417       2934/server_linux
tcp        0      0 0.0.0.0:14534           0.0.0.0:*               LISTEN     1005       7416       2934/server_linux
tcp        0      0 88.198.34.118:27015     0.0.0.0:*               LISTEN     1003       207981987  11519/srcds_amd
tcp        0      0 0.0.0.0:3784            0.0.0.0:*               LISTEN     1008       7494       2980/ventrilo_srv
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN     101        6171       2428/mysqld
tcp        0      0 0.0.0.0:61100           0.0.0.0:*               LISTEN     0          6449       2560/pure-ftpd (SER
tcp        0      0 0.0.0.0:4949            0.0.0.0:*               LISTEN     0          6704       2684/munin-node
tcp        0      0 78.47.63.142:53         0.0.0.0:*               LISTEN     107        6082       2345/named
tcp        0      0 78.47.63.141:53         0.0.0.0:*               LISTEN     107        6080       2345/named
tcp        0      0 78.47.63.140:53         0.0.0.0:*               LISTEN     107        6078       2345/named
tcp        0      0 78.47.63.139:53         0.0.0.0:*               LISTEN     107        6076       2345/named
tcp        0      0 78.47.63.138:53         0.0.0.0:*               LISTEN     107        6074       2345/named
tcp        0      0 78.47.63.137:53         0.0.0.0:*               LISTEN     107        6072       2345/named
tcp        0      0 88.198.34.118:53        0.0.0.0:*               LISTEN     107        6070       2345/named
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN     107        6068       2345/named
tcp        0      0 0.0.0.0:15000           0.0.0.0:*               LISTEN     0          169896137  20397/perl
tcp        0      0 127.0.0.1:953           0.0.0.0:*               LISTEN     107        6085       2345/named
tcp6       0      0 :::53                   :::*                    LISTEN     107        6065       2345/named
tcp6       0      0 ::1:953                 :::*                    LISTEN     107        6086       2345/named
udp        0      0 0.0.0.0:32768           0.0.0.0:*                          107        6083       2345/named
udp        0      0 0.0.0.0:20101           0.0.0.0:*                          1005       7414       2934/server_linux
udp        0      0 88.198.34.118:27015     0.0.0.0:*                          1003       207981984  11519/srcds_amd
udp     1840      0 88.198.34.118:27020     0.0.0.0:*                          1003       207981985  11519/srcds_amd
udp        0      0 88.198.34.118:26901     0.0.0.0:*                          1003       207982008  11519/srcds_amd
udp        0      0 0.0.0.0:15000           0.0.0.0:*                          0          169896138  20397/perl
udp     3808      0 0.0.0.0:28960           0.0.0.0:*                          1000       164454270  31454/cod4_lnxded-b
udp     1104      0 0.0.0.0:28961           0.0.0.0:*                          1001       164460369  31508/cod4_lnxded-b
udp     2944      0 0.0.0.0:28962           0.0.0.0:*                          1007       164639361  949/cod4_lnxded-bin
udp      368      0 78.47.63.138:28966      0.0.0.0:*                          1006       164630601  925/cod4_lnxded-bin
udp        0      0 78.47.63.142:53         0.0.0.0:*                          107        6081       2345/named
udp        0      0 78.47.63.141:53         0.0.0.0:*                          107        6079       2345/named
udp        0      0 78.47.63.140:53         0.0.0.0:*                          107        6077       2345/named
udp        0      0 78.47.63.139:53         0.0.0.0:*                          107        6075       2345/named
udp        0      0 78.47.63.138:53         0.0.0.0:*                          107        6073       2345/named
udp        0      0 78.47.63.137:53         0.0.0.0:*                          107        6071       2345/named
udp        0      0 88.198.34.118:53        0.0.0.0:*                          107        6069       2345/named
udp        0      0 127.0.0.1:53            0.0.0.0:*                          107        6067       2345/named
udp        0      0 0.0.0.0:3784            0.0.0.0:*                          1008       7495       2980/ventrilo_srv
udp        0      0 78.47.63.142:123        0.0.0.0:*                          0          6503       2595/ntpd
udp        0      0 78.47.63.141:123        0.0.0.0:*                          0          6502       2595/ntpd
udp        0      0 78.47.63.140:123        0.0.0.0:*                          0          6501       2595/ntpd
udp        0      0 78.47.63.139:123        0.0.0.0:*                          0          6500       2595/ntpd
udp        0      0 78.47.63.138:123        0.0.0.0:*                          0          6499       2595/ntpd
udp        0      0 78.47.63.137:123        0.0.0.0:*                          0          6498       2595/ntpd
udp        0      0 88.198.34.118:123       0.0.0.0:*                          0          6497       2595/ntpd
udp        0      0 127.0.0.1:123           0.0.0.0:*                          0          6496       2595/ntpd
udp        0      0 0.0.0.0:123             0.0.0.0:*                          0          6492       2595/ntpd
udp        0      0 88.198.34.118:27005     0.0.0.0:*                          1003       207981986  11519/srcds_amd
udp6       0      0 :::32769                :::*                               107        6084       2345/named
udp6       0      0 :::53                   :::*                               107        6064       2345/named
udp6       0      0 fe80::21d:92ff:fe63:123 :::*                               0          6495       2595/ntpd
udp6       0      0 ::1:123                 :::*                               0          6494       2595/ntpd
udp6       0      0 :::123                  :::*                               0          6493       2595/ntpd


hilft dir des weiter???
Last edited by michi on 2008-12-29 15:04, edited 1 time in total.

User avatar
michi
Posts: 56
Joined: 2008-04-24 00:36
Location: Steyr

Re: apache2 start error!

Post by michi » 2008-12-27 13:30

nee! ipv4 reicht! warum???

ipng werd ich erst benutzn, wenns ma bisschen mehr ausgereift und nimma soviele probleme mit den nameserver etc macht! aba was hat ipv4 bzw ipv6 mit meinem problem zutun???!

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: apache2 start error!

Post by Roger Wilco » 2008-12-27 19:24

matzewe01 wrote:Ich vermute einfach mal, dass der Port 80 einmal durch das IP6 und einmal durch das IP4 Protokoll belegt wird.

Ich würde mich wirklich wundern, wenn das die Ursache für das Problem wäre. Ich habe hier mehrere Dualstack-Systeme mit IPv4- und IPv6-Konnektivität und ich hatte noch nie irgendwelche Probleme diesbezüglich mit dem Apache httpd.

Ich vermute eher einen Bug bzw. eine Inkompatibilität in der ClamAV-Erweiterung für PHP mit dem laufenden System. Das ließe sich ggf. mit einem Debugger oder einfach strace belegen. Eventuell reicht es auch schon, das Loglevel von PHP und des Apache httpd hochzuschrauben.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: apache2 start error!

Post by Joe User » 2008-12-27 21:17

Sowohl php-clam als auch php-clamavlib werden nicht mehr weiterentwickelt und sollten daher auch nicht mehr produktiv verwendet werden...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: apache2 start error!

Post by Joe User » 2008-12-28 11:33

matzewe01 wrote:
Roger Wilco wrote:
matzewe01 wrote:Ich vermute einfach mal, dass der Port 80 einmal durch das IP6 und einmal durch das IP4 Protokoll belegt wird.

Ich würde mich wirklich wundern, wenn das die Ursache für das Problem wäre. Ich habe hier mehrere Dualstack-Systeme mit IPv4- und IPv6-Konnektivität und ich hatte noch nie irgendwelche Probleme diesbezüglich mit dem Apache httpd.


Dann bindest Du aber an feste Adressen oder?

Nicht nötig, IPv4 und IPv6 stören sich hierbei nicht gegenseitig...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: apache2 start error!

Post by Roger Wilco » 2008-12-28 12:47

matzewe01 wrote:Dann bindest Du aber an feste Adressen oder?

Nein, jeweils an alle. Eben mit einem simplen `Listen 80` und `Listen 443`.
matzewe01 wrote:Ob und in welchem Umfang die Probleme in rüheren Releases bestanden weiss ich nicht. besser gesagt, seit wann dieses Problem bestand.

AFAIR trat das Problem nur auf, wenn z. B. für IPv4 alle Interfaces (also 0.0.0.0) und für IPv6 ein bestimmtes Interface gebunden wurde ("and vice versa").

Beim OP schlug sowohl das binden an [::]:80, als auch 0.0.0.0:80 fehl. Bei dem genannten Bug würde nur eines von beiden fehlschlagen.

User avatar
michi
Posts: 56
Joined: 2008-04-24 00:36
Location: Steyr

Re: apache2 start error!

Post by michi » 2008-12-28 13:29

matzewe01 wrote:Deaktiviere IP6 Support.


wie? wo?

und was soll ich anstatt clamav benutzn???

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: apache2 start error!

Post by Roger Wilco » 2008-12-28 13:59

michi wrote:wie? wo?

http://www.google.de/search?q=debian+etch+disable+ipv6

michi wrote:und was soll ich anstatt clamav benutzn???

Du kannst ClamAV schon benutzen, nur eben nicht die kaputte PHP-Erweiterung.

User avatar
michi
Posts: 56
Joined: 2008-04-24 00:36
Location: Steyr

Re: apache2 start error!

Post by michi » 2008-12-28 21:39

Roger Wilco wrote:
michi wrote:wie? wo?

http://www.google.de/search?q=debian+etch+disable+ipv6

michi wrote:und was soll ich anstatt clamav benutzn???

Du kannst ClamAV schon benutzen, nur eben nicht die kaputte PHP-Erweiterung.

thx
ok gut, das heisst dann, das ich clamav dann eh nimma brauch, weil ohne php-erweiterung kann ich nix anfangen damit!

oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: apache2 start error!

Post by oxygen » 2008-12-29 14:50

Du hast einige Dienste von aussen erreichbar, die du vermutlich nicht brauchst und ein potenzielles Sicherheitsrisiko darstellen. Da solltest du auch überlegen, ob du diese nicht deaktivierst.
Insbesondere meine ich webmin, munin, ntpd. webmin hatte schon einige aus der ferne ausnutzbare root exploits. bind brauchst du zwar wahrscheinlich auch nicht, aber hier ist das Risiko eher gering.
Mir ist zwar klar, dass du teamspeak, ventrilo und die ganzen Gameserver wohl brauchst, aber hier sollte dir klar sein dass diese einige Schwachstellen aufweisen und auch ein Risiko darstellen. Immerhin laufen sie bei dir unter verschiedenen Usern, dass ist schonmal ein Anfang. Optimal wäre aber sicherlich eine chroot Umgebung.

User avatar
michi
Posts: 56
Joined: 2008-04-24 00:36
Location: Steyr

Re: apache2 start error!

Post by michi » 2008-12-29 15:03

oxygen wrote:Du hast einige Dienste von aussen erreichbar, die du vermutlich nicht brauchst und ein potenzielles Sicherheitsrisiko darstellen. Da solltest du auch überlegen, ob du diese nicht deaktivierst.
Insbesondere meine ich webmin, munin, ntpd. webmin hatte schon einige aus der ferne ausnutzbare root exploits. bind brauchst du zwar wahrscheinlich auch nicht, aber hier ist das Risiko eher gering.
Mir ist zwar klar, dass du teamspeak, ventrilo und die ganzen Gameserver wohl brauchst, aber hier sollte dir klar sein dass diese einige Schwachstellen aufweisen und auch ein Risiko darstellen. Immerhin laufen sie bei dir unter verschiedenen Usern, dass ist schonmal ein Anfang. Optimal wäre aber sicherlich eine chroot Umgebung.


webmin läuft nicht immer! nur wenn ichs ma brauche! munin haste recht, wird eig. nimma gebraucht, kann ich deaktivieren! hm und ntp, naja bei mir is halt die uhr immer nachgegangen, somit hab ich ntp installt, jetzt gibts solche probs nimma! ventrilo brauch ich eig. auch nimma! wenn jeder gameserver mit dem gleichen user laufen würde, dann wär des ja ein einziges wirrwarr wo sich dann keiner mehr auskennt, auch beim prozesse killen würds dann schwer werden usw! ich weiss das mein server noch die ein oder andere sicherheitslücke aufweist! erstens läuft keine firewall! da trau ich mich irgendwie net drüber! will mich net selber aussperren! mir gehts auch ziemlich am a**** das sich bei mir sogut wie jeder user über ssh an der console anmelden kann! was ich auch manchmal benötige! zumindest sehr oft für die game-server user, und auch ab und zu mal für web für wget wenn ma grosse datein anfallen! ich hab mir jetzt erstma 3 bücher über debian etch gekauft, die werd ich jetzt ma eins nachn anderen lesn, ich glaub das mich des auch weiter bringen wird, und ich euch dann wegen nub fragen nimma nerven muss :D ! der ssh und ftp port wurden zwar geändert, und der root login gesperrt! nur gibt des auch nur geringen schutz! kann nur besser werden :D!

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: apache2 start error!

Post by Joe User » 2008-12-29 16:18

Der NTPd muss nicht laufen, sondern nur wegen ntpdate installiert sein. Folgender Cronjob reicht völlig für eine zuverlässige Uhrzeit:

Code: Select all

cat > /etc/cron.hourly/ntpdate << "EOF"
#!/bin/sh
/usr/sbin/ntpdate -b -s -p 4 -t 0.1 ptbtime2.ptb.de
EOF
chmod 0755 /etc/cron.hourly/ntpdate
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

EdRoxter
Posts: 483
Joined: 2006-01-06 03:23
Location: Neben Bonn

Re: apache2 start error!

Post by EdRoxter » 2008-12-31 12:36

Wie alt oder neu ist das? Wenn man davon ausgeht, dass die meisten Distris einen Version Freeze für die einzelnen Pakete durchführen, wäre ja bspw. je nach Aktualität diese Aussage auf das ausgeschiffte ntp-Paket nicht zwingend zutreffend. Debian Etch ist ja jetzt auch schon wieder 200 Jahre alt... ;)

oxygen
Posts: 2138
Joined: 2002-12-15 00:10
Location: Bergheim

Re: apache2 start error!

Post by oxygen » 2008-12-31 15:19

matzewe01 wrote:Übrigens: Es ist ziemelich egal, wie alt Deine Distribution ist, wenn Du mit anderen Diensten zuverlässig Kommunizieren möchtest, musst Du halt aktuell bleiben und Änderungen aktzeptieren. Insbesondere, wenn ein Dienst nicht mehr angeboten werden soll.

Das ist natürlich grundsätzlich richtig, aber in diesem Fall nicht zutreffend. Es geht bei dieser Änderung nur darum, dass das ntpd team nicht mehr zwei verschiedene Programme pflegen will. Das fette Warning ist also etwas übertrieben. Hinter dem genannten Link sind die Aussagen schon etwas gemäßigter.
"The combination of ntpd and sntp now implements the functions of ntpdate. As soon as a few remaining issues with sntp are resolved the ntpdate program will be retired."
Es besteht als kein Grund zur Annahme, dass die Nutzung von ntpdate in nächster Zeit irgendwelche Probleme mit sich bringt.

User avatar
michi
Posts: 56
Joined: 2008-04-24 00:36
Location: Steyr

Re: apache2 start error!

Post by michi » 2009-01-01 16:18

nochma zurück zur chroot umgebung. ich hab mir des jetzt alles durchgelesen von dem link. da gibts 2 möglichkeiten! erstens entweder benutzer einsperren, oder zweitens den gesamten ssh server einsperren. jede möglichkeit hat ihre vor und nachteile! zb. ist man bei 2. gegen exploits gesichert soviel ich da gelesen hab, aba bei der ersten möglichkeit nicht. dafür kann man halt bei der ersten variante jedem benutzer sein eigenes gefängnis basteln! ich weiss, ich sollte das auswählen, des mir am meisten passt. aba da bin ich mir eben net sicher... auf meinem server gibts nur mich! weder für ftp noch für ssh hat jemand anders zugang! ich weiss net, ob das von bedeutung ist, die erste variante auszuschliessen?! könnt ihr mir da bitte ma nen rat geben?