XeN 3.3 auf Debian-Lenny

VirtualBox, VMWare, KVM, XEN, OpenVZ, Virtuozzo, etc.
sledge0303
RSAC
Posts: 767
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

XeN 3.3 auf Debian-Lenny

Post by sledge0303 » 2008-11-30 17:21

Hallo Leutz,

bin jetzt in Sachen Debian etwas raus aus der Materie seit Umstieg auf Gentoo. Hab Lenny (unstable) aufgesetzt und aus den Sourcen XeN 3.3 gebastelt.
Anhand erster Tests läuft alles super, wirkt weder langsam noch instabil, doch ist mir folgendes aufgefallen:

Code: Select all

dmesg
...
...
  ***************************************************************
  ***************************************************************
  ** WARNING: Currently emulating unsupported memory accesses  **
  **          in /lib/tls glibc libraries. The emulation is    **
  **          slow. To ensure full performance you should      **
  **          install a 'xen-friendly' (nosegneg) version of   **
  **          the library, or disable tls support by executing **
  **          the following as root:                           **
  **          mv /lib/tls /lib/tls.disabled                    **
  ** Offending process: modprobe (pid=1082)                    **
  ***************************************************************
  ***************************************************************
...
...


/lib/tls kann ich nicht verschieben/umbenennen ==> gibt es nicht
Das Paket libc6-xen ist installiert und entsprechend konfiguriert

Code: Select all

cat /etc/ld.so.conf.d/libc6-xen.conf

hwcap 1 nosegneg


Meine Frage an Euch wäre, hat jemand XeN aus den Lenny-Paketen installiert, erscheint die selbe Meldung bei dmesg und läuft Xen stabil?
Ich schreibe gerade ein Wunsch-Howto XeN 3.3 unter Debian Lenny und würde gerne Fehler vermeiden, deswegen sind Infos wichtig bzw. Hinweise auf irgendwelche Auffälligkeiten die Ihr festgestellt habt im laufenden Betrieb...

...nebenbei erwähnt: XeN und Gentoo RULEZ, yeahhh :D

f4rr3ll
Posts: 36
Joined: 2008-03-09 23:36
Location: Schweitenkirchen

Re: XeN 3.3 auf Debian-Lenny

Post by f4rr3ll » 2008-12-03 02:22

Ich schreibe gerade ein Wunsch-Howto XeN 3.3 unter Debian Lenny und würde gerne Fehler vermeiden,


Sledge das finde ich geil .... extra für mich fragste rum ;)

Kann zwar nicht konstruktiv zu dem Thema schrieben, aber nen dickes Danke an deine Arbeit .

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: XeN 3.3 auf Debian-Lenny

Post by daemotron » 2008-12-03 12:53

Arbeitst Du mir i368 oder mit amd64? Bei der 32-Bit-Variante musste man AFAIR Gewalt anwenden und die Glibc mit -mno-tls-direct-seg-refs kompilieren. Wenn das in den Spec-Files für Lenny nicht drin ist, hat Houston wohl ein Problem...

sledge0303
RSAC
Posts: 767
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: XeN 3.3 auf Debian-Lenny

Post by sledge0303 » 2008-12-03 23:29

jfreund wrote:Arbeitst Du mir i368 oder mit amd64? Bei der 32-Bit-Variante musste man AFAIR Gewalt anwenden und die Glibc mit -mno-tls-direct-seg-refs kompilieren. Wenn das in den Spec-Files für Lenny nicht drin ist, hat Houston wohl ein Problem...


Moin,

denke mal das Houston ein Problem hat...32 Bit Variante. Was den technischen Ablauf angeht, hab mal ein paar Hard-Core Benchmarks laufen lassen, von der Performance domU sowie dom0 keine Probleme offensichtlich - jedenfalls nicht auf dem ersten Blick erkennbar. Jedenfalls wäre das Tutorial nach jetzigem Stand der Dinge für den produktiven Einsatz ungeeignet, bzw. sollte im produktiven Bereich stets argwöhnisch im Auge behalten werden.

@F4RR3LL

Jein, nicht (alleine) wegen dir, es laufen noch andere Projekte in meinem Bereich, wo die Frage XeN+Lenny mal kommen könnte... wie du weisst, ich bastel ja soooo gerne in meiner Freizeit :D
Jedenfalls wird Gentoo never-ever again durch Debian ersetzt werden...

User avatar
Joe User
Project Manager
Project Manager
Posts: 11580
Joined: 2003-02-27 01:00
Location: Hamburg

Re: XeN 3.3 auf Debian-Lenny

Post by Joe User » 2008-12-04 11:20

<OT>
sledge0303 wrote:Jedenfalls wird Gentoo never-ever again durch Debian ersetzt werden...

/me: Und wieder jemanden langfristig überzeugt ;)
</OT>
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

thorsten
RSAC
Posts: 732
Joined: 2003-02-01 13:14
Location: Fuldatal

Re: XeN 3.3 auf Debian-Lenny

Post by thorsten » 2008-12-04 14:05

Muss es denn Xen 3.3 sein?
Seit wenigen Wochen sind die dom0 OpenSuse Patche in lenny und xen 3.2 läuft dort einwandfrei...

(Meine beiden debian/sarge dom0 mit 2.6.16.20 und 2.6.16.27 laufen seit Mai 2006 problemlos mit xen 3.0 ...)

sledge0303
RSAC
Posts: 767
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: XeN 3.3 auf Debian-Lenny

Post by sledge0303 » 2008-12-05 12:56

Thorsten wrote:Muss es denn Xen 3.3 sein?
Seit wenigen Wochen sind die dom0 OpenSuse Patche in lenny und xen 3.2 läuft dort einwandfrei...

(Meine beiden debian/sarge dom0 mit 2.6.16.20 und 2.6.16.27 laufen seit Mai 2006 problemlos mit xen 3.0 ...)


Hmmm, muss mir mal die Pakete aus Lenny anschauen.

thorsten
RSAC
Posts: 732
Joined: 2003-02-01 13:14
Location: Fuldatal

Re: XeN 3.3 auf Debian-Lenny

Post by thorsten » 2008-12-06 00:50

Mach das mal, läuft schmerzfrei quasi out-of-the-box.
Bei einer Testinstallation mit 3 NICs wollte ich eth1 anstelle von eth0 für die dom0 verwenden. Mit ein wenig (dokumentierter) Handarbeit war das möglich.

Achja: Wenn du die xentools einsetzt, benutze --role=udev und schau, dass du console=xvc0 über die xm.tmpl in die $SERVERNAME.cfg bekommst.
Näheres gerne per PN.