Xen 3.3, Gentoo 2008 dom0, Bug, Feature oder falsche Konfig? ...

VirtualBox, VMWare, KVM, XEN, OpenVZ, Virtuozzo, etc.
sledge0303
RSAC
Posts: 767
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Xen 3.3, Gentoo 2008 dom0, Bug, Feature oder falsche Konfig? ...

Post by sledge0303 » 2008-10-26 12:53

Hallo Leute,

ich hab jetzt alle dom0 Maschinen von Debian auf Gentoo migriert. Die Kisten rennen 1A, alles funktioniert wie gewünscht. Soweit alles OK und kein Problem. Das einzigste was ich feststellen musste ist die Tatsache, nach einem Reboot des Wirtsystems werden die domU nicht mehr automatisch gestartet...
d.h. jede domU muss nach einem reboot manuell per "xm create -c ..." gestartet werden.

Die Konfiguration sieht folgendermaßen aus:

Code: Select all

ls -la /etc/xen/auto/
insgesamt 8
drwxr-xr-x 2 root root 4096 24. Okt 23:57 .
drwxr-xr-x 4 root root 4096 26. Okt 11:25 ..
-rw-r--r-- 1 root root    0 22. Okt 09:19 .keep_app-emulation_xen-tools-0
lrwxrwxrwx 1 xen xen   17 22. Okt 11:59 mail.sxp -> /etc/xen/mail.sxp
lrwxrwxrwx 1 xen xen  17 24. Okt 23:57 web.sxp -> /etc/xen/web.sxp


Die domU wird wie folgt hochgefahren

Code: Select all

cat /etc/xen/mail.sxp
name="Mailserver"
kernel="/boot/vmlinuz-2.6.18-xenU"
root="/dev/sda1"
memory=512
maxmem=1024
disk = ['phy:/dev/xenlvm/mail,sda1,w','phy:/dev/xenlvm/mail-swap,sda2,w']

vif=[ 'ip=10.0.0.10' ]
hostname="Mailserver"
ip="10.0.0.10"
netmask="255.0.0.0"
gateway="10.0.0.254"
on_poweroff = 'destroy'
on_reboot   = 'restart'
on_crash    = 'restart'

extra="console=xvc0 xencons=tty"


Netzwerk: NAT, wie man unschwer erkennen kann ;)

xend ist wie folgt konfiguriert

Code: Select all

cat xend-config.sxp
# -*- sh -*-

(xend-relocation-server yes)
(xend-relocation-hosts-allow '^localhost$ ^localhost\.localdomain$')
(network-script network-nat)
(vif-script     vif-nat)
(dom0-min-mem 128)
(enable-dom0-ballooning yes)
(dom0-cpus 0)
(vncpasswd '')


Last but not least, die Versionsnummer:

Code: Select all

Xen 3.3.0 auf Gentoo 2008


Hat einer von Euch selbst XeN auf Gentoo installiert, bzw Version 3.3 auf einem anderen OS, stellt exakt die selben Probleme fest?

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Xen 3.3, Gentoo 2008 dom0, Bug, Feature oder falsche Konfig? ...

Post by oxygen » 2008-10-26 16:45

Code: Select all

# rc-update add xendomains default

sledge0303
RSAC
Posts: 767
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: Xen 3.3, Gentoo 2008 dom0, Bug, Feature oder falsche Konfig? ...

Post by sledge0303 » 2008-10-26 19:59

Arfffffffffffffffff.... das war es ](*,)

Vielen Dank für den Tipp