Mysql Server startet nicht

derfahnder
Posts: 4
Joined: 2008-10-21 20:43

Mysql Server startet nicht

Post by derfahnder »

Hallo,

ich habe einen VServer bei Strato und dort frisch Debian 4.0 installiert.
Jetzt wollte ich mir einen Apache und Mysql5 draufmachen und stelle fest, dass selbst wenn alle Dienste unten sind Mysql nicht gestartet werden kann mit folgender Fehlermeldung:

cut: error while loading shared libraries: libc.so.6: failed to map segment from shared object: Cannot allocate memory
. . . . . . . . . . . . . . failed!

Das kanns ja wohl nicht sein oder? Weiß einer, was man da machen kann? Ich hab schon gegoogelt aber nur Sachen gefunden, dass der RAM bei laufendem Server knapp wird, aber nicht dass der Server nicht mal hochkommt :(

top sagt das:

1 root 16 0 1868 660 564 S 0 0.0 0:00.02 init
24452 root 16 0 1556 572 456 S 0 0.0 0:00.10 syslogd
25795 root 15 0 8752 944 720 S 0 0.0 0:00.05 nscd
25820 root 16 0 4948 1084 784 S 0 0.1 0:00.00 sshd
25843 root 16 0 2136 708 568 S 0 0.0 0:00.00 cron
25961 root 16 0 8412 2332 1892 S 0 0.1 0:00.50 sshd
25964 root 15 0 4036 1652 1324 S 0 0.1 0:00.21 bash
5206 root 15 0 2160 848 688 R 0 0.0 0:00.00 top


meminfo:
MemTotal: 2068296 kB
MemFree: 40104 kB
Buffers: 150984 kB
Cached: 774876 kB
SwapCached: 0 kB
Active: 1289428 kB
Inactive: 416684 kB
HighTotal: 0 kB
HighFree: 0 kB
LowTotal: 2068296 kB
LowFree: 40104 kB
SwapTotal: 3068392 kB
SwapFree: 3067528 kB
Dirty: 128 kB
Writeback: 0 kB
Mapped: 915880 kB
Slab: 290684 kB
CommitLimit: 4102540 kB
Committed_AS: 2863964 kB
PageTables: 11856 kB
VmallocTotal: 2039800 kB
VmallocUsed: 9324 kB
VmallocChunk: 2030416 kB

edit: vzfree:

./vzfree
VPS Speichernutzung:
Momentan genutzt: 14,1641 MB
Maximal genutzt: 15,2852 MB
Zugesichert: 259,375 MB
Maximal nutzbar: 791,281 MB
Top

derfahnder
Posts: 4
Joined: 2008-10-21 20:43

Re: Mysql Server startet nicht

Post by derfahnder »

Da hab ich schon einige Werte recht planlos geändert von 16M auf 1M x_X

Code: Select all

#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port      = 3306
socket      = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket      = /var/run/mysqld/mysqld.sock
nice      = 0

[mysqld]
#
# * Basic Settings
#
user      = mysql
pid-file   = /var/run/mysqld/mysqld.pid
socket      = /var/run/mysqld/mysqld.sock
port      = 3306
basedir      = /usr
datadir      = /var/lib/mysql
tmpdir      = /tmp
language   = /usr/share/mysql/english
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address      = 127.0.0.1
#
# * Fine Tuning
#
key_buffer      = 1M
max_allowed_packet   = 1M
thread_stack      = 128K
thread_cache_size   = 8
max_connections        = 10
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit       = 1M
query_cache_size        = 1M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log      = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log_slow_queries   = /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
#server-id      = 1
log_bin         = /var/log/mysql/mysql-bin.log
# WARNING: Using expire_logs_days without bin_log crashes the server! See README.Debian!
expire_logs_days   = 1
max_binlog_size         = 10M
#binlog_do_db      = include_database_name
#binlog_ignore_db   = include_database_name
#
# * BerkeleyDB
#
# Using BerkeleyDB is now discouraged as its support will cease in 5.1.12.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
# You might want to disable InnoDB to shrink the mysqld process by circa 100MB.
#skip-innodb
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet   = 1M

[mysql]
#no-auto-rehash   # faster start of mysql but no tab completition

[isamchk]
key_buffer      = 1M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the NDB Data Nodes (ndbd processes)
# not from the NDB Management Nodes (ndb_mgmd processes).
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1


#
# * IMPORTANT: Additional settings that can override those from this file!
#
!includedir /etc/mysql/conf.d/


Top

derfahnder
Posts: 4
Joined: 2008-10-21 20:43

Re: Mysql Server startet nicht

Post by derfahnder »

Problem gelöst, innodb abgestellt und schon fluppts :)
Top

derfahnder
Posts: 4
Joined: 2008-10-21 20:43

Re: Mysql Server startet nicht

Post by derfahnder »

matzewe01 wrote:Dann gebe Ich Dir mal eine passende nicht planlos veränderte Konfiguration für einen vserver.
bzw. auf einem Vserver im Einsatz.

Binlog ist beabsichtigt?
Zudem war die server-id nicht gesetzt.
Prüfe nochmals die Pfade.


Hi,

danke für die schnelle Hilfe.
Die Server-Id habe ich nun gesetzt und binlog deaktiviert. Welche Pfade meinst Du muss ich noch überprüfen?

Grüße,

Benjamin
Top