Problem bei Amavis-New in Squirrelmail

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
erdferkel
Posts: 8
Joined: 2008-10-05 15:54

Problem bei Amavis-New in Squirrelmail

Post by erdferkel » 2008-10-08 12:50

Hallo zusammen,

ich habe folgendes Problem, dass ich nicht gelöst bekomme: im Apache-Error-Log steht ständig diese Meldung drin:

Code: Select all

[Wed Oct 08 12:43:01 2008] [error] [client 123.123.123.123] PHP Warning:  include_once(DB.php): failed to open stream: Datei oder Verzeichnis nicht gefunden in /srv/www/htdocs/web0/html/squirrelmail/plugins/amavisnewsql/amavisnewsql.class.php on line 14, referer: https://web0.Blub.Blah.net/squirrelmail/src/webmail.php
[Wed Oct 08 12:43:01 2008] [error] [client 123.123.123.123] PHP Warning:  include_once(): Failed opening 'DB.php' for inclusion (include_path='.') in /srv/www/htdocs/web0/html/squirrelmail/plugins/amavisnewsql/amavisnewsql.class.php on line 14, referer: https://web0.Blub.Blah.net/squirrelmail/src/webmail.php
[Wed Oct 08 12:43:01 2008] [error] [client 123.123.123.123] PHP Fatal error:  Class 'DB' not found in /srv/www/htdocs/web0/html/squirrelmail/plugins/amavisnewsql/amavisnewsql.class.php on line 1080, referer: https://web0.Blub.Blah.net/squirrelmail/src/webmail.php


Meine Konfiguration:
Suse 10.2, Confixx 3, Postfix, Amavis-New, Spamassasin, courier-imap und eben als Frontend für Webmail: squirrelmail mit dem
AddOn "AmavisNewSQL".

Kann mir jemand weiterhelfen?

Vielen Dank im voraus und viele Grüße,

's Erdferkelchen

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Problem bei Amavis-New in Squirrelmail

Post by Joe User » 2008-10-08 15:40

Das AddOn passt nicht zu der SM Version...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

erdferkel
Posts: 8
Joined: 2008-10-05 15:54

Re: Problem bei Amavis-New in Squirrelmail

Post by erdferkel » 2008-10-08 15:56

Danke für die flinke Antwort. Ich habe die SM Version 1.4.16 und die AmavisNewSQL Version 0.8.0.
Sollte doch eigentlich passen, oder? Eine neuere Version von AmavisNewSQL gibt's leider nicht :-(

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Problem bei Amavis-New in Squirrelmail

Post by Roger Wilco » 2008-10-08 21:10

erdferkel wrote:

Code: Select all

[Wed Oct 08 12:43:01 2008] [error] [client 123.123.123.123] PHP Warning:  include_once(DB.php): failed to open stream: Datei oder Verzeichnis nicht gefunden in /srv/www/htdocs/web0/html/squirrelmail/plugins/amavisnewsql/amavisnewsql.class.php on line 14, referer: https://web0.Blub.Blah.net/squirrelmail/src/webmail.php

PEAR::DB ist auf deinem System nicht installiert. Hole das mit deinem Paketmanager oder "pear" nach und sorge dafür, dass deine PHP-Installation die Dateien auch findet und einbinden darf.

erdferkel
Posts: 8
Joined: 2008-10-05 15:54

Re: Problem bei Amavis-New in Squirrelmail

Post by erdferkel » 2008-10-08 22:48

Danke Dir. Nun kommt zwar keine Fehlermeldung mehr, aber trotzdem kann ich die Spamassassin-Settins
in Squirrelmail noch nicht öffnen. Es kommt schlicht eine weiße Seite... :-(
Wat iss'n da noch im argen?

---

Zudem habe ich noch ich in der configtest.php die Fehlermeldung:

Code: Select all

Checking paths...
ERROR: Data dir () does not exist!


In meine config.php von Squirrelmail steht aber eindeutig:

Code: Select all

$data_dir                 = SM_PATH . 'data/';
$attachment_dir           = "$data_dir/attach/";


Wobei es egal ist, ob ich den kompletten Pfad angebe oder mit SM_PATH.

Any idea?

erdferkel
Posts: 8
Joined: 2008-10-05 15:54

Re: Problem bei Amavis-New in Squirrelmail

Post by erdferkel » 2008-10-09 15:41

Also inzwischen scheint Squirrelmail auch meine Path-Angaben zu akzeptieren (jedenfalls laut configtest.php). Es geschehen noch Zeiten und Wunder ;-)
Trotzdem kann ich immer noch keine Spam-Settings vornehmen, da die weiße Seite immer noch kommt, wenn ich in Squirrelmail unter
"Optionen" => "Spamassassin Configuration" anklicke.

Der einzig brauchbare Eintrag im error_log von apache lautet:

Code: Select all

[Thu Oct 09 15:34:17 2008] [error] [client 123.123.123.123] PHP Notice:  Undefined variable: user in /srv/www/htdocs/web0/html/squirrelmail/src/redirect.php on line 108, referer: https://web0.Blubl.Blah.net/squirrelmail/src/login.php


Im mail_log steht nichts drin. Kann mir da jemand weiterhelfen?

Danke Euch.

[-o< Ich will doch nur meine Spam-Settings ändern... [-o<