Problem: Mails werden doppelt verschickt

Anonymous

Problem: Mails werden doppelt verschickt

Post by Anonymous »

Hallo,
ich bin noch Server- Neuling und möchte mich nach und nach in die „Servermaterie“ einarbeiten. Dazu habe ich einen vServer mit Suse 10.3 und Plesk 8.6 und ein Problem :D

Zu meiner Konfiguration:
.qmail ruft .procmailrc zwecks Spamassassin- Filerung auf:

| true
| preline /usr/bin/procmail -m .procmailrc
# | /usr/bin/deliverquota ./Maildir

Das Zusammenspiel von qmail, procmail und spamassassin funktioniert prinzipiell auch sehr gut. Mails werden korrekt markiert und gefiltert. Also laufen wohl qmail, procmail und spamassassin ordnungsgemäß auf dem Server, da sämtliche Mails im Header wie vorgesehen markiert werden.

Soweit, so gut. Jetzt zu meinem Problem:

Per Zufall habe ich heute folgendes festgestellt: Ist in Outlook Express bzw. Windows Mail in den Kontoeinstellungen die Option „Kopie aller Nachrichten auf dem Server belassen“ aktiviert, empfange ich sämtliche Mails zweimal, allerdings nicht sofort beim ersten Abrufen, sondern einmal beim ersten Abrufen und das zweite Mal erst beim zweiten Abrufen.
Ich bin jetzt schon soweit gekommen, dass ich folgendes herausgefunden habe:

1. Ich verschicke eine Testmail an mich (das Problem tritt aber auch auf, wenn ich von extern Mails bekomme). „Kopie aller Nachrichten auf dem Server belassen“ ist dabei aktiviert.
2. Die Mail landet z. B. als „msg.SToy“ auf dem Server im Pfad /var/qmail/mailnames/domain.de/kontakt/Maildir/cur
3. Nun rufe ich mit Windows Mail die Mailbox auf und ich erhalte die zugeschickte Mail (1x).
4. Auf dem Server wurde nun die Mail „msg.SToy“ umbenannt in „msg.SToy:2,S“. Dies scheint ja wohl so eine Art Lesemarkierung zu sein.
5. Ich rufe mit Windows Mail die Mailbox erneut auf und erhalte die Mail zum 2. Mal.
6. Die Mail bleibt als „msg.SToy:2,S“ auf dem Server erhalten, da ja im E-Mail-Programm die Option „Kopie aller Nachrichten auf dem Server belassen“ aktiviert ist.
7. Nochmal rufe ich die Mailbox auf und bekomme diese Mail nicht mehr.

Irgendwie kommt es mir so vor, dass durch die Umbenennung der Mail mein Mailprogramm diese Mail als neue Mail einstuft und deshalb nochmal empfängt. Daneben vermute ich (bin mir aber überhaupt nicht sicher, ob das der Grund ist), dass dieses Problem mit procmail zusammenhängt. Als Test habe ich den Aufruf von procmail in der .qmail mal entfernt und die Standard- .qmail verwendet. Hierbei kommt es nicht zu dem oben genannten Fehlverhalten.

Über eure Hilfe bin ich äußerst dankbar, zumal ich schon das Internet erfolglos „abgegrast“ habe.
Viele Grüße
Henning
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Problem: Mails werden doppelt verschickt

Post by Roger Wilco »

Top