Bayes-Filter hat plötzlich schlechte Erkennungsrate

Anonymous

Bayes-Filter hat plötzlich schlechte Erkennungsrate

Post by Anonymous »

Hallo,

ich setze Spamassassin mit Bayes-Filter ein. Der Bayes-Filter hat bisher super gelernt und fast alle Spams erkannt. Seit gestern sieht das anders aus. Die Spam werden wenn überhaupt nur noch mit einer geringen Wahrscheinlichkeit (unter 40%) bewertet oder gar mit 0%. Auch das Verarbeiten solcher nicht erkannten Spams mit sa-learn andert bisher nichts an dem Problem.

Hat jemand änlich Erfahrungen oder kann mir Tipps zur Problembehebung geben? Hilft es Vielleicht die Bayes-DB neu aufzubauen?

Vielen Dank.
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Bayes-Filter hat plötzlich schlechte Erkennungsrate

Post by Roger Wilco »

Vielleicht hast du den Bayesfilter einfach "überfüttert". Teilweise verschlechtert sich die Erkennungsrate massiv, wenn zu viele uneindeutige Tokens in der Datenbank liegen.

Eventuell hilft es, wenn du veraltete Tokens aus der Datenbank löschst, siehe http://wiki.apache.org/spamassassin/BayesForceExpire.
Top

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Bayes-Filter hat plötzlich schlechte Erkennungsrate

Post by oxygen »

Das klang jetzt so als handelte es sich um eine plötzliche Verschlechterung? Das klingt eigentlich nicht nach einer übersättigen Datenbank sondern eher nach einer leeren oder beschädigten Datenbank. Zum Vergleich mal die Werte meiner Bayes Datenbank:

Code: Select all

# ls /var/amavis/.spamassassin/ -lh
total 39M
-rw------- 1 amavis amavis  21M Aug 23 16:14 auto-whitelist
-rw------- 1 amavis amavis  86K Aug 23 16:14 bayes_journal
-rw------- 1 amavis amavis  20M Aug 23 16:14 bayes_seen
-rw------- 1 amavis amavis 5.1M Aug 23 16:14 bayes_toks
Top