defekte C Funktion nach Serverumzug

Serverdienste ohne eigene Kategorie
boo
Posts: 3
Joined: 2008-08-22 13:20

defekte C Funktion nach Serverumzug

Post by boo »

hey leute wir sind mit drownedworld.de umgezogen auf einen neuen server.... vor nem jahr schonmal und kurz davor schonmal und immer hat alles geklappt aber seit dem letzten umzug funzt die funktion für die avatare nicht mehr...

Code: Select all

138 if( ( file = fopen( fname, "wb" ) ) )
139 {
140 fwrite( avatar, 1, filesize, file );
141 fclose( file );
142 sprintf( fname, "/upic%d", id );
143 iohttpFileDel( fname );
144 if( ( cfile = iohttpFileAdd( filesize ) ) )
145 {
146 cfile->type = 0;
147 cfile->mime = b;
148 dbMaind[id].picmime = b;
149 sprintf( cfile->path, "/upic%d", id );
150 memcpy( cfile->data, avatar, filesize );
151 svSendString( cnt, "<i>"LNG_AVATAR_OK"</i><br><br>" );
152 }
153 }
naja so siehts aus... haben mehrere welten und nur an einer weiter gearbeitet und es geht bei anderen welten auch nicht also nirgends......... falls wer zocken will lemuria ist als einzige aktiv zur zeit :P hoffe irgendwer hat nen plan was bei einem neuen server da falsch laufen könnte... wobei mein informatiker kollege meint es macht keinen sinn :twisted:

Roger Wilco
Administrator
Administrator
Posts: 5923
Joined: 2004-05-23 12:53

Re: defekte C Funktion nach Serverumzug

Post by Roger Wilco »

Glaubst du ernsthaft, dass wir bei dem hingerotzten Codeschnipsel ohne Kontext und der unheimlich ausführlichen Fehlerbeschreibung auch nur ansatzweise helfen können?

boo
Posts: 3
Joined: 2008-08-22 13:20

Re: defekte C Funktion nach Serverumzug

Post by boo »

da wir am source 0 geändert haben also an den funktionen ... ja

es geht nur um so grundsätzliche sachen wie plugins oder was auch immer die vielleicht nötig sind damit der server den code der da steht ordentlich verarbeiten kann oder sowas

nachtrag: die funktion erstellt nut 0 byte dateien statt wie vorher die bilder ordentlich einzusetzen!

Roger Wilco
Administrator
Administrator
Posts: 5923
Joined: 2004-05-23 12:53

Re: defekte C Funktion nach Serverumzug

Post by Roger Wilco »

Boo wrote:da wir am source 0 geändert haben also an den funktionen ... ja
Wenn es selbstgeschriebene Software ist müsstet ihr euch selbst helfen können. Wenn es Software eines Drittherstellers ist, fragt den.
Boo wrote:es geht nur um so grundsätzliche sachen wie plugins oder was auch immer die vielleicht nötig sind damit der server den code der da steht ordentlich verarbeiten kann oder sowas
Wie gesagt, keine Infos zum Setup, Fehler usw., keine Hilfe.

boo
Posts: 3
Joined: 2008-08-22 13:20

Re: defekte C Funktion nach Serverumzug

Post by boo »

problem behoben.

der pfad war nur bis 16 zeichen ausgelegt... bleibt zwar die frage wieso es jemals funktioniert hat...... aber wenigstens jetzt nun :D

danke