SSH Problem

Serverdienste ohne eigene Kategorie
avu4m9
Posts: 20
Joined: 2008-07-29 00:00

SSH Problem

Post by avu4m9 »

Hallo.
Ich habe einen Dezidierten Server von Hetzner.
Seid gestern kann ich mich nicht mehr via SSH einloggen.
Auch der FTP Server antwortet nicht.
Folgender Fehler wir mir bei einem SSH Login versuch ausgegeben: ssh: connect to host meineDomain.TLD
Ich kann mich erinnern, dass ich die Datei /etc/hosts verändert habe.
Ich habe sie wiederhergestellt. Leider Erfolglos.
Ist es möglich über die Rescue Konsole von Hetzner, SSH neu zu installieren??
Danke für die Hilfe.

MfG
AVU4m9

User avatar
daemotron
Administrator
Administrator
Posts: 2636
Joined: 2004-01-21 17:44

Re: SSH Problem

Post by daemotron »

Das ist doch keine Windows-Kiste, wo man einfach mal ein Programm neu installiert, wenn es nicht so will wie man selbst. Du solltest erst mal ein paar Augenblicke in die Diagnose investieren. Ist der Server generell noch per Netzwerk zu erreichen (ping, traceroute)? Läuft ein Paketfilter? Was fördert ein Portscan (z. B. mit nmap) auf Port 22 zutage? Löst Dein Rechner die IP korrekt auf (dig dein.hostname.tld) bzw. funktioniert es, wenn Du direkt die IP verwendest?

Das Rettungssystem kannst Du nutzen, um einen Snapshot vom System zu machen. Nach Deiner Fehlerbeschreibung ist vieles möglich, auch, dass Du nicht (mehr) der einzige root auf Deinem Server bist...

avu4m9
Posts: 20
Joined: 2008-07-29 00:00

Re: SSH Problem

Post by avu4m9 »

Ja der Server ist über den Port 80 sowie Port 25 (Postfix) und MySQL erreichbar.
Ein Paketfilter läuft meines wissens nicht.
Über die IP ist der Server auch ganz normal erreichbar.
Es gibt lediglich bei Port 22 und 21 Probleme.

nMap ergibt folgendes:

Code: Select all

 nmap -sT mei.ne.IP

Starting Nmap 4.53 ( http://insecure.org ) at 2008-08-11 13:48 CEST
Interesting ports on mei.ne.IP:
Not shown: 1704 closed ports
PORT      STATE    SERVICE
21/tcp    open     ftp
25/tcp    open     smtp
80/tcp    open     http
110/tcp   open     pop3
143/tcp   open     imap
445/tcp   filtered microsoft-ds
993/tcp   open     imaps
995/tcp   open     pop3s
6667/tcp  filtered irc
10000/tcp open     snet-sensor-mgmt

Nmap done: 1 IP address (1 host up) scanned in 16.000 seconds
MfG
AVU4m9

User avatar
daemotron
Administrator
Administrator
Posts: 2636
Joined: 2004-01-21 17:44

Re: SSH Problem

Post by daemotron »

OK, Dein sshd läuft nicht oder auf Deinem Server läuft ein Paketfilter, der dropt. Und was läuft da bei Dir auf Port 10000? Ist das gewollt?

Du kannst so wirklich nur noch ins Rettungssystem booten und Dir die Logs anschauen, warum der sshd nicht läuft - oder alternativ beim Support nach einer LARA fragen (stellt H. kostenlos zur Verfügung). Welche Distribution nutzt Du denn?

avu4m9
Posts: 20
Joined: 2008-07-29 00:00

Re: SSH Problem

Post by avu4m9 »

Hmm...
Joa Logs wäre noch ne Lösung.
Lara würde aber auch nicht wirklich was bringen außer das es keine Downtime gibt?
Damit kann ich auch nicht viel mehr machen als im Rescue Modus.

Auf dem Server oder auf meine PC@Home??
Auf dem Server läuft Debian.
Bei mir läuft Ubuntu.

Danke für deine Hilfsbereitschaft :-D.

MfG
AVU4m9

avu4m9
Posts: 20
Joined: 2008-07-29 00:00

Re: SSH Problem

Post by avu4m9 »

So!
Problem gelöst.
Hetzner hat mir die LARA bereitgestellt und ich konnte das Problem beheben.
Ich musste den ssh rsa und dsa Key neu generieren.
Nur FTP läuft leider noch nicht :(

MfG
AVU4m9

User avatar
daemotron
Administrator
Administrator
Posts: 2636
Joined: 2004-01-21 17:44

Re: SSH Problem

Post by daemotron »

FTP scheint aber ein Konfigurationsproblem zu sein, da der Dienst selbst ja läuft (zumindest lt. Deinem Portscan). Welcher FTPd, genaue Fehlerbeschreibung, ggf. Logs, Konfigurationsauszüge...?

avu4m9
Posts: 20
Joined: 2008-07-29 00:00

Re: SSH Problem

Post by avu4m9 »

Folgendes steht in den Syslogs:

Code: Select all

pure-ftpd: (?@?) [ERROR] Unable to start a standalone server: [Das Argument ist ungültig]

User avatar
daemotron
Administrator
Administrator
Posts: 2636
Joined: 2004-01-21 17:44

Re: SSH Problem

Post by daemotron »

Ohne mich mit pure-ftpd wirklich auszukennen: irgendwie sieht das danach aus, als wären Stand-alone und (x)inetd-Setup durcheinander geraten. Du musst Dich für eine Variante entscheiden (vielleicht hilft Dir das weiter...)

avu4m9
Posts: 20
Joined: 2008-07-29 00:00

Re: SSH Problem

Post by avu4m9 »

Ich habe mal in der /etc/ined.conf nachgesehen.
Dort ist alles so, wie es sein sollte.
Ich habe noch etwas in den Syslogs entdeckt:

Code: Select all

proftpd[21192]: error: cannot execute /usr/sbin/proftpd: No such file or directory
Ich habe proftpd eigentlich gar nicht installiert??

MfG
AVU4m9

Roger Wilco
Administrator
Administrator
Posts: 5923
Joined: 2004-05-23 12:53

Re: SSH Problem

Post by Roger Wilco »

AVU4m9 wrote:Ich habe proftpd eigentlich gar nicht installiert??
In deinen Logs steht etwas anderes.

avu4m9
Posts: 20
Joined: 2008-07-29 00:00

Re: SSH Problem

Post by avu4m9 »

Ich habe es schon versucht zu deinstallieren. Erfolglos.
Kann ich die Dateien von proftpd auch manuell löschen? Wenn ja, wo?

MfG
AVU4m9

Roger Wilco
Administrator
Administrator
Posts: 5923
Joined: 2004-05-23 12:53

Re: SSH Problem

Post by Roger Wilco »

AVU4m9 wrote:Ich habe es schon versucht zu deinstallieren. Erfolglos.
Wie hast du es versucht?
AVU4m9 wrote:Kann ich die Dateien von proftpd auch manuell löschen? Wenn ja, wo?
Das geht bestimmt. Einfach alle Dateien, die mit ProFTPd zusammenhängen löschen und die Konfiguration der Programme, die davon abhängen, entsprechend anpassen.

avu4m9
Posts: 20
Joined: 2008-07-29 00:00

Re: SSH Problem

Post by avu4m9 »

aptitude remove --purge proftpd

:D. Du hast recht ^^. Dumme Idee...

avu4m9
Posts: 20
Joined: 2008-07-29 00:00

Re: SSH Problem

Post by avu4m9 »

Ich habe nun einfach mal ProFTPD installiert und PureFTPD deinstalliert. Einfach nur zum testen.
ProFTPD gibt mir schon genauere Informationen zu diesem Problem.

Code: Select all

Aug 11 20:46:18 Debian-40-etch-64-LAMP proftpd[2021]
Failed binding to ::, port 21: Address already in use
Check the ServerType directive to ensure you are configured correctly.
Wie kann ich einen Port killen? Geht das?
Ich hab schon raus gefunden wer den Port nutzt: inetd
Wenn ich einen anderen Port in Proftpd einstelle, kann ich mich verbinden.

MfG
AVU4m9

User avatar
daemotron
Administrator
Administrator
Posts: 2636
Joined: 2004-01-21 17:44

Re: SSH Problem

Post by daemotron »

Wie ich schon sagte - Du musst Dich entscheiden, ob Du FTP über inetd anbieten willst, oder ob der FTPd im Stand-Alone Betrieb laufen soll. Die meisten modernen FTP-Server wie ProFTPd oer VSFTPd brauchen inted nicht mehr, das ist eher ein Relikt aus bösen alten Tagen :wink: Heute gibt es eigentlich keinen Grund mehr, (x)inetd überhaupt noch einzusetzen, wenn man Standard-Software nutzt (ist allerdings nützlich, wenn man mit ein bisschen Geskripte einen eigenen Server programmieren will). Also prüfe doch noch mal, welche Dienste bei Dir über inetd gesteuert werden. Wenn es nur FTP ist, kannst Du inetd ganz deaktivieren. Ansonsten eben nur den Abschnitt zu FTP auskommentieren und inetd neu starten.

avu4m9
Posts: 20
Joined: 2008-07-29 00:00

Re: SSH Problem

Post by avu4m9 »

Das habe ich bereits getan.
Es zeigt kein Erfolg und FTP läuft immer noch über inetd.

edit:

Code: Select all

# /etc/inetd.conf:  see inetd(8) for further informations.
#
# Internet superserver configuration database
#
#
# Lines starting with "#:LABEL:" or "#<off>#" should not
# be changed unless you know what you are doing!
#
# If you want to disable an entry so it isn't touched during
# package updates just comment it out with a single '#' character.
#
# Packages should modify this file by using update-inetd(8)
#
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
#
#:INTERNAL: Internal services
#discard                stream  tcp     nowait  root    internal
#discard                dgram   udp     wait    root    internal
#daytime                stream  tcp     nowait  root    internal
#time           stream  tcp     nowait  root    internal

#:STANDARD: These are standard services.

#:BSD: Shell, login, exec and talk are BSD protocols.

#:MAIL: Mail, news and uucp services.

#:INFO: Info services

#:BOOT: TFTP service is provided primarily for booting.  Most sites
#       run this only on machines acting as "boot servers."

#:RPC: RPC based services

#:HAM-RADIO: amateur-radio services

#:OTHER: Other services
Ist nichts aktiv, oder?
Kann ich inetd auch einfach deinstallieren??

MfG
AVU4m9

User avatar
daemotron
Administrator
Administrator
Posts: 2636
Joined: 2004-01-21 17:44

Re: SSH Problem

Post by daemotron »

AVU4m9 wrote:Es zeigt kein Erfolg und FTP läuft immer noch über inetd.
Eventuell ist es auch xinetd; dementsprechend wäre es dann /etc/xinetd.conf oder entsprechende includes. Auf jeden Fall hast Du den (x)inetd-Dienst noch nicht beendet (/etc/init.d/inetd stop)
AVU4m9 wrote:Kann ich inetd auch einfach deinstallieren??
Ansich ja. Ich kenne kaum ein Szenario, in dem (x)inetd wirklich zwingend benötigt wird. Ich weiß allerdings nicht, welche Abhängigkeiten Debian da hat; eventuell mal mit aptitude -s (ich glaub zumindest, dass es das war... lieber noch mal manpage lesen) erst mal die Deinstallation simulieren.

avu4m9
Posts: 20
Joined: 2008-07-29 00:00

Re: SSH Problem

Post by avu4m9 »

bei mir heißt es glaube ich openbsd-inetd.
Ich habe es restartet.
Erfolglos...

Nun habe ich mir mal die PrFTPD Doku angesehen.
Dort steht wie man den Dienst killt der auf 21 läuft.
Dies war dann auch erfolgreich.
Der FTP Server läuft.
So habe ich es hin bekommen:

Code: Select all

webserver:~ # fuser -n tcp 21
21/tcp: 3191
webserver:~ # ps aux | grep 3191
nobody 3191 0.0 0.5 2656 1260 ? S 15:17 0:00 inetd: (accepting connections)
root 3197 0.0 0.1 1396 476 pts/0 R 15:18 0:00 grep 3191
webserver:~ # kill -SIGHUP 3191
Der Prozess der bei mir die Zahl 3191 hat, muss durch den ersetzt werden der bei fuser -n tcp 21 raus kommt.
Vielen Dank für die Hilfe. Echt Top! Ich werde euch Weiterempfehlen. ;) =D>

MfG
AVU4m9