Debian SW Raid

Alles was sonst Nirgends passt
thomas.km
Posts: 364
Joined: 2003-09-14 11:35
Location: Schleswig-Holstein

Debian SW Raid

Post by thomas.km » 2008-06-05 11:08

Hallo,

falls ich in dem Unterform falsch bin, sorry....

Folgendes:

Ich habe mind. schon 15 Systeme mit einem normalen Software Raid 1 installiert, nie ohne Probleme, da ja da auch nicht viel dabei ist.

Aber heute, habe ich folgendes Problem.

md: invalid raid superblock magic on hda
md: hda has invalid sb, not importing!
md: md_import_device returned -22
md: md1 stopped.
md: bind<hda2>
md: md1: raid array is not clean -- starting background reconstruction
raid1: raid set md1 active with 1 out of 1 mirrors
md: bind<hdc1>
md: bind<hda1>
raid1: raid set md0 active with 1 out of 1 mirrors


Er kann das raid md1 nicht starten.

Folgende Partitionen wurden bei der Installation angelegt:

13 GB auf / ext3 (boot)
450GB LVM

Debian 2.6.18-4 amd64

Ausgabe mdstat
cat /proc/mdstat
Personalities : [raid1]
md1 : active raid1 hda2[0]
475692608 blocks [1/1] [U]

md0 : active raid1 hda1[0] hdc1[1](S)
12691200 blocks [1/1] [U]

unused devices: <none>


Er kann hdc2 nicht einbinden. Will ich es manuell mit mdadm machen, sagt er das hdc2 busy ist.

Es sind SATAII Festplatten vom Typ Western Digital WD50000AAKS verbaut
Board ist ein Gigabyte GA-G33-DSR

Die Frage die sich mir stellt: ist er wirklich dabei es zu synchronisieren (reconstrution) und dauert es nur ewig lang oder gibt es wirklich ein Problem mit hdc2
Ich habe auch schon 2 andere Festplatten verbaut und ca .4 mal neu installiert.

lspci noch
lspci
00:00.0 Host bridge: Intel Corporation Unknown device 29c0 (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Unknown device 29c2 (rev 02)
00:1a.0 USB Controller: Intel Corporation Unknown device 2937 (rev 02)
00:1a.1 USB Controller: Intel Corporation Unknown device 2938 (rev 02)
00:1a.2 USB Controller: Intel Corporation Unknown device 2939 (rev 02)
00:1a.7 USB Controller: Intel Corporation Unknown device 293c (rev 02)
00:1b.0 Audio device: Intel Corporation Unknown device 293e (rev 02)
00:1c.0 PCI bridge: Intel Corporation Unknown device 2940 (rev 02)
00:1c.3 PCI bridge: Intel Corporation Unknown device 2946 (rev 02)
00:1c.4 PCI bridge: Intel Corporation Unknown device 2948 (rev 02)
00:1d.0 USB Controller: Intel Corporation Unknown device 2934 (rev 02)
00:1d.1 USB Controller: Intel Corporation Unknown device 2935 (rev 02)
00:1d.2 USB Controller: Intel Corporation Unknown device 2936 (rev 02)
00:1d.7 USB Controller: Intel Corporation Unknown device 293a (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation Unknown device 2916 (rev 02)
00:1f.2 IDE interface: Intel Corporation Unknown device 2920 (rev 02)
00:1f.3 SMBus: Intel Corporation Unknown device 2930 (rev 02)
00:1f.5 IDE interface: Intel Corporation Unknown device 2926 (rev 02)
02:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 02)
02:00.1 IDE interface: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 02)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)


Das Boad selber hatte ich schon mehrfach im Einsatz und kann es mir nicht erklären.

Ich wäre daher über jeden Tipp dankbar

thomas.km
Posts: 364
Joined: 2003-09-14 11:35
Location: Schleswig-Holstein

Re: Debian SW Raid

Post by thomas.km » 2008-06-05 11:25

Ich habe jetzt md1 gestopt und mit mdadm create neu angelegt, jetzt läuft scheinbar der sync, allerdings will er daran 65 Stunden sitzen :-(

cat /proc/mdstat
Personalities : [raid1]
md1 : active raid1 hdc2[1] hda2[0]
475692608 blocks [2/2] [UU]
[>....................] resync = 0.1% (493440/475692608) finish=3915.2min speed=2020K/sec

md0 : active raid1 hda1[0] hdc1[1](S)
12691200 blocks [1/1] [U]

unused devices: <none>


Kann man das irgendwie beschleunigen?


EDIT:
Ich glaube das Problem ist:
Losing some ticks... checking if CPU frequency changed.
warning: many lost ticks.
Your time source seems to be instable or some driver is hogging interupts
rip ide_do_request+0x30e/0x78c [ide_core]
Falling back to HPET


Aber das sagt mir leider nicht viel :-/

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Debian SW Raid

Post by Joe User » 2008-06-08 14:43

Entweder Dein Kernel hat eine zuhohe Tickrate, oder Deine CPU hat ein Problem mit ihrer Stromversorgung, oder, oder, ...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.