Probleme beim IPTables::IPv4 installieren

Bash, Shell, PHP, Python, Perl, CGI
termi11
Posts: 34
Joined: 2004-05-10 10:07
Location: Luxemburg

Probleme beim IPTables::IPv4 installieren

Post by termi11 »

Hallo,

ich versuche gerade bei Ubuntu 8.04 das IPTables::IPv4 zu installieren.
Über cpan geht's nicht. Hab dann versucht die tgz selbst zu compilieren mit perl Makefile.pl und dann beim make erhalte ich diese Fehlermeldung: (die gleiche wie im cpan)
  • root@nas:/home/dirk/IPTables-IPv4-0.98# perl Makefile.PL
    Checking if your kit is complete...
    Looks good
    Writing Makefile for IPTables::IPv4
    root@nas:/home/dirk/IPTables-IPv4-0.98# make
    cp IPv4/Chain.pm blib/lib/IPTables/IPv4/Chain.pm
    cp IPv4/TableTie.pm blib/lib/IPTables/IPv4/TableTie.pm
    cp IPv4.pm blib/lib/IPTables/IPv4.pm
    AutoSplitting blib/lib/IPTables/IPv4.pm (blib/lib/auto/IPTables/IPv4)
    cp IPv6.pm blib/lib/IPTables/IPv6.pm
    AutoSplitting blib/lib/IPTables/IPv6.pm (blib/lib/auto/IPTables/IPv6)
    cp IPv4/Rule.pm blib/lib/IPTables/IPv4/Rule.pm
    cp IPv4/Toplevel.pm blib/lib/IPTables/IPv4/Toplevel.pm
    cp IPv4/RuleList.pm blib/lib/IPTables/IPv4/RuleList.pm
    /usr/bin/perl /usr/share/perl/5.8/ExtUtils/xsubpp -noprototypes -typemap /usr/share/perl/5.8/ExtUtils/typemap -typemap IPTables.typemap IPv4.xs > IPv4.xsc && mv IPv4.xsc IPv4.c
    cc -c -Iinclude -I/usr/src/linux/include -Wall -DMODULE_PATH="/usr/local/lib/IPTables-IPv4" -O2 -DVERSION="0.98" -DXS_VERSION="0.98" -fPIC "-I/usr/lib/perl/5.8/CORE" IPv4.c
    In file included from /usr/src/linux/include/linux/netfilter_ipv4.h:8,
    from /usr/src/linux/include/linux/netfilter_ipv4/ip_tables.h:26,
    from include/libiptc/libiptc.h:6,
    from IPv4.xs:28:
    /usr/src/linux/include/linux/netfilter.h:54: error: expected specifier-qualifier-list before â__u32â
    IPv4.xs: In function âXS_IPTables__IPv4__Table_set_policyâ:
    IPv4.xs:329: warning: dereferencing type-punned pointer will break strict-aliasing rules
    IPv4.xs: In function âXS_IPTables__IPv4__Table_get_referencesâ:
    IPv4.xs:379: warning: pointer targets in passing argument 1 of âiptc_get_referencesâ differ in signedness
    make: *** [IPv4.o] Error 1
Kernel ist ein 2.6.25.4

Was hab ich da falsch gemacht?

Besten Dank im Voraus!
lordy
Posts: 83
Joined: 2006-06-22 12:45

Re: Probleme beim IPTables::IPv4 installieren

Post by lordy »

Release-Date IPTables::IPv4 -> 18 Aug 2003
Release-Date Kernel 2.6.0 -> 18 Dec 2003

Noch Fragen ? :-)