HT-Access Befehl funktioniert nicht

Apache, Lighttpd, nginx, Cherokee
birgit
Posts: 9
Joined: 2008-06-01 13:43

HT-Access Befehl funktioniert nicht

Post by birgit » 2008-06-03 09:29

Hallo,

ich würde gerne eine Userin aus meinem Blog draußenhalten und habe in der HT-Access wie folgt gesperrt:

<LIMIT GET POST>
order deny,allow
deny from 89.48.
</LIMIT>

Diesen Befehl fand ich im Netz...

Ich habe das mit meiner eigenen IP (auch nur 91.11.) ausprobiert und es funktioniert perfekt. Auf keinem Weg kann ich auf meine Seite zugreifen. Nicht über eine Verlinkung in einem anderen Blog, nicht über den Feedreader und nicht über die Kommentarbenachrichtigung.

89.48. kommt mich aber täglich weiterhin besuchen... Wie macht die das und gibt es einen besseren Befehl?

Bin private Anwenderin und Laie - bitte in idiotensicherer Weise mit mir sprechen! :wink:

jan10001
Anbieter
Posts: 727
Joined: 2004-01-02 12:17

Re: HT-Access Befehl funktioniert nicht

Post by jan10001 » 2008-06-03 10:13

order deny,allow
deny from 89.48.

Das sollte wohl ehr stimmen.

<LIMIT GET POST>
....
</LIMIT>
Das bezieht sich auf die auf das Übertragen der Daten zum Server mit GET und POST.

Mehr dazu hier: http://de.selfhtml.org/servercgi/server/htaccess.htm

birgit
Posts: 9
Joined: 2008-06-01 13:43

Re: HT-Access Befehl funktioniert nicht

Post by birgit » 2008-06-03 10:21

okay, danke

habt Ihr ne Erklärung dafür, warum es funktioniert, wenn ich meine eigene IP sperre? 403 Forbidden hab ich bekommen...

birgit
Posts: 9
Joined: 2008-06-01 13:43

Re: HT-Access Befehl funktioniert nicht

Post by birgit » 2008-06-03 11:01

noch eine Frage:

das ist der bisherige Inhalt der ht-access (den die Blogsoftware freundlicherweise angelegt hat). Kommt der neue Befehl irgendwo dazwischen oder einfach ganz unten dran?

# BEGIN s9y
DirectoryIndex /index.php

<Files *.tpl.php>
deny from all
</Files>

<Files *.tpl>
deny from all
</Files>

<Files *.sql>
deny from all
</Files>

<Files *.inc.php>
deny from all
</Files>

<Files *.db>
deny from all
</Files>

# END s9y
#SPAMDENY
Deny From 124.38.187.118,195.245.198.244,198.145.182.32,205.234.98.22,207.58.177.167,207.58.181.182,208.113.155.28,208.53.147.118,209.11.242.250,209.160.32.30,212.227.119.7,212.27.63.204,212.3.144.20,213.171.218.179,213.251.189.201,213.251.189.203,24.14.223.183,64.141.108.29,64.18.158.194,64.185.237.50,64.191.93.101,64.202.161.130,64.202.165.131,64.202.165.201,66.197.151.229,66.197.220.230,66.232.107.104,66.7.202.21,66.90.104.89,66.96.233.190,67.159.44.159,68.197.73.109,68.201.12.59,69.80.224.68,69.89.27.222,69.9.38.210,70.84.23.178,72.167.39.145,72.232.177.42,72.233.78.5,72.249.11.157,72.55.146.22,72.55.165.26,74.208.14.215,74.208.14.63,74.208.16.108,74.208.16.112,74.208.16.163,74.208.16.164,74.208.16.77,74.208.69.221,74.52.109.18,74.54.176.210,76.171.140.255,77.232.72.45,78.129.208.135,80.74.144.85,81.28.232.69,82.165.139.105,83.170.102.67,88.198.47.45,91.121.140.14,91.186.21.78,91.84.248.29
#/SPAMDENY

jan10001
Anbieter
Posts: 727
Joined: 2004-01-02 12:17

Re: HT-Access Befehl funktioniert nicht

Post by jan10001 » 2008-06-03 12:25

Häng es einfach unten dran, dann gilt es für alles.

Das deine Anweisung vorher bei dir blockte hing damit zusammen, das da vermutlich ein JavaScript etwas zur Seite übertragen hat oder du hast beim Seitenaufruf Informationen übertragen die per get eingelesen werden. z.B. mit so einer URL http://xxx.de/posting.php?mode=zxy

birgit
Posts: 9
Joined: 2008-06-01 13:43

Re: HT-Access Befehl funktioniert nicht

Post by birgit » 2008-06-03 13:00

dankeschön!

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: HT-Access Befehl funktioniert nicht

Post by daemotron » 2008-06-03 13:35

Nur zur Ergänzung: GET ist der Standard-HTTP-Befehl, um Inhalt vom Server anzufordern. Im einfachsten Fall ist das ein

Code: Select all

GET / HTTP/1.1
Dazu braucht's weder JavaScript noch Parameter in der URL (siehe http://de.wikipedia.org/wiki/Http)

jan10001
Anbieter
Posts: 727
Joined: 2004-01-02 12:17

Re: HT-Access Befehl funktioniert nicht

Post by jan10001 » 2008-06-03 16:55

Stimmt :oops: Dann könnte sie vielleicht einen Proxy Server als Zwischenstation nutzen.

birgit
Posts: 9
Joined: 2008-06-01 13:43

Re: HT-Access Befehl funktioniert nicht

Post by birgit » 2008-06-03 21:51

Es geht nicht und ich zweifle gleich an meinem Verstand:

Ich hab diesen Befehl unter dieses Serendipity-Zeug geschrieben, hochgeladen und eine Stunde später ist es nicht mehr da. Ich hab das jetzt 4 oder 5 x gemacht und ich bin absolut sicher, daß ich die HT-Access abgespeichert habe.

Warum kann sich HT-Access nicht länger als eine Stunde merken, was ich da reingeschrieben habe?

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: HT-Access Befehl funktioniert nicht

Post by daemotron » 2008-06-03 22:38

Serendipity überschreibt diese Datei, insbesondere wenn irgendwelche Spamschutz-Plugins aktiv sind. In diesem Fall hilft nur, solche dauerhaften Deny-Anweisungen in der Webserver-Konfiguration für den entsprechenden virtuellen Host unterzubringen.

birgit
Posts: 9
Joined: 2008-06-01 13:43

Re: HT-Access Befehl funktioniert nicht

Post by birgit » 2008-06-03 22:49

*ggg*

Ich hab gerade Deinen s9y-Blog gesehen - dann kennst Du sicher auch Garvin..? Garvin kennt mein Problem und hat mir dieses Forum empfohlen. Sowas weiß er doch normal, oder? :-D

birgit
Posts: 9
Joined: 2008-06-01 13:43

Re: HT-Access Befehl funktioniert nicht

Post by birgit » 2008-06-03 23:02

Überschreibt Serendipity diese Datei nicht?

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: HT-Access Befehl funktioniert nicht

Post by daemotron » 2008-06-04 07:51

Mein s9y-Blog läuft mit lighttpd; der ignoriert die htaccess-Datei :wink: . Auf das überschreiben bin ich gekommen, weil bei Dir eine Spam-Blacklist eingetragen ist, die auch dynamische Adressen (z. B. aus dem T-Offline-Pool) enthält. Und irgendwie müssen die ja da reingekommen sein. Wahrscheinlich ist das aber ein Plugin und nicht das Core-System, das da aktiv wird. Vielleicht hilft es ja, wenn Du Deine Denys zwischen # END s9y und #SPAMDENY packst. Oder stammen die SPAMDENY-Einträge von Dir...? :-k

birgit
Posts: 9
Joined: 2008-06-01 13:43

Re: HT-Access Befehl funktioniert nicht

Post by birgit » 2008-06-04 07:54

Nein, die Spamdeny-Einträge stammen nicht von mir :-) Ich kann bloggen und ich konnte mein Design selbst machen, aber das war's dann schon ;-)

birgit
Posts: 9
Joined: 2008-06-01 13:43

Re: HT-Access Befehl funktioniert nicht

Post by birgit » 2008-06-05 16:55

jfreund wrote:Serendipity überschreibt diese Datei, insbesondere wenn irgendwelche Spamschutz-Plugins aktiv sind. In diesem Fall hilft nur, solche dauerhaften Deny-Anweisungen in der Webserver-Konfiguration für den entsprechenden virtuellen Host unterzubringen.


I proudly present:

[client 89.48.***.***] client denied by server configuration


Ich hab ne 2. HT-Access angelegt und den deny-Befehl da reingeschrieben und es hat geklappt.