MX Records

Bind, PowerDNS
nixdorf
Posts: 88
Joined: 2005-07-28 15:34

MX Records

Post by nixdorf » 2008-05-12 11:09

Hallo,

ich habe auf einem Root-Server eine Internetseite gehostet. Die Domain soll auf dem Server bleiben, aber die Emails der Domain möchte ich auf einem anderem Server mit dem Exchange-Server verwalten. Daher habe ich auf dem Root-Server folgende DNS-Einträge gemacht:

MX Records
Host Mail Exchanger TTL Präferenz
domain.de mail2.xchangemail.de 86400 10
domain.de mail1.xchangemail.de 86400 10
CNAME Records
Host Canonical Name TTL
domain.de autodiscoverredirect.tcom-it.de 86400

eine abfrage nslookup -querytype=mx domain.de zeigt mir folgendes an:

Server: 217.13.124.1
Address: 217.13.124.1#53

Non-authoritative answer:
domain.de canonical name = autodiscoverredirect.tcom-it.de.
autodiscoverredirect.tcom-it.de canonical name = autodiscover.tcom-it.de.

Authoritative answers can be found from:
tcom-it.de
origin = pns.dtag.de
mail addr = hostmaster.visionapp.de
serial = 2008043001
refresh = 10800
retry = 1800
expire = 3600000
minimum = 300


kann es sein das die Email immer noch nicht an den Exchange-Server weitergeleitet werden? Wenn ich versuche die Mail via Outlook von dem Exchange-Server abzurufen klappt das noch nicht.

Gruß Nixdorf

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: MX Records

Post by Roger Wilco » 2008-05-12 11:29

Was erwartest du denn als Antwort, wenn du den CNAME für example.com gesetzt hast?

nixdorf
Posts: 88
Joined: 2005-07-28 15:34

Re: MX Records

Post by nixdorf » 2008-05-12 11:34

Hallo,

ich habe das nach der Anleitung des Excahge - Providers gemacht. Darin stand, das ich auch diese CNAME - Eintrag machen sollte.

Muß ich den entfernen?

Gruß NIxdorf

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: MX Records

Post by Roger Wilco » 2008-05-12 11:37

nixdorf wrote:ich habe das nach der Anleitung des Excahge - Providers gemacht. Darin stand, das ich auch diese CNAME - Eintrag machen sollte.

Ich schätze mal, dass die Domain dann auf das Webinterface (vllt. OWA?) verweisen soll. Leg dir dafür eine eigene Subdomain an oder frag nochmal bei dem Provider nach, ob das wirklich so gedacht ist.

nixdorf
Posts: 88
Joined: 2005-07-28 15:34

Re: MX Records

Post by nixdorf » 2008-05-12 11:47

Danke, ich versuche da schon die ganze Zeit anzurufen...

Gruß NIxdorf

texmecx
Posts: 18
Joined: 2003-11-23 00:03

Re: MX Records

Post by texmecx » 2008-05-17 16:42

domain.de autodiscoverredirect.tcom-it.de 86400

So ist das leider falsch....in der Anleitung steht das auch anders. ;)
Du sollst unter Deiner Domain einen CNAME für den Host autodiscover anlegen, der auf autodiscoverredirect.tcom-it.de zeigt.