[qmail] postmaster nimmt keine Mails mehr an

manjo
Posts: 32
Joined: 2004-01-14 14:46

[qmail] postmaster nimmt keine Mails mehr an

Post by manjo »

Hallo!

Jetzt suche ich seit Stunden, finde aber keine Lösung:

System: Rootserver von 1und1, Plesk 8.1.1, suse 10.1

Emails , die an postmaster@p12345678.puresurfer.info gehen, werden abgelehnt:

Code: Select all

I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.


Das Logfile ist auch nicht sonderlich auskunftsfreudig:

Code: Select all

Apr 14 13:55:49 p15200713 qmail: 1208174149.179055 new msg 4278243
Apr 14 13:55:49 p12345678 qmail: 1208174149.179189 info msg 4278243: bytes 394 from <absender@mydomain.de> qp 2232 uid 0
Apr 14 13:55:49 p12345678 qmail: 1208174149.195794 starting delivery 1: msg 4278243 to local postmaster@p12345678.pureserver.info
Apr 14 13:55:49 p12345678 qmail: 1208174149.195931 status: local 1/10 remote 0/20
Apr 14 13:55:49 p12345678 qmail: 1208174149.199020 delivery 1: failure:
Apr 14 13:55:49 p12345678 qmail: 1208174149.199153 status: local 0/10 remote 0/20
Apr 14 13:55:49 p12345678 qmail: 1208174149.214877 bounce msg 4278243 qp 2235
Apr 14 13:55:49 p12345678 qmail: 1208174149.215014 end msg 4278243


Mails, die ich an postmaster@mydomain.de schicke, kommen an. Sieht nach einem Bounce aus, doch ich weiß nicht, wo ich noch suchen soll.

1. /etc/aliases sieht ok aus:

Code: Select all

# Basic system aliases that MUST be present.
postmaster:     root
mailer-daemon:  postmaster

# amavis
virusalert:     root

# General redirections for pseudo accounts in /etc/passwd.
administrator:  root
daemon:         root
lp:             root
news:           root
uucp:           root
games:          root
man:            root
at:             root
postgres:       root
mdom:           root
amanda:         root
ftp:            root
wwwrun:         root
squid:          root
msql:           root
gnats:          root
nobody:         root
# "bin" used to be in /etc/passwd
bin:            root

# Further well-known aliases for dns/news/ftp/mail/fax/web/gnats.
newsadm:        news
newsadmin:      news
usenet:         news
ftpadm:         ftp
ftpadmin:       ftp
ftp-adm:        ftp
ftp-admin:      ftp
hostmaster:     root
mail:           postmaster
postman:        postmaster
post_office:    postmaster
# "abuse" is often used to fight against spam email
abuse:          postmaster
spam:           postmaster
faxadm:         root
faxmaster:      root
webmaster:      root
gnats-admin:    root
mailman:        root
mailman-owner:  mailman


2. /var/qmail/aliases/.qmail-postmaster // .qmail-root // .qmail-mailer-daemon sind alle gleich:

Code: Select all

&webmaster@mydomain.de


3. /var/qmail/control/locals

Code: Select all

localhost
p12345678.pureserver.info


4. /var/qmail/control/me

Code: Select all

mydomain.de
p12345678.pureserver.info


Hat jemand eine Idee, wo ich noch suchen könnte oder was falsch ist in der Konfig?

Viele Grüße
Manjo
Top

aubergine
RSAC
Posts: 475
Joined: 2005-09-10 17:52
Location: Frankfurt am Main

Re: [qmail] postmaster nimmt keine Mails mehr an

Post by aubergine »

Die "me" Datei darf imho nur einen Hostnamen enthalten der als HELO Hostname von qmail verwendet wird. (Vergleiche Reverse DNS)

Leg doch deine Domain p12345678.puresurfer.info einfach in Plesk an und steuer das ganze über die VirtualAliases von Plesk.
Top

manjo
Posts: 32
Joined: 2004-01-14 14:46

[qmail] globale Mailaliase funzen nicht

Post by manjo »

Das habe ich alles schon durch. Alle Varianten:
- Nur eine Domain in "me", mal die Hauptdomain, mal die p12345678...
- p12345678.pureserver.info als Domainalias angelegt
Hat alles nix gebracht. Jetzt habe ich qmail erstmal dazu gebracht, bei fehlerhaften Zustellungen nicht mailer-daemon@p12345678... sondern @mydomain.de zu verwenden. Ist auch schon mal was. Löst aber nicht das o.g. Problem.

Im übrigen sollten die Empfänger, die ich in /var/qmail/aliase/.qmail-hans:wurst definiere, alle Mails mit der Empfängeradresse hans.wurst@irgendeine-domain-die-auf-de ... tet-ist.de erhalten, oder? Das tut nämlich auch nicht und ich frage mich warum.
Top