Apache2/PHP-Einrichtung

Apache, Lighttpd, nginx, Cherokee
1nf0rmat1ker
Posts: 19
Joined: 2006-11-25 10:11

Apache2/PHP-Einrichtung

Post by 1nf0rmat1ker » 2008-03-19 13:32

Hallo,
habe gestern eine Neuinstallation machen müssen und seit dem funktioniert die Website auf meinem Server nicht mehr richtig. Ich setze Debian 5, Apache 2 und PHP5 in den jeweils aktuellen Packages von Debian ein.

Die Seiten werden z.T. richtig angezeigt (http://www.market-team.org), wenn ich jedoch auf einen der Links klicke, so wird die Seite nicht geladen, sondern die gleiche Seite erscheint nochmals. Es handelt sich dabei immer um selbstgeschriebene PHP-Seiten. Zuvor haben diese jedoch einwandfrei (vor der Neuinstallation) funktioniert. So dass es eigentlich nicht an den Files selbst liegt.

Außerdem wird im per htaccess geschützen Bereich nach erfolgreicher Eingabe des Passworts nicht die index.htm geladen sondern ein Directory Listung durchgeführt.

In den Logs sind keine Fehler verzeichnet.

Kennt jemand das Problem und weiß wie ich es beheben kann? (Habe gerade keinen Zugriff auf die Configfiles, kann die aber nachliefern).

Habe gestern in einer Nachtschicht den Server neuaufgesetzt bin bin ein wenig verzweifelt, darum wäre ich euch sehr dankbar für Tipps. Vielleicht habe ich ja auch nur was ganz banales übersehen... *hoff*

Vielen Dank!,

Martin

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: Apache2/PHP-Einrichtung

Post by oxygen » 2008-03-19 14:31

Das Problem ist, dass du PHP nicht richtig beherrschst. vgl. register_globals

1nf0rmat1ker
Posts: 19
Joined: 2006-11-25 10:11

Re: Apache2/PHP-Einrichtung

Post by 1nf0rmat1ker » 2008-03-19 20:53

Hallo,
vielen Dank für den Tipp, du hast mir den Abend gerettet =D> !!! Jetzt funktioniert die Seite wieder, da lasse ich mich doch gerne einen PHP-Anfänger nennen! (Bin ich ja auch ;-))
BTW: Was wäre denn die sauberere Alternative, wenn man die Option register_globals wieder ausschalten möchte?
Gruß,

Martin