mod_rewrite macht probleme

Apache, Lighttpd, nginx, Cherokee
blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

mod_rewrite macht probleme

Post by blnsnoopy26 » 2008-02-23 20:02

Hi,

Und zwar habe ich ein kleines Problem mit dem mod_rewrite.
Für eine Präsenz funktioniert das ohne Probleme und zwar für das phpmyfaq da gibs keine Probleme.

So jetzt will ich für ein anderes Projekt das einrichten, aber keine Chance es funktioniert nicht und in den logs taucht auch nix auf.

So sieht meine regel aus:

Code: Select all

RewriteEngine on
RewriteBase /cgi-bin/
RewriteRule     ^meine-domain-test.ath.cx/+(.+)/(.+);(.*)$ /home/micha/clanhp/test/cgi-bin/player-status.fcgi?server=$1&name=$2&page=char&$3 [L]
RewriteRule     ^meine-domain-test.ath.cx/+(.+)/(.*)$  /home/micha/clanhp/test/cgi-bin/player-status.fcgi?server=$1&name=$2&page=char    [L]


Docroot für die Domain ist: /home/micha/clanhp/test

So sieht meine vhost für diese domain aus:

Code: Select all

<Directory "/home/micha/clanhp/test">
  AllowOverride None
  Options +FollowSymLinks +SymLinksIfOwnerMatch
  Options +ExecCGI
  DirectoryIndex jgs_portal.php index.html index.htm index.php
  <IfModule mod_access.c>
    Allow from all
  </IfModule>
  <Files ~ ".shtml$">
    allow from all
 </Files>
  <Files ~ ".(wml.*|wbmp)$">
    allow from all
  </Files>
</Directory>


Code: Select all

<VirtualHost xx.xxx.xxx.xx:80>
ServerName meine-domain-test.ath.cx
ServerAlias meine-domain-test.ath.cx www.meine-domain-test.ath.cx

DocumentRoot /home/micha/clanhp/test/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /home/micha/phptmp/
php_admin_flag register_globals off
php_admin_flag safe_mode off
php_admin_flag engine on
suPHP_Engine on
AddType application/x-httpd-php .php .php3 .php4 .html
AddHandler x-httpd-php .php .php3 .php4 .html
</VirtualHost>


Komischerweise geht es für mein anderes projekt aber hier will es einfach nicht funktionieren.
Habe die .htaccess schon in allen möglichen Verzeichnissen aber nichts wollte helfen und hoffe jetzt hier die Hilfe zu bekommen um das problem zu lösen.

:google: und im Forum hab ich auch schon geschaut und diverses ausprobiert, aber nix wollte funzen.
Kann ja nicht sein, das es bei einem geht und woanders wieder nicht. Selbst verschiedene schreibweisen in der .htaaccess probiert es greift einfach nicht.

OS: Debian Etch 32 Bit
Apache 1.3.4

User avatar
Joe User
Project Manager
Project Manager
Posts: 11139
Joined: 2003-02-27 01:00
Location: Hamburg

Re: mod_rewrite macht probleme

Post by Joe User » 2008-02-23 21:32

Ich würde folgende Zeile anpassen:

Code: Select all

  AllowOverride None
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

blnsnoopy26
Posts: 660
Joined: 2002-10-19 14:01

Re: mod_rewrite macht probleme

Post by blnsnoopy26 » 2008-02-23 22:22

Joe User wrote:Ich würde folgende Zeile anpassen:

Code: Select all

  AllowOverride None


Da habe ich auch schon verschiedene params probiert, aber ohne Erfolg.
Irgendwie muss es ja eine Lösung geben.

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: mod_rewrite macht probleme

Post by Roger Wilco » 2008-02-24 14:04

blnsnoopy26 wrote:Da habe ich auch schon verschiedene params probiert, aber ohne Erfolg.

Dann probiers doch einfach mal mit dem richtigen Parameter...
-> http://httpd.apache.org/docs/2.2/mod/co ... owoverride