libmysqlclient_r.so.15 -> PLESK

Swiper
Posts: 91
Joined: 2003-10-12 23:28
Location: Köln

libmysqlclient_r.so.15 -> PLESK

Post by Swiper »

Hallo !

Ich habe versucht Plesk auf Version 8.3 zu updaten.
Nun hat Plesk keine Verbindung mehr zum mySQL 5.0.45

Im Install LOG steht sinngemäß das er die libmysqlclient.so.15 nicht finden kann.

Ich habe vor einiger Zeit php5 mit mySQL 5.0.45 selbst gebaut bzw. die mySQL per .rpm geupdated.
Nach langen hin und her habe ich es dann doch noch in bekommen.
Allerdings mit dem kleinen Schönheitsfehler das mySQL-Client auf Version 4.x.x.x lief.
PMA hat zwar gemekkert aber es lief alles zu meiner Zufriedenheit.

Bis heute. zu meinem Plesk update.

Also noch mal das ganze..

Code: Select all

Linux AMD64 / Intel EM64T generic RPM downloads:
MySQL-bench-5.0.51a-0.glibc23.x86_64.rpm
MySQL-client-5.0.51a-0.glibc23.x86_64.rpm
MySQL-devel-5.0.51a-0.glibc23.x86_64.rpm
MySQL-server-5.0.51a-0.glibc23.x86_64.rpm
MySQL-shared-5.0.51a-0.glibc23.x86_64.rpm
MySQL-shared-compat-5.0.51a-0.glibc23.x86_64.rpm

...und natürlich das gleiche Spiel von vorne.

Code: Select all

warning: MySQL-bench-5.0.51a-0.glibc23.x86_64.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
Preparing...                ########################################### [100%]
        file /usr/lib64/libmysqlclient.so.15.0.0 conflicts between attempted installs of MySQL-shared-5.0.51a-0.glibc23 and MySQL-shared-compat-5.0.51a-0.glibc23
        file /usr/lib64/libmysqlclient_r.so.15.0.0 conflicts between attempted installs of MySQL-shared-5.0.51a-0.glibc23 and MySQL-shared-compat-5.0.51a-0.glibc23
        file /usr/lib64/libndbclient.so.2.0.0 conflicts between attempted installs of MySQL-shared-5.0.51a-0.glibc23 and MySQL-shared-compat-5.0.51a-0.glibc23

Ich weis einfach nicht wo ich die fehlende(n) Datei(n) her bekomme.
Ich denke mal das sie in die oben genannten Verzeichnisse kommen?!
Ware ne feine Sache wenn mir jemand helfen könnte, denn alleine will's nicht klappen ;-)

Habe Suse 10.0 auf nem 1blu, V-Server
php 5.2.4
Top

jan10001
Anbieter
Posts: 720
Joined: 2004-01-02 12:17

Re: libmysqlclient_r.so.15 -> PLESK

Post by jan10001 »

Also ich sehe hier nichts von einer fehlenden libmysqlclient.so.15 vielmehr gibt da einen Konflikt mit der bestehenden libmysqlclient.so.15. Bei der libndbclient.so.2.0.0 ist es genauso. Du könntest versuchen die Installation der Pakete zu erzwingen damit deinen alten Dateien ausgetauscht werden.
Top

User avatar
isotopp
RSAC
Posts: 482
Joined: 2003-08-21 10:21
Location: Berlin

Re: libmysqlclient_r.so.15 -> PLESK

Post by isotopp »

xxl3 wrote:

Code: Select all

MySQL-shared-5.0.51a-0.glibc23.x86_64.rpm
MySQL-shared-compat-5.0.51a-0.glibc23.x86_64.rpm


Die Installation von MySQL-shared und MySQL-shared-compat schließt sich gegenseitig aus. MySQL-shared-compat ist eine Obermenge von MySQL-shared.
Top

jan10001
Anbieter
Posts: 720
Joined: 2004-01-02 12:17

Re: libmysqlclient_r.so.15 -> PLESK

Post by jan10001 »

Die Installation von MySQL-shared und MySQL-shared-compat schließt sich gegenseitig aus. MySQL-shared-compat ist eine Obermenge von MySQL-shared.

Stimmt, glatt übersehen. (Naja um die Uhrzeit.) :oops:
Top

Swiper
Posts: 91
Joined: 2003-10-12 23:28
Location: Köln

Re: libmysqlclient_r.so.15 -> PLESK

Post by Swiper »

Ich habe das mit der 5.0.45 & php5 Versionen auch mittels dieses HowTos hinbekommen
http://serversupportforum.de/forum/faqs-anleitungen/10762-howto-php5-installieren-3.html#35

Nun habe ich es wieder geschafft das ich mySQL5 gar nicht mehr hin bekomme

Ich hatte es jetzt war so weit das ich alles (auch den Client) installieren konnte auf 5.0.51a.
Aber PMA zeigte mir 4.1.23 als client an und ein Plesk 8.3 Autoupdate aus der Shell bestätigte mir das.
####

Also bin ich in YAST und habe alles was mit mySQL 4.x zu tun hatte deinstallt.

Nun bekomme ich zwar DEVEL installt aber dafür den Rest nicht.

Code: Select all

warning: MySQL-client-5.0.51a-0.glibc23.x86_64.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
error: Failed dependencies:
        libmysqlclient.so.15()(64bit) is needed by MySQL-client-5.0.51a-0.glibc23
        libmysqlclient.so.15(libmysqlclient_15)(64bit) is needed by MySQL-client-5.0.51a-0.glibc23

Eine .so.15 habe ich nicht drauf nur eine .so.14
Muss mir YAST wohl gelöscht haben

---- EDIT
Habe nun per YAST wieder mySQL 4.1.xx installiert und dann wieder mein RPM-Update gemacht.
Auch der CLIENT lief ohne Fehlermeldung durch.
YAST zeit mir nun keine 4.1.xx Installationen mehr an sondern nur noch die neuen 5.0.51.

Jedoch bekomme ich in PMA immer noch den Hinweis:
Die Version der verwendeten PHP MySQL Bibliothek 4.1.23 unterscheidet sich von der Version des MySQL Servers 5.0.51a.
Sowie das Plesk Autoupdate aus der Shell läuft deshalb nicht durch.
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11519
Joined: 2003-02-27 01:00
Location: Hamburg

Re: libmysqlclient_r.so.15 -> PLESK

Post by Joe User »

Wenn Du die MySQL-Client-Libraries aktualisierst, musst Du alle dagegen gelinkten Binaries rekompilieren, damit sie die aktualisierte MySQL-Client-Library verwenden. Dies betrifft nicht nur PHP und Plesk...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

Swiper
Posts: 91
Joined: 2003-10-12 23:28
Location: Köln

Re: libmysqlclient_r.so.15 -> PLESK

Post by Swiper »

Ich habe jetzt php5 neu gebaut. Es waren zwar ein paar Fehler dabei aber jetzt zeigt mir PMA die richtige Client Version
So. Was muß ich nun noch tun damit ich Plesk Updaten kann., denn es geht immer noch nicht.

Code: Select all

Determining the packages that need to be installed.
ERROR: Unable to proceed with the installation until the package MySQL-shared-compat-5.0.51a-0.glibc23.x86_64 is removed from the system.
Not all packages were installed.

Was will er ?? Habe ich doch installt!!
Vielleicht könntest Du mir das etwas genauer erklären ? :oops:
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11519
Joined: 2003-02-27 01:00
Location: Hamburg

Re: libmysqlclient_r.so.15 -> PLESK

Post by Joe User »

Steht doch eindeutig in der Fehlermeldung: Plesk will, dass Du MySQL-shared-compat-5.0.51a-0.glibc23.x86_64 (und die anderen MySQL-Pakete) wieder auf die offiziellen Distributions-Versionen downgradest. Danach kannst Du dann Plesk upgraden und sofern es Plesk dann zulässt auch MySQL und PHP. So ist es eben, wenn man sich das Leben mit Tools wie Plesk extra schwer macht...

BTW: Deine Distributions-Version wird seit Monaten nicht mehr supportet und daher auch nicht mehr mit Sicherheits-Updates versorgt!
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

Swiper
Posts: 91
Joined: 2003-10-12 23:28
Location: Köln

Re: libmysqlclient_r.so.15 -> PLESK

Post by Swiper »

Ja da kommt freude auf....
Obwohl es die ganze Zeit mit 5.0.45 lief
Aber kann mich erinnern das ich da auch hin und her gemacht habe und es mit mySql 4 geupdated hatte. und danach auf 5 umgestiegen bin.

Also eine Plesk install mit mySQL 4.1 geht nicht weil die PSA-DB SQL5 Daten enthält und SQL4 nicht (mehr) damit klar kommt.
Top