HTTP_ACCEPT_LANGUAGE phpinfo() set value problem

Apache, Lighttpd, nginx, Cherokee
Anonymous

HTTP_ACCEPT_LANGUAGE phpinfo() set value problem

Post by Anonymous » 2008-01-31 15:30

Hallo Forum.

1st: Ja, ich weiß noobs wie ich einer bin sollten keinen Webserver betreiben, aber als Student habe ich leider nicht das nötige Kleingeld für einen Managed Server.

2nd: Ja ich habe mich dumm und ämlich gegoogelt und leider nichts gefunden deshalb bin ich hier. Ich lese im Forum schon seit über 2 Jahren aber erst jetzt ist es für mich notwendenig geworden zu posten, dann die restlichen Fragen hatten sich alle durch die Suchfunktion lösen lassen.

3rd: Folgedes Problem:

Habe laut phpinfo:

Code: Select all

HTTP_ACCEPT_LANGUAGE    en-us,en;q=0.5 


ich benötige aber auch de

wie kann ich das machen?

in der entsprechenden vhost.conf habe ich schon versucht:

Code: Select all

php_admin_value HTTP_ACCEPT_LANGUAGE de
php_admin_value HTTP_ACCEPT_LANGUAGE de-de
php_admin_value HTTP_ACCEPT_LANGUAGE de_de
 
php_admin_flag HTTP_ACCEPT_LANGUAGE de
php_admin_flag HTTP_ACCEPT_LANGUAGE de-de
php_admin_flag HTTP_ACCEPT_LANGUAGE de_de


aber das klappt nicht die werte in phpinfo() bleiben gleich.

Hab Debian 4.0 mit Conifxx

thx for help

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: HTTP_ACCEPT_LANGUAGE phpinfo() set value problem

Post by Joe User » 2008-01-31 15:45

HTTP_ACCEPT_LANGUAGE wird durch den Client (Browser) gesetzt, nicht durch PHP. Du musst also Deinen Browser umkonfigurieren...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

Anonymous

Re: HTTP_ACCEPT_LANGUAGE phpinfo() set value problem

Post by Anonymous » 2008-01-31 16:58

1000 Danke ich bin ein Idiot.

Hab durch den Hinweis das Problem jetzt lösen können

mit

Code: Select all

locale -a 


feststellen ob deutsch überhaupt installiert ist und gegebenenfalls mit

Code: Select all

dpkg-reconfigure locales


den Server neu configurieren.

Jetzt klappt alles JUHU