Etch / Plesk 8.3: Postgresql wird nicht richtig eingebunden

Apache, Lighttpd, nginx, Cherokee
dawn
Posts: 64
Joined: 2006-01-05 11:32

Etch / Plesk 8.3: Postgresql wird nicht richtig eingebunden

Post by dawn » 2008-01-18 10:25

Guten Tag,

Ich habe auf einem frisch installierten Debian Etch Server Plesk 8.3 installiert. Es hat eigentlich alles prima geklappt und der Server scheint auch stabil zu laufen, nur Postgresql macht noch Zikcen.

Wenn ich via /etc/init.d/psa start Plesk starte erhalte ich folgende Ausgabe:

Code: Select all

/etc/init.d/psa start
Starting xinetd service... done
Starting bind9 service... done
Starting mysql service... done
Starting qmail service... done
Starting courier-imap service... done
Starting postgresql service... not installed
Starting psa-spamassassin service... not installed
Starting Plesk... done
Starting drwebd service... not installed


Würde ja einen Sinn ergeben, wenn ich die Postgresql-Komponente nicht installiert hätte und Postgresql nicht laufen würde:

Code: Select all

ps ax | grep postgresql
 2125 ?        S      0:00 /usr/lib/postgresql/7.4/bin/postmaster -D /var/lib/postgresql/7.4/main


Auch in Plesk selber wird unter "Services" Angezeigt das Postgresql läuft und der Watchdog überprüft dies ja auch. Ich habe dann gedacht vielleicht liegt es daran das ich den Admin noch nicht definiert habe, habe dies getan und eine Datenbank angelegt. Jetzt wirds noch merkwürdiger:

Die Datenbank wurde zwar erstellt, aber jedes mal wenn ich sie droppen will (via phpPgAdmin) wird die Login-Form von phpPgAdmin wieder angezeigt und die Datenbank welche ich vorher testweise erstellt habe wird nicht gedropt. In Plesk selber wird angezeigt das 0 Datenbanken vorhanden sind.

Ein blick in /var/log/postgresql/postgresql-7.4-main.log sagt folgendes:

Code: Select all

2008-01-17 20:02:01 LOG:  incomplete startup packet
2008-01-17 21:40:40 LOG:  incomplete startup packet
2008-01-17 21:40:40 LOG:  received fast shutdown request
2008-01-17 21:40:40 LOG:  shutting down
2008-01-17 21:40:42 LOG:  database system is shut down
2008-01-17 21:40:43 LOG:  database system was shut down at 2008-01-17 21:40:42 CET
2008-01-17 21:40:43 LOG:  checkpoint record is at 0/A356B0
2008-01-17 21:40:43 LOG:  redo record is at 0/A356B0; undo record is at 0/0; shutdown TRUE
2008-01-17 21:40:43 LOG:  next transaction ID: 1199; next OID: 17156
2008-01-17 21:40:43 LOG:  database system is ready
2008-01-17 21:40:44 LOG:  incomplete startup packet


Wenn ich dazu Google bin ich auf nichts brauchbares gestossen - leider :( Nun seit ihr meine letzte Hoffnung.. Habe ihr irgend eine Idee was ich tun kann?

Gruss,
Dawn

User avatar
daemotron
Administrator
Administrator
Posts: 2635
Joined: 2004-01-21 17:44

Re: Etch / Plesk 8.3: Postgresql wird nicht richtig eingebunden

Post by daemotron » 2008-01-18 18:43

Erwartet Plesk denn Postgresql 7.4 oder doch 8.1? Unterstützt Dein Lizenz-Schlüssel überhaupt das Postgresql-Modul?

dawn
Posts: 64
Joined: 2006-01-05 11:32

Re: Etch / Plesk 8.3: Postgresql wird nicht richtig eingebunden

Post by dawn » 2008-01-18 19:38

Das mit der Postgresql Version ist ein guter Ansatz. Ehrlich gesagt habe ich keine Ahnung und auch nirgends irgendwelche Informationen dazu gefunden. Die Aussage von SW Soft ist eigentlich klar: Plesk läuft unter Etch, und dies heisst für mich entweder PSA interne Packete oder die aktuelle stable release. Und die ist 7.4.

Die Lizenz ist eine Trial-Lizenz für Plesk für 100 Domains mit allen Features frei geschaltet. Diese habe ich erhalten da ich meinen alten Debian Sarge Server migriere. Die Lizenz unterstützt Postgresql sicher, da sonst unter Services Postgresql nicht als gestartet angezeigt wird sondern darauf hingewiesen wird das eine Lizenz benötigt ist. Auch unter dem Punkt "Lizenz" ist das Feature als aktiviert gekennzeichnet.

Hast du noch andere Ideen?

Gruss und besten Dank,
Dawn