Courier bzw mysqlauth bzw libmysqlclient.so.15

Anonymous

Courier bzw mysqlauth bzw libmysqlclient.so.15

Post by Anonymous »

Hallo!
wir wollen einen POP3-Server einrichten (wer hätts gedacht), nachdem smtp jetzt funktioniert. Dabei haben wir uns courier ausgesucht. die benutzerverwaltung wollten wir dann mysql überlassen, was leider nicht funktionieren will, womit wir bei unserem problem wären ^^
zuerst mal was wir haben:
openSuse 10.1
mysql 5.0.26
courier-imap 4.0.6
courier-authlib 0.58
mysql-client 5.0.26

beim starten von courier-authlib wird folgendes ins mail.log geschrieben:
Jan 11 21:46:58 h1328602 authdaemond: modules="authmysql", daemons=5
Jan 11 21:46:58 h1328602 authdaemond: Installing libauthmysql
Jan 11 21:46:58 h1328602 authdaemond: libauthmysql.so: cannot open shared object file: No such file or directory

das mysql log bleibt natürlich leer...
anschließend ham wir versucht, libauthmysql.so (nicht in yast zu finden) über das rpm-paket courier-authlib-mysql-0.58-36.i586.rpm zu installiern, allerdings fehlt uns dafür libmysqlclient.so.15 . Diese wollten wir mit dem Paket libmysqlclient15-5.0.51-2.i586.rpm hinzufügen (was wir ja theoretisch auch schon haben), was wiederrum nicht funktioniert hat:
error: Failed dependencies:
mysql-shared = 5.0.26 is needed by (installed) mysql-devel-5.0.26-12.13.i586


wenn ihr noch fragen habt fragen, wir sind müde und uns fällt nichts mehr ein ;)
danke schon mal!
greetz
Jonny007
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Courier bzw mysqlauth bzw libmysqlclient.so.15

Post by Roger Wilco »

libmysqlclient.so.15 ist in mysql-shared enthalten, das muss installiert sein. Du kannst nicht einfach wild RPMs mit Bibliotheken installieren, die nicht zum restlichen System passen.
Top

Anonymous

Re: Courier bzw mysqlauth bzw libmysqlclient.so.15

Post by Anonymous »

nur ist bei uns halt schon mysql-shared installiert und es funktioniert trotzdem nicht ;)
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Courier bzw mysqlauth bzw libmysqlclient.so.15

Post by Joe User »

Code: Select all

yast -i  courier-authlib-mysql
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

schmidti159
Posts: 4
Joined: 2007-09-06 22:31
Location: Merkendorf

Re: Courier bzw mysqlauth bzw libmysqlclient.so.15

Post by schmidti159 »

Hallo (ich bin der 2. im bunde),
Joe User wrote:yast -i courier-authlib-mysql

Das Problem bei der Sache ist, dass yast dieses Paket bei uns nicht findet! dort gibt es in diesem zusammenhang nur

Code: Select all

courier-authlib-debuginfo, courier-authlib-devel, courier-authlib-ldap, courier-authlib-userdb
und wir wollen jetzt nicht auch wieder postfix komplett auf ldap oder userdb umstellen.
Wir haben einen V-Server bei strato und uns stehen als Installationsquellen nur die strato-internen Server zur Verfügung auf denen dieses Paket anscheinend nicht vorhanden ist.
Ich habe auch schon mehrfach probiert andere Installationsquellen hinzuzufügen was allerdings nie funktioniert hat.
Grüße Schmidti

edit:
auch das installieren der rpm-datei über yast

Code: Select all

 yast -i courier-authlib-mysql-0.58-36.i586.rpm
funktioniert nicht! Es erscheint nur kurz der blaue Hintergrund von yast dann ist man wieder in der Konsole und hat keinerlei Meldungen. Allerdings ist das Paket trotzdem nicht installiert.
Top