Server unterstützt keine sichere Authentifizierung

rene
Posts: 4
Joined: 2008-01-11 17:26

Server unterstützt keine sichere Authentifizierung

Post by rene »

Hallo,

suse 9.0
plesk 7.1.7

Wenn ich in meinem E-Mail-Konto via Thunderbird die sichere Authentifizierung für dieses Konto aktiviere, so kann ich mich dort nicht mehr anmelden, geschweige denn E-Mails versenden.

Angeblich unterstützt mein Server keine sichere Authentifizierung.

Zum besseren Verständnis und zur Sicherheit habe ich euch mal 2 Screenshots gezaubert:

http://img262.imageshack.us/my.php?image=unbenannt1kq0.jpg

http://img246.imageshack.us/my.php?image=unbenannt2or4.jpg

Ist dem so? Was könnte ich dagegen tun?
Das Ganze läuft via Qmail.

Ich habe hier: http://members.elysium.pl/brush/qmail-smtpd-auth/ einen "Patch" für qmail gefunden, der smtp auth. aktivieren soll.

Könnte das klappen? Jemand Erfahrung damit?

---

-> Wer sich fragt, warum ich eine sichere Auth. haben will, wenn ich doch schon einen SSL Tunnel habe dem sei gesagt:

ch beziehe die IP für meinen Internetzugang zuhause dynamisch von meinem ISP (Netcologne).

Dieser weist mir immer eine IP aus der Range 87.78.0.0/16 zu, also z.B.87.78.164.30

Wenn ich nun von zu Hause aus eine E-Mail verschicken möchte, bekomme ich immer die Fehlermeldung, dass der E-Mail-Server keine korrekte Begrüßung gesendet hat und werde auf Spamhaus.org verwiesen - Ref: PBL114008 (siehe: http://www.spamhaus.org/pbl/query/PBL114008).

Hier ist zu lesen, dass die Range 87.78.0.0/16 in der Privacy Block List (PBL) gelisted ist.

Dies sollte mcih aber nicht weiter stören, wenn ich wie im rot makierten Absatz beschrieben meine smtp auth. aktiviere:

"Important: If you are using any normal email software such as Outlook, Entourage, Thunderbird, Apple Mail, and you are being blocked by this Spamhaus PBL listing when you try to send email, the reason is simply that you need to turn on "SMTP Authentication" in your email software settings (Tools : Accounts : Properties : Outgoing Mail Server : check "My server requires authentication").
If you do not know how to do this, ask your Internet Service Provider for help with "SMTP Authentication"."


Da mein Server aber keine smt auth. unterstütz und Netcologne nichts gegen das Listing ihrer IP-Ranges tun kann (oder will - laut Support) sehe ich es als einzige Lösung smtp auth. zu aktivieren, damit ich auch von daheim E-Mails versenden kann.

-> Dazu noch etwas: In Plesk habe ich folgende Einstellungen getroffen:

http://img137.imageshack.us/my.php?image=unbenannt1zf0.jpg

Unter MAPS-Zonen habe ich folgendes eingetragen: zen.spamhaus.org;dnsbl.ahbl.org;dnsbl.njabl.org

Mein HE-Server steht selbst auf keiner Blackliste, jedoch die IP, die mir Netcologne zuweist.

In der zen.spamhaus.org ist die PBL enthalten, wenn ich die zen.spamhaus.org aus den MAPS-Zonen entferne, kann ich auch von zuhause aus Mails verschicken. Jedoch möchte ich diese nicht herausnehmen, da ich mit ihr deutlich weniger SPAM bekomme.

Also möchte ich gerne smtp auth aktivieren um auch über die gelistete IP bzw. dessen Range E-Mails verschicken zu könen.

Wie man sieht habe ich auch die nötigen Felder in Plesk aktiviert, nur leider lässt Thunderbid mich nicht einloggen....


Jemand eine Idee, wie ich es zum laufen bekomme?

Danke!
Last edited by rene on 2008-01-11 21:14, edited 1 time in total.
Top

timeless2
Posts: 416
Joined: 2005-03-04 14:45
Location: Paris

Re: erver unterstützt keine sichere Authentifizierung

Post by timeless2 »

Rene wrote:Hallo,

suse 9.0
plesk 7.1.7

Bei SuSE 9.0 solltest du langsam an ein Update denken! (wird nicht mehr supportet)
Wenn du SMTP-Authentifizierung verwenden möchtest, musst du natürlich den entsprechenden Patch einspielen.
Top

rene
Posts: 4
Joined: 2008-01-11 17:26

Re: erver unterstützt keine sichere Authentifizierung

Post by rene »

timeless2 wrote:Bei SuSE 9.0 solltest du langsam an ein Update denken! (wird nicht mehr supportet)
Wenn du SMTP-Authentifizierung verwenden möchtest, musst du natürlich den entsprechenden Patch einspielen.


Ist denn dies hier der richtige Patch: http://members.elysium.pl/brush/qmail-smtpd-auth/ ?
Kommt SUSE von Haus aus nicht mit smtp Auth.?
Top

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: Server unterstützt keine sichere Authentifizierung

Post by daemotron »

*seufz* das ist eine für Plesk angepasste qmail-Version, die SMTP-Authentifizierung unterstützt, aber eben nur PLAIN und nicht CRAM/MD5. Ehrlich, bei den Software-Versionen (Distribution, Plesk) ist das Auth-Verfahren für den Mailserver Dein geringstes Problem...
Top

rene
Posts: 4
Joined: 2008-01-11 17:26

Re: Server unterstützt keine sichere Authentifizierung

Post by rene »

Naja... nicht wenn ich keine E-Mails verschicken kann ;-)
Top