Problem mit Update der Modsecurity-Regeln

Apache, Lighttpd, nginx, Cherokee
toberkel
Posts: 86
Joined: 2004-07-16 17:22
Location: Hamburg

Problem mit Update der Modsecurity-Regeln

Post by toberkel » 2008-01-10 09:50

Hi.

Ich benutze seit kurzem mod_security 1.9 für den Apache 1.3. Das funktioniert soweit auch ganz gut. Ich hab einige angepasste Regeln und vorgefertigte von gotroot.com. Das Problem ist nur, wenn ich das Script modsec.sh ausführe, welches die aktuelle rules.conf und blacklist.conf von gotroot.com holt und den Apache neustartet, dann bekomm ich beim neustarten immer folgenden Fehler:

Code: Select all

Syntax error on line 404 of /etc/modsecurity/rules.conf:
Invalid regular expression: ;x20+?perlx20+[A-Za-z|0-9]+;
 failed!

Weiss jemand woran das liegen könnte?

MfG,

toberkel

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Problem mit Update der Modsecurity-Regeln

Post by Joe User » 2008-01-12 20:07

Vermutlich ist die rules.conf von gotroot nicht kompatibel mit mod_security <2.0?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

toberkel
Posts: 86
Joined: 2004-07-16 17:22
Location: Hamburg

Re: Problem mit Update der Modsecurity-Regeln

Post by toberkel » 2008-01-13 11:02

Sowas hab ich auch schon vermutet. Hab das ganze nun so gelöst das sed die ein #-Zeichen davor setzt... Aber das ist im Moment nicht so schlimm wie mein anderes Modsecurity Problem ;)

MfG,

toberkel