PHP Fehler

Apache, Lighttpd, nginx, Cherokee
alex007
Posts: 11
Joined: 2008-01-07 21:23

PHP Fehler

Post by alex007 » 2008-01-07 21:25

Hallo,

ich habe heute auf eine CentOS (Redhat) Kiste PHP installiert bzw. kompiliert. Vorher war dort eine rpm PHP (über yum).

Jedoch nach einem Start von Apache (httpd) kam folgendes:

/etc/init.d/httpd start
Starting httpd: httpd: Syntax error on line 206 of /etc/httpd/conf/httpd.conf: Cannot load /usr/lib/httpd/modules/libphp5.so into server: /usr/lib/httpd/modules/libphp5.so: undefined symbol: executor_globals
[FAILED]

Ich weß nicht, womit ich anfangen soll. Hoffe mir kann jemand helfen.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11139
Joined: 2003-02-27 01:00
Location: Hamburg

Re: PHP Fehler

Post by Joe User » 2008-01-07 21:37

Weshalb kompilierst Du selbst, statt die CentOS-RPMs zu verwenden? Wie genau hast Du kompiliert? Welche Patches hast Du verwendet?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

alex007
Posts: 11
Joined: 2008-01-07 21:23

Re: PHP Fehler

Post by alex007 » 2008-01-07 21:43

Weil die RPM gd ausschaltet: "--without-gd".

So sieht meine Configure aus:

./configure -with-apxs2=/usr/sbin/apxs --with-bz2 --with-curl --with-zlib --with-gd --with-sqlite --libdir=/usr/lib --with-libdir=lib --with-libxml-dir=/usr --with-mime-magic=/etc/httpd/conf/magic --exec-prefix=/usr --libexecdir=/usr/libexec --with-jpeg-dir=/usr --with-pcre-regex=/usr --with-png-dir=/usr --with-exec-dir=/usr/bin --prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --with-freetype-dir=/usr

php-5.2.5 wurde kompiliert.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11139
Joined: 2003-02-27 01:00
Location: Hamburg

Re: PHP Fehler

Post by Joe User » 2008-01-07 22:46

Die Distributions-RPMs sind in der Regel modular aufgabaut, weshalb der ./configure aus phpinfo() nicht mehr als Referenz herangezogen werden kann.
Bitte selbst anpassen:

Code: Select all

yum install php[45]-gd
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

alex007
Posts: 11
Joined: 2008-01-07 21:23

Re: PHP Fehler

Post by alex007 » 2008-01-07 23:08

Jedoch ist es nicht so bei Centos, ich habe natürlich schon yum install gd durchgeführt:

"php-gd is already the newest version."

Trotzdem funktioniert GD nicht.

alex007
Posts: 11
Joined: 2008-01-07 21:23

Re: PHP Fehler

Post by alex007 » 2008-01-07 23:16

Habe da noch paar weitere Pakete wie ..-devel usw. installiert. Scheint nun zu klappen. Danke!