[gelöst] E-Mail versenden funktioniert nicht

sandro
Posts: 46
Joined: 2007-02-11 23:39

[gelöst] E-Mail versenden funktioniert nicht

Post by sandro »

Hallo,
auf einem Ubuntu-Server läuft Postfix + Courie. Ich kann Problemlos Email empfangen. Bei senden kann ich allerdings nur innerhalb meiner Domains Mail senden.

D.h. wenn ich von info@meindomain.de an abc@gmx.de ein Email sende, erhalte ich sofort folgendes: “Ihre Nachricht hat einige oder alle Empfänger nicht erreicht “ :cry:

Woran kann es liegen?

Vor kurzem hat mir meinen Provider eine neue IP-Adresse zu geteilt. Seitdem habe ich das Problem. Vorher lief alles korrekt.

Kann es am DNS – Server liegen? Zurzeit benutze ich den DNS-Server von HanseNet, denn bei DNS-Server von meinem Provider können meine Domains nicht erreich werden.

Danke im Voraus, Sandro
Last edited by sandro on 2008-01-08 11:31, edited 1 time in total.
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: E-Mail versenden funktioniert nicht

Post by Roger Wilco »

Logs?
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: E-Mail versenden funktioniert nicht

Post by sandro »

Hallo,
hier ist mail.log als ich versucht habe ein Mail zu versenden:

Code: Select all

Jan  7 17:33:27 server287762 postfix/smtpd[18705]: connect from d191225.adsl.hansenet.de[85.182.x.x]
Jan  7 17:33:27 server287762 postfix/smtpd[18705]: 9D7C22781B4: client=d191225.adsl.hansenet.de[85.182.x.x], sasl_method=LOGIN, sasl_username=info@meindomain.de
Jan  7 17:33:30 server287762 postfix/smtpd[18705]: 74CFD2781B4: client=d191225.adsl.hansenet.de[85.182.x.x], sasl_method=LOGIN, sasl_username=info@meindomain.de
Jan  7 17:33:30 server287762 postfix/cleanup[18733]: 74CFD2781B4: message-id=<20080107163330.74CFD2781B4@server.aol.de>
Jan  7 17:33:30 server287762 postfix/qmgr[18517]: 74CFD2781B4: from=<info@meindomain.de>, size=2340, nrcpt=1 (queue active)
Jan  7 17:33:30 server287762 postfix/smtpd[18705]: disconnect from d191225.adsl.hansenet.de[85.182.x.x]
Jan  7 17:33:33 server287762 postfix/smtp[18736]: 74CFD2781B4: to=<abcde@gmx.de>, relay=mx0.gmx.net[213.165.x.x], delay=3, status=sent (250 2.6.0 Message accepted {mx071})
Jan  7 17:33:33 server287762 postfix/qmgr[18517]: 74CFD2781B4: removed

Gruß Sandro.
Last edited by sandro on 2008-01-07 17:56, edited 1 time in total.
Top

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: E-Mail versenden funktioniert nicht

Post by daemotron »

Poste mal bitte die Ausgabe von postconf -n
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: E-Mail versenden funktioniert nicht

Post by sandro »

Hallo,
hier ist postconf -n
Gruß

Code: Select all

root@server287762 :~# postconf -n
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
inet_interfaces = all
mydestination = localhost
myhostname = server.aol.de
mynetworks = 127.0.0.0/8, x.x.x.x             (wobei x.x.x.x IP des Servers ist)
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, rej                                                              ect_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
virtual_alias_domains =
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_forwardings.cf mysql:/etc/                                                              postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_uid_maps = static:5000
root@server287762 :~#
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: E-Mail versenden funktioniert nicht

Post by sandro »

Dazwischen habe ich herausgefunden, dass die E-Mails eigentlich z.B. an GMX oder Compuserve ankommen, aber leider werden dort als Spamverdacht angehalten.

Kann mir jemand sagen, woran kann es liegen? :?:

Gruß
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: E-Mail versenden funktioniert nicht

Post by Joe User »

RDNS und myhostname passen nicht zueinander...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: E-Mail versenden funktioniert nicht

Post by sandro »

Hallo,
Ich habe nicht verstanden, wie Du es meinst?
Meinst Du vielleicht: myhostname = server.aol.de ?
Ich habe immer "myhostname = server.aol.de" eingetragen gehabt und GMX hat meine E-Mails nicht als Spam betrachtet.

Sollte ich vielleicht myhostname = server287762 .de oder myhostname = meinDomain .de ?
Ich habe aber ca. 10 Domains auf dem Server, welche soll ich für myhostname eintragen?
Gruß
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: E-Mail versenden funktioniert nicht

Post by Roger Wilco »

Lass $myhostname weg und sorge dafür, dass dein System den korrekten Hostname (FQDN!) gesetzt hat. -> /etc/hostname, `man hostname`
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: E-Mail versenden funktioniert nicht

Post by sandro »

Wenn ich die Zeile: myhostname = server.aol.de auskommentiere, beim “reload“ von postfix bekomme ich :

Warning: My hostname server287762 is not afully qualified name – set my hostname or mydomain in /etc/postfix/main.cf

Beim Versenden von E-Mails kommen sie zurück “Undelivered Mail Returned to Sender”
Wenn ich warden : myhostname = server287762 eintrage, bekomme ich zwar keine Warnung von postfix, aber die E-Mail kommen auch zurück “Undelivered Mail Returned to Sender”

Gruß
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: E-Mail versenden funktioniert nicht

Post by Roger Wilco »

Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: E-Mail versenden funktioniert nicht

Post by Joe User »

<RDNS> (siehe SuFu) bitte entsprechend ersetzen:

Code: Select all

myhostname = <RDNS>
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: E-Mail versenden funktioniert nicht

Post by sandro »

Echt toll, es funktioniert. Ich kann endlich wieder mal korrekt E-Mail versenden! :lol:
Ich habe allerdings:
myhostname = MeinDomain1.de eingetragen und es funktioniert für alle Account bzw. Domain-Namen.

Sollte ich vielleicht besser wie folgt die Eintragung machen:

myhostname = MeinDomain1.de, MeinDomain2.de, … MeinDomain10.de

Gruß
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: E-Mail versenden funktioniert nicht

Post by sandro »

Ok, ich habe es ausprobiert. Man kann nur ein Hostname/Damainname eintragen: myhostname = MeinDomain1

Wenn ich ein E-Mail von info@MeinDomain3 versende und mit Outlook empfange, dann unter Eigenschaften kann ich die Daten dieses E-Mails anschauen. Ich sehe unter anderem MeinDomain1.de, aber das E-Mail kommt aus MeinDomain3.de.

MeinDomain1.de und MeinDomain3.de sind zwei unterschiedlichen Firmen!
Wie kann ich also erreichen, dass wenn ich ein E-Mail von z.B. MeinDomain3.de versende, nur die Daten von dieser Domain/Account zu sehen sein werden?

Gruß

Ich glaube, es wäre besser, wenn ich ein neues Thread eröffnen würde.
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: E-Mail versenden funktioniert nicht

Post by Roger Wilco »

Sandro wrote:Wie kann ich also erreichen, dass wenn ich ein E-Mail von z.B. MeinDomain3.de versende, nur die Daten von dieser Domain/Account zu sehen sein werden?

X MTAs auf X verschiedenen IP-Adressen betreiben. Oder einfach einen "neutralen" Hostname wählen.
Top

sandro
Posts: 46
Joined: 2007-02-11 23:39

Re: [gelöst] E-Mail versenden funktioniert nicht

Post by sandro »

Danke für den Tipp.
An ein "neutralen" Hostname, habe ich auch selbst gedacht.
Aber mit "X MTAs auf X verschiedenen IP-Adressen betreiben wählen" kann ich nicht viel anfangen.
Es wäre schön, wenn Du es etwas ausführlicher erklären könntest (oder ein llink ?)

Gruß
Top