Error beim installieren neuer komponenten - z.B. Webalizer

Apache, Lighttpd, nginx, Cherokee
malo
Posts: 61
Joined: 2005-01-03 22:40

Error beim installieren neuer komponenten - z.B. Webalizer

Post by malo » 2007-12-17 23:03

hi wenn ich webalizer instalieren will, oder einfach nur nen apt-get upgrade machen will, kommt folgendes :(


Code: Select all

Debian-40-etch-32-LAMP:~# apt-get install webalizer
Reading package lists... Done
Building dependency tree... Done
The following NEW packages will be installed:
  webalizer
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
5 not fully installed or removed.
Need to get 0B/346kB of archives.
After unpacking 1245kB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously deselected package webalizer.
(Reading database ... 53129 files and directories currently installed.)
Unpacking webalizer (from .../webalizer_2.01.10-32_i386.deb) ...
Setting up exim4-config (4.63-17) ...
Error: Unsplit config selected and /etc/exim4/exim4.conf.template missing ... exiting
dpkg: error processing exim4-config (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of exim4-base:
 exim4-base depends on exim4-config (>= 4.30) | exim4-config-2; however:
  Package exim4-config is not configured yet.
  Package exim4-config-2 is not installed.
  Package exim4-config which provides exim4-config-2 is not configured yet.
dpkg: error processing exim4-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of exim4-daemon-light:
 exim4-daemon-light depends on exim4-base (>= 4.63); however:
  Package exim4-base is not configured yet.
dpkg: error processing exim4-daemon-light (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of exim4:
 exim4 depends on exim4-base (>= 4.63); however:
  Package exim4-base is not configured yet.
 exim4 depends on exim4-daemon-light | exim4-daemon-heavy | exim4-daemon-custom; however:
  Package exim4-daemon-light is not configured yet.
  Package exim4-daemon-heavy is not installed.
  Package exim4-daemon-custom is not installed.
dpkg: error processing exim4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rkhunter:
 rkhunter depends on exim4 | postfix | sendmail | mail-transport-agent; however:
  Package exim4 is not configured yet.
  Package postfix is not installed.
  Package sendmail is not installed.
  Package mail-transport-agent is not installed.
  Package ssmtp which provides mail-transport-agent is not installed.
  Package exim which provides mail-transport-agent is not installed.
  Package postfix which provides mail-transport-agent is not installed.
  Package exim4-daemon-heavy which provides mail-transport-agent is not installed.
  Package exim4-daemon-light which provides mail-transport-agent is not configured yet.
dpkg: error processing rkhunter (--configure):
 dependency problems - leaving unconfigured
Setting up webalizer (2.01.10-32) ...

Errors were encountered while processing:
 exim4-config
 exim4-base
 exim4-daemon-light
 exim4
 rkhunter
E: Sub-process /usr/bin/dpkg returned an error code (1)



hat einer ne idee, wie ich das fixen kann?

danke

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: Error beim installieren neuer komponenten - z.B. Webalizer

Post by flo » 2007-12-17 23:28

installiere mal Postfix - rkhunter nippelt wegen des exims ab und irgendwas ist da zerschossen. webalizer müsste aber eigentlich installiert worden sein - ab da steht doch kein Fehler mehr!?