Hilfe! Emails einiger Absender kommen nicht an.

stuber79
Posts: 14
Joined: 2006-07-08 10:39

Hilfe! Emails einiger Absender kommen nicht an.

Post by stuber79 »

Hallo zusammen,

eins vorweg: Ja, ich weiß, wie dämlich es ist, mit meinen geringen Serverkenntnissen einen Rootserver zu betreiben. Das war meine bisher blödeste Entscheidung und ich bereue Sie schon ziemlich lange.

Okay, nun zu meinem Problem (Betrifft einen 1und1-RootServer mit SUSE 9.1 und Plesk 7.5):

Heute rief mich einer meiner Hosting-Kunden an und sagte, bei ihm kämen viele E-Mails nicht an. Um sicherzustellen, dass diese Mails nicht in seinem Firmennetzwerk untergehen, hat er zunächst seinen PC-Service-Kerl gefragt, der sein Netzwerk betreut. Dieser sieht allerdings die Verantwortung bei mir.

Natürlich habe ich nun angefangen zu recherchieren. Folgendermaßen bin ich vorgegangen:

  • Ich habe über den Webmailer die Eingänge des Postfachs geprüft, um sicherzustellen, dass ich meine Testmails sehe, bevor diese vom Kundenrechner abgeholt werden und dann evtl. bei diesem verschwinden.
  • Alle Testmails, die ich versandt habe, kamen dabei völlig problemlos an. Auch die eine oder andere Spam-Mail habe ich in seinem Postfach entdeckt.
  • Für mich sah das also so aus, als ob das Postfach einwandfrei funktioniert.
  • Ich habe nun den Absender einer verschollenen Mail gebeten, diese nocheinmal zu senden und meine E-Mail-Adresse als CC anzugeben, (damit ich die Möglichkeit habe, die Empfängeradresse auf Richtigkeit zu prüfen).
  • Und tatsächlich: Bei mir selbst kam die E-Mail an, die Empfängeradresse meines Kunden war auch richtig angegeben, aber über den Webmailer meines Kunden konnte ich beim besten Willen keinen Eingang dieser E-Mail feststellen.
Nun stehe ich dumm da. Meine Mailbox befindet sich auf dem gleichen Server wie die des Kunden mit der verschollenen Mail. Alle Einstellungen sollten identisch sein, der Absender ist der gleiche. Bei mir kommt die Mail an, beim Kunden nicht.

Woran könnte das liegen?!? Welche Faktoren könnten dafür verantwortlich sein?

Meine Überlegung war nun, dass in irgendeinem Logfile ja etwas drin stehen müsste, wenn mein Server eine E-Mail ablehnt. Nur, wo finde ich die entsprechenden Logfiles?

Ihr seht schon, ich hab keinen Plan und sollte mich mit sowas gar nicht selbst beschäftigen. Ich war nur dumm genug, der Einschätzung eines 1&1-Kundenberaters zum Thema "wie kritisch ist es, als Laie einen Rootserver zu betreiben" Glauben zu schenken. Und jetzt steh ich da mit meinen Problemen. So bald wie möglich werde ich mir bei einem vernünftigen Hoster einen ManagedServer mieten, allerdings muss ich erst mal dieses akute Problem beheben, bevor ich mich damit beschäftigen kann.

Ich bitte daher dringend um Tipps und Ideen, die mir bei der Lösung dieses Problems behilflich sein können.

Tausend Dank im Voraus!
Top

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: Hilfe! Emails einiger Absender kommen nicht an.

Post by Roger Wilco »

1. SuSE Linux 9.1 wird schon lange nicht mehr supportet. Wechsle so schnell wie möglich auf eine noch unterstützte Version!

2. Schau in deine Mail Logs (/var/log/mail* und /usr/local/psa/var/log/*), ob die E-Mail(s) angenommen wurde(n). Das bringt mehr, als einfach nur mit dem Webmail Interface in die Postfächer zu schauen.
Top

stuber79
Posts: 14
Joined: 2006-07-08 10:39

Hab in den Logfiles was gefunden... was bedeutet das?

Post by stuber79 »

Hi,

danke schonmal für den Hinweis auf die richtigen Logfiles.

Ich habe auch was Interessantes gefunden.

Und zwar wurde eine Testmail versandt, die meinen Kunden (bei dem die Mail nicht ankommt) als Empfänger und mich (bei mir kommt sie an) im CC hatte.

In dem Logfile habe ich nun einen Eintrag gefunden, der seltsamerweise den Empfang der E-Mail an mich als CC dokumentiert, vom Eingang der Email an den eigentlichen Empfänger ist aber nichts zu sehen...

Was kann das bedeuten?

Hier der Ausschnitt ausm Logfile:

Code: Select all

Dec  3 13:53:17 p15187198 qmail: 1296186323.365767 new msg 20980483
Dec  3 13:53:17 p15187198 qmail: 1296186323.365878 info msg 20980483: bytes 595847 from <info@irgendwas.de> qp 29838 uid 2020
Dec  3 13:53:17 p15187198 qmail: 1296186323.376033 starting delivery 2865: msg 20980483 to local 21-info@meineadresse.com
Dec  3 13:53:17 p15187198 qmail: 1296186323.376109 status: local 1/10 remote 0/20
Dec  3 13:53:17 p15187198 qmail: 1296186323.482880 delivery 2865: success: did_1+0+1/
Dec  3 13:53:17 p15187198 qmail: 1296186323.482957 status: local 0/10 remote 0/20
Dec  3 13:53:17 p15187198 qmail: 1296186323.482969 end msg 20980483
Dec  3 13:53:18 p15187198 pop3d: IMAP connect from @ [86.190.159.91]DEBUG: Connection, ip=[86.190.159.91]


Was ich daran nicht verstehe: Wenn mein Server daran Schuld wäre, dass die E-Mail bei meinem Kunden nicht ankommt, müsste an dieser Stelle doch zumindest etwas vom Zustellungsversuch stehen, oder? Stattdessen steht nur etwas von der erfolgreichen Zustellung an mich...

Kann ich anhand des Logfiles so ausschließen, dass mein Server überhaupt jemals die verschollene E-Mail erhalten hat?

Wenn ja, wo um alles in der Welt kann die E-Mail dann abgeblieben sein? (Die Empfängeradresse war garantiert richtig geschrieben, das habe ich kontrolliert).
Top

bernsteinkater
Posts: 67
Joined: 2006-06-27 11:47

Re: Hilfe! Emails einiger Absender kommen nicht an.

Post by bernsteinkater »

Zeigt MX-Eintrag der problematischen Domain auf Deine IP?

("dig mx $domain.de +short" und dann "host $mx.de" - jeweils ohne " und ohne $)
Top

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: Hilfe! Emails einiger Absender kommen nicht an.

Post by flo »

Teste das dochmal von einem GMX-Account aus - die lokale Zustellung sagt im Problemfall gar nichts aus.
Top

stuber79
Posts: 14
Joined: 2006-07-08 10:39

Re: Hilfe! Emails einiger Absender kommen nicht an.

Post by stuber79 »

Meine Tests im Überblick:

1. Ich habe an die Adresse, die Probleme macht (info@meinkunde.de) eine Testmail von einem Yahoo-Account gesendet.
>> Diese kam problemlos an

2. Der E-Mail-Absender, dessen E-Mails nicht bei meinem Kunden ankommen, hat eine Testmail gesendet, bei der die problematische Kundenadresse (info@meinkunde.de) als Empfängeradresse und meine eigene E-Mail-Adresse als CC eingetragen war.
>> Bei mir kam die E-Mail an, bei meinem Kunden nicht. In den Logfiles ist der Eingang der E-Mail an meine Adresse feststellbar (siehe Auszug aus dem Logfile weiter oben), dass an den Kunden überhaupt irgendetwas gesendet wurde, lässt sich dem Logfile nicht entnehmen.

Was könnte ich noch prüfen? Der MX-Record muss doch eigentlich richtig sein, sonst könnte meine Testmail von meinem Yahoo-Account nicht ankommen, oder?
Top

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: Hilfe! Emails einiger Absender kommen nicht an.

Post by flo »

stuber79 wrote:Der MX-Record muss doch eigentlich richtig sein, sonst könnte meine Testmail von meinem Yahoo-Account nicht ankommen, oder?


Richtig - wenn Deine Mail auch über die Yahoo-Server ging.
Top

stuber79
Posts: 14
Joined: 2006-07-08 10:39

Re: Hilfe! Emails einiger Absender kommen nicht an.

Post by stuber79 »

flo wrote:Richtig - wenn Deine Mail auch über die Yahoo-Server ging.


Dann bin ich kurz davor, mich als unschuldig bezüglich dieses Problems anzusehen ;-)

Wichtige Frage noch:
Wie beweist Ihr Euren Kunden, dass Ihr nix dafür könnt, wenn sich bei Euch jemand über angeblich nicht erhaltene E-Mails beschwert? Mein Kunde möchte mich grad für jede E-Mail verantwortlich machen, die er nicht bekommen hat. Damit krieg ich's auch ab, wenn sein lokaler Spamfilter was rausschmeisst oder wenn er einfach was verschlampt oder vergisst, dass er ne Mail doch bekommen hat...

Mir wäre daher wichtig, schnell und unkompliziert einen handfesten Beweis für meine einwandfreie Dienstleistung bringen zu können? Wie regelt Ihr sowas?
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Hilfe! Emails einiger Absender kommen nicht an.

Post by Joe User »

IMHO:
Dem Kunden muss mitgeteilt werden ob und welche Anti-Spam/Virus-Massnahmen serverseitig betrieben werden und welche Konsequenzen dies haben kann. Zudem muss sorgfältig und lückenlos geloggt werden, um die Zustellung/Abweisung einer Mail dem Kunden gegenüber beweisen zu können. Ist dies Alles gegeben, muss der Absender das korrekte Versenden der Mail dem Kunden gegenüber nachweisen. Ist auch dies geschehen, bleibt nur noch ein (temporäres) Problem zwischen Versender und eigenem Mailserver übrig, was im Allgemeinen nicht beeinflusst werden kann...
Top

stuber79
Posts: 14
Joined: 2006-07-08 10:39

DES RÄTSELS LÖSUNG! ...hoffe ich ...

Post by stuber79 »

Hola,

nach viel Grübeln habe ich jetzt den möglichen Grund für das Verschwinden der E-Mail(s) entdeckt.

Ich hätte jetzt gerne Eure Einschätzung, ob ich damit richtig liegen kann.

Meine Erklärung:

Der Absender und der Empfänger hatten Ihren Webspace und auch ihre E-Mail-Postfächer bis vor einiger Zeit auf dem gleichen Server eines Providers. Der Empfänger ist nun von diesem Server auf meinen Server umgezogen. Seither zeigen natürlich auch die DNS-Einträge der Domain auf meinen Server.

Bevor der Empfänger auf meinen Server umgezogen ist, konnte er E-Mails vom Absender zugestellt bekommen, in dem diese auf dem Server einfach von einem Verzeichnis in ein anderes verschoben wurden. Die E-Mails mussten damals ja eigentlich gar nicht wirklich extern "versandt" werden.

Seit der Empfänger umgezogen ist, geht das natürlich auf diesem Wege nimmer.

Ich vermute nun, dass auf dem Mailserver des alten Providers noch immer das Postfach des Empfängers existiert, weshalb dieser gar nicht erst versucht, die Mails des Absenders extern zu versenden. Stattdessen schiebt er diese vermutlich immer noch einfach in das alte Postfach, welches natürlich nicht mehr abgeholt wird.

Das wäre aus meiner Sicht eine Erklärung für den Verbleib der verschollenen E-Mails.

Jetzt meine Frage: Klingt das plausibel?


Wenn ja, fällt Euch irgendeine Möglichkeit ein, wie ich das nachweisen kann? Sollte ich mit meiner Vermutung nämlich Recht haben, hätte ich ganz gerne eine gewisse Aufwandsentschädigung des eigentlich schuldigen. Wenn ich nun aber einfach bei dem Provider anrufe und mal nachfrage, wird der das kaum zugeben und das Problem still und heimlich beheben.

Vielen Dank im Voraus für Eure stets schnelle und kompetente Hilfe!
Top

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: Hilfe! Emails einiger Absender kommen nicht an.

Post by flo »

telnet server 25 --> smtp-session für diese email initiieren.

Wenn der andere Server die Mail ohne Aithentifizierung annimmt, kannst Du mit Sicherheit davon ausgehen, daß der andere Provider die Mails noch lokal annimmt.

Die Telnet-Session würde ich dann in Kopie an Deinen Kunden, den Provider und die "Gegenstelle" schicken.

Übrigens ist das die plausibelste Erklärung dafür - wann war denn der Umzug?
Top

stuber79
Posts: 14
Joined: 2006-07-08 10:39

Wow, sieht gut aus!

Post by stuber79 »

flo wrote:telnet server 25 --> smtp-session für diese email initiieren.

Wenn der andere Server die Mail ohne Aithentifizierung annimmt, kannst Du mit Sicherheit davon ausgehen, daß der andere Provider die Mails noch lokal annimmt.

Die Telnet-Session würde ich dann in Kopie an Deinen Kunden, den Provider und die "Gegenstelle" schicken.

Übrigens ist das die plausibelste Erklärung dafür - wann war denn der Umzug?


Danke für den Tipp, ich hab das natürlich gleich mal getestet und folgendermaßen lief die Telnet-SMTP-Session ab:

Code: Select all

220 mail.irgendwas.de ESMTP
HELO
250 mail.irgendwas.de
MAIL FROM:test@test.de
250 ok
RCPT TO:info@meinkunde.de
250 ok
DATA
354 go ahead
SUBJECT: Testnachricht Nr. 1

Hallo,
dies ist nur eine Testnachricht.

.
250 ok 1196822478 qp 10152


Ich vermute mal, das bedeutet, dass der Server Mails für diese Domain noch annimmt, d. h. es existiert dort wohl noch das alte Postfach, in dem sich vermutlich alle verschollenen Mails befinden.

Ich habe auch mal eine andere E-Mail-Adresse getestet, die sich definitiv nicht auf diesem Server befindet und da kam die Meldung "Sorry, that Domain isn't in my list of allowed RCTP-Hosts" (oder so ähnlich).

Damit sollte doch sichergestellt sein, dass er nicht jeden Müll annimmt, sondern nur die E-Mails für die er auch ein Postfach hat.

Liege ich damit richtig?

Der Umzug ist übrigens jetzt ca. 10 Monate her. Ich gehe aber davon aus, dass einfach vergessen wurde, den Kunden auf dem Server des alten Providers zu löschen. Ist schließlich auch eine kleine Firma, die nicht gerade für ihre zuverlässige Arbeit bekannt ist.

Cool... Wenn ich jetzt noch von Euch die abschließende Feststellung bekomme, dass meine Unschuld bezüglich der vermissten Mails auf diesem Weg bewiesen wurde, bleibt mir nur noch, Euch tausend Dank zu sagen für die schnellen und qualifizierten Antworten.

Und wieder hab ich viel Interessantes gelernt! :-)

Danke!
Top

flo
RSAC
Posts: 2297
Joined: 2002-07-28 13:02
Location: Berlin

Re: Hilfe! Emails einiger Absender kommen nicht an.

Post by flo »

Schaut so aus - die Möglichkeit eines offenen Relay hast Du ausgeschlossen.

Sprich Deinen Kunden zuerst einmal darauf an, ob er seine alten POP3-Daten noch hat - wenn er dann über seinen alten Provider plötzlich seine aktuellen Mails bekommt, zählt das mehr als jegliche Argumentation von Dir.
Top

stuber79
Posts: 14
Joined: 2006-07-08 10:39

Re: Hilfe! Emails einiger Absender kommen nicht an.

Post by stuber79 »

Cool, dann bin ich beruhigt und zufrieden :-)

Mein Kunde ist schon auf der Suche nach seinen alten POP3-Daten. Ich hoffe sehr, dass er diese findet. Vermutlich wird er damit alles abholen können, was er bisher vermisst.

Wie gesagt: Vielen Dank für die schnelle und kompetente Hilfe!
Top