fast_cgid für einen vhost deaktivieren

Apache, Lighttpd, nginx, Cherokee
whyte
Posts: 61
Joined: 2006-01-09 14:21

fast_cgid für einen vhost deaktivieren

Post by whyte » 2007-11-26 12:29

Hallo,

ich habe jetzt auf meinem Server mod_fastcgid aktiviert, alles läuft auch wunderbar. Bis auf einem vhost, der ab und zu mal grosse Dateien verarbeiten muss und somit in einen Servererror 500 läuft.
Wie kann ich in der vhost.conf bei diesem vhost den fast_cgi deaktivieren ?

Vielen Dank
Gruß
Marco

handeglo
Posts: 62
Joined: 2007-11-21 11:26

Re: fast_cgid für einen vhost deaktivieren

Post by handeglo » 2007-11-26 12:42

verwendest du irgend ein Confixx ???
Control Panel?
Last edited by handeglo on 2007-11-26 14:57, edited 2 times in total.

whyte
Posts: 61
Joined: 2006-01-09 14:21

Re: fast_cgid für einen vhost deaktivieren

Post by whyte » 2007-11-26 12:55

nein, alles Handarbeit ...

whyte
Posts: 61
Joined: 2006-01-09 14:21

Re: fast_cgid für einen vhost deaktivieren

Post by whyte » 2007-11-26 14:22

Also
auch den Eintrag

Options +ExecCGI

weglassen, bringt nichts. da läuft dann immernoch mod_fcgi

handeglo
Posts: 62
Joined: 2007-11-21 11:26

Re: fast_cgid für einen vhost deaktivieren

Post by handeglo » 2007-11-26 14:34

wie du ja schon weisst hat jedes Domaön ein eigenen htpp.conf...
wir f doch al da einen Blick unter

/srv/www/vhosts/deindomän/conf/http.include

Options ExecCGI einfach weg lasses

und starte den apache mit

apache2ctl stop
apache2ctl start

gruss

whyte
Posts: 61
Joined: 2006-01-09 14:21

Re: fast_cgid für einen vhost deaktivieren

Post by whyte » 2007-11-26 14:39

Hallo

also bei mir habe ich eigentlich nur eine httpd.conf ...
aber mehrere vhost.conf

in der entsprechenden habe ich diese Option schon weg gelassen.

Allerdings zeigt phpinfo() immernoch den FCGI an.

ich habe auch schon
option -ExecCGI
gemacht, aber das war auch nix.

Gruß

handeglo
Posts: 62
Joined: 2007-11-21 11:26

Re: fast_cgid für einen vhost deaktivieren

Post by handeglo » 2007-11-26 14:47

also du hast doch bestimmt irgendwelche Domäns, von der aus du deine seiten präsentierst? wenn nein dann erklär mir mal. wo dein Domaän verzeichnis ist!!!
oder hast du doch keinnen Domän?
Es läuft Folgendermaßen.
Du hast für jeden Domän ein service in Plesk zur Verfügung, wo du deine Module aktivierst oder auch unaktiv macht. Da du aber kein Plesk oder ähnliches verwendest kannst du über den Konsole in deinem Domän Verzeichnis in der Apache Konfigurationsdatei einstellen. Die betrifft dann NUR aber dein einen Domön und nicht den ganzen Server !!!!

whyte
Posts: 61
Joined: 2006-01-09 14:21

Re: fast_cgid für einen vhost deaktivieren

Post by whyte » 2007-11-26 15:00

Hallo,

ja das ist richtig.
Ich habe mehrere Domains, pro Domain eine vhost.conf
In dieser vHost.conf jeweils immer Option +ExecCGI

Bei diesem einen vhost.conf habe ich das nun rausgenommen. Aber dennoch habe ich auf diesem vhost dann bei phpinfo() die Anzeige, dass es aktiv ist.

Gruß

handeglo
Posts: 62
Joined: 2007-11-21 11:26

Re: fast_cgid für einen vhost deaktivieren

Post by handeglo » 2007-11-26 15:32

kannst du bitte bei bzw Fehlermeldung und die konfigurations datei posten ....

whyte
Posts: 61
Joined: 2006-01-09 14:21

Re: fast_cgid für einen vhost deaktivieren

Post by whyte » 2007-11-26 15:50

Hier die vhost.conf, in der ich das abschalten möchte

fcgid ist per sysconfig.d/apache2 aktiviert.

Code: Select all

# SHOP ADMIN SERVER 1
<VirtualHost *:80>
 ServerAdmin webmaster@mm-shop-hosting.ath.cx
 ServerName shopadmin.mm-sh.ath.cx
 ServerAlias sa1.mm-sh.ath.cx
 DocumentRoot /srv/www/htdocs/m/mm-sh.ath.cx/sa1/
 CustomLog /var/log/apache2/sa1.mm-sh.ath.cx_access_log combined
 ErrorLog /var/log/apache2/sa1.mm-sh.ath.cx_error_log
 DirectoryIndex index.html index.shtml start.htm start.html start.shtml index.php
 php_admin_value open_basedir /srv/www/htdocs/m/mm-sh.ath.cx:/tmp
 php_admin_value upload_tmp_dir /srv/www/htdocs/m/mm-sh.ath.cx/tmp
 php_admin_value session.save_path /srv/www/htdocs/m/mm-sh.ath.cx/tmp
</VirtualHost>


eine phpinfo kannst du hier abfragen:

http://sa1.mm-sh.ath.cx/phpinfo.php

gruß + danke

handeglo
Posts: 62
Joined: 2007-11-21 11:26

Re: fast_cgid für einen vhost deaktivieren

Post by handeglo » 2007-11-26 16:04

Ok ich sehe da kein Problem eigentlich...
setzt doch mal bitte statt den * die IP-Adresse. Sollte eingentlich egal sein aber mal ausprobieren. versuche mit dem ...

ansonsten schau ob solche konfigurationen vorhanden sind

Code: Select all

 

                Options +Includes +ExecCGI


bist du dir ganz sicher, dass es KEINE ExecCGI irgendwo im zusammenhang mit den port 80:80 bzw 80 steht?
ich würde noch in deine stelle folgendes in deinem Virtual Hostes ergänzen
hat aber nichts mit dem Problem zu tun....

Code: Select all

 Alias "/error_docs" "/srv/www/vhosts/dein Domän/error_docs"
        ErrorDocument 400 /error_docs/bad_request.html
        ErrorDocument 401 /error_docs/unauthorized.html
        ErrorDocument 403 /error_docs/forbidden.html
        ErrorDocument 404 /error_docs/not_found.html
        ErrorDocument 500 /error_docs/internal_server_error.html


ach und mir fällt gleich noch was auf .... hast du es es mal mit einem
SuexecUserGroup was gemacht ... könnte auch ein Grund sein

Code: Select all

SuexecUserGroup         Username psacln


gruss
Mohamed

whyte
Posts: 61
Joined: 2006-01-09 14:21

Re: fast_cgid für einen vhost deaktivieren

Post by whyte » 2007-11-26 16:14

Hallo,

du hattest zwar recht, in der default-server.conf stand es auch nochmal, aber nach dem rausnehmen und neustarten ist es wie immer, das fcgi ist an.

Nochmal steht es in der mod_fcgid.conf in der passage:

Code: Select all

<FilesMatch ".php">
    AddHandler fcgid-script .php
    FCGIWrapper /srv/www/cgi-bin/php5 .php
    Options +ExecCGI
</FilesMatch>


nehme ich es aber da raus, läuft der Server garnicht mehr, also nur noch Error 500.

Gruß
Marco

handeglo
Posts: 62
Joined: 2007-11-21 11:26

Re: fast_cgid für einen vhost deaktivieren

Post by handeglo » 2007-11-26 16:26

du musst in deinem vhost verzeichnis irgendein http.conf oder http.include haben ....

schau mal nach

whyte
Posts: 61
Joined: 2006-01-09 14:21

Re: fast_cgid für einen vhost deaktivieren

Post by whyte » 2007-11-26 16:29

die habe ich alle gefunden und die +ExecCGI auch entfernt.

Nutzt aber nix, ich befürchte, dass es garnicht abzuschalten geht.

Dann lass ich es einfach beim normalen Apache Handler

danke

handeglo
Posts: 62
Joined: 2007-11-21 11:26

Re: fast_cgid für einen vhost deaktivieren

Post by handeglo » 2007-11-26 16:32

ich konnte es schon mal unaktive machen....
kann dir leider so nicht weiter helfen sorry....
Viel Glück noch

gruss

Mohamed

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: fast_cgid für einen vhost deaktivieren

Post by Roger Wilco » 2007-11-26 17:02

1. Handler entfernen
2. Options -ExecCGI
3. Ins error_log schauen

handeglo
Posts: 62
Joined: 2007-11-21 11:26

Re: fast_cgid für einen vhost deaktivieren

Post by handeglo » 2007-11-26 17:18

Options -ExecCGI
hat er schon versucht denke ich ....bzw. auch weg gelassen...
trotzdem funktioniert es nicht
aber mit dem Handler ist auch ne gute Idee

gruss

whyte
Posts: 61
Joined: 2006-01-09 14:21

Re: fast_cgid für einen vhost deaktivieren

Post by whyte » 2007-11-26 20:38

Wie lasse ich denn einen Handler weg ?

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: fast_cgid für einen vhost deaktivieren

Post by Roger Wilco » 2007-11-26 20:41

RemoveHandler...

whyte
Posts: 61
Joined: 2006-01-09 14:21

Re: fast_cgid für einen vhost deaktivieren

Post by whyte » 2007-11-29 22:23

Hmm
ich habe RemoveHandler ExecCGI sowie RemoveHandler FastCGI

bringt aber nix, immernoch wie immer.

Gruß