iptables / nat phänomen

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
dante77
Posts: 36
Joined: 2006-10-18 11:33

iptables / nat phänomen

Post by dante77 »

Ob das Tiefgang hat, weiss ich nicht, aber ich bin momentan überaus ratlos und hoffe auf Hilfe.. es geht um einen SuSE 9 Server der als Firewall (iptables-Skript) beim Internetzugriff dient. Darauf läuft auch ein Squid. Seit kurzem funktionieren keine direkten HTTP-Anfragen mehr, sondern nur noch über Squid. Vorher konnte man sowohl über Squid als auch direkt aufs Internet zugreifen. Dabei habe ich nichts an der Konfiguration auf Linux-Seite geändert.

Wenn ich per Browser eine Seite abrufen will, sieht das so aus (Dump von Wireshark):
http://62.75.241.166/img/traffic.png

Kann mir einer erklären, was da vorgeht? Offenbar wird sofort, nachdem eine HTTP GET Anfrage abgesetzt wurde, die Verbindung resetted. Firefox teilt dann auch mit, "Connection Reset". Iptables loggt auch nichts dergleichen, dass etwas geblockt wurde in dem Fall. Woran kann das liegen? Hat irgend jemand einen Tipp für mich? Bin ratlos..
captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: iptables / nat phänomen

Post by captaincrunch »

Drei Fragen:
1. Auf welchem System wurde der Wireshark gestartet?
2. Was sagen die Webserver-Logs (falls verfügbar)?
3. Wie sieht dein Regelwerk / NAT aus?
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc
dante77
Posts: 36
Joined: 2006-10-18 11:33

Re: iptables / nat phänomen

Post by dante77 »

Hallo Captain, danke für das Hilfsangebot, ich bin mittlerweile drauf gekommen.. offenbar hat 1&1 den Namesrver umgestellt, den ich manuell eingetragen hatte. Merkwürdiger Weise hat der zwar immer noch DNS-Anfragen beantwortet, allerdings immer nur mit einer IP aus dem 1&1/Telekom-Adressbereich. Nachdem ich aktuelle 1&1 DNS-Server Adressen recherchiert hatte, gehts jetzt.