mal wieder php5 mit gd und ttf, ich bekomms nicht gebacken

Apache, Lighttpd, nginx, Cherokee
manuelw
Posts: 63
Joined: 2002-07-08 23:37

mal wieder php5 mit gd und ttf, ich bekomms nicht gebacken

Post by manuelw » 2007-09-14 16:45

Aloha,

ich habe hier ein selber kompiliertes php5 welches soweit auch funktioniert.
Nur bekomme ich freetype nicht ans laufen, ich raff nicht wieso.

hier mein configure
./configure --with-sqlite=shared --enable-sqlite-utf8 --disable-cgi --prefix=/php5 --with-litespeed --with-config-file-path=../php --with-xmlrpc=shared --enable-xmlreader=shared --enable-xmlwriter=shared --with-xsl=shared --with-tidy=shared,/usr --with-inifile=shared --with-flatfile=shared --enable-pdo=shared --with-pdo_sqlite=shared --with-pdo-mysql=shared,/usr --with-iconv=shared --with-kerberos --with-mcrypt=shared --with-mhash=shared --with-mysql=shared,/usr --with-mysql-sock=/var/lib/mysql/mysql.sock --with-mysqli=shared --with-ncurses=shared --with-openssl=shared --with-pspell=shared --enable-tokenizer=shared --enable-wddx=shared --with-zlib=shared --with-bz2=shared --with-curl=shared --with-db4=shared,/usr --with-inifile=shared --with-flatfile=shared --with-gd=shared --enable-gd-jis-conv --with-png-dir=/usr --with-jpeg-dir=/usr --with-zlib-dir=/usr --with-gettext=shared --with-gmp=shared --enable-ctype=shared --enable-dbase=shared --enable-dom=shared --enable-exif=shared --enable-filepro=shared --enable-ftp=shared --enable-mbstring=shared --enable-mbregex --enable-pcntl=shared --enable-posix=shared --enable-shmop=shared --enable-ucd-snmp-hack --enable-soap=shared --enable-sockets=shared --enable-sysvmsg=shared --enable-sysvsem=shared --enable-sysvshm=shared --enable-magic-quotes --enable-libxml --enable-session --with-pcre-regex --enable-xml --enable-simplexml --enable-spl --enable-safe-mode --enable-sigchild --disable-debug --enable-memory-limit --enable-inline-optimization --enable-zend-multibyte --disable-rpath --enable-cli --with-pear=/usr/share/php5/PEAR --enable-bcmath=shared --enable-calendar=shared --includedir=/usr/include/ --with-imap --with-imap-ssl --with-mysql --with-ttf=shared,/usr --with-freetype-dir=shared,/usr --enable-gd-native-ttf


Ich hab schon verschiedene Sachen probiert aber es will einfach nicht.
phpinfo findet ihr hier: http://www.rc-heli.de/info.php

Wäre klasse wenn jemand nen Tip hat.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11134
Joined: 2003-02-27 01:00
Location: Hamburg

Re: mal wieder php5 mit gd und ttf, ich bekomms nicht gebacken

Post by Joe User » 2007-09-14 17:01

1) --with-flatfile und --with-mysql sind doppelt vorhanden.
2) Aus dem Gentoo PHP Ebuild:
The configure option --enable-gd-native-ttf (enabled by the 'truetype' USE flag) was removed at upstreams request, as it's considered old and broken.

manuelw
Posts: 63
Joined: 2002-07-08 23:37

Re: mal wieder php5 mit gd und ttf, ich bekomms nicht gebacken

Post by manuelw » 2007-09-14 17:28

hmm, aber wenn ich --enable-gd-native-ttf weg lasse ändert sich auch nix.

synex
Posts: 45
Joined: 2005-06-17 23:00
Location: Möckern

Re: mal wieder php5 mit gd und ttf, ich bekomms nicht gebacken

Post by synex » 2007-09-14 21:49

FreeType 1.x To enable support for FreeType 1.x add --with-ttf[=DIR].
FreeType 2 To enable support for FreeType 2 add --with-freetype-dir=DIR.


von http://www.php.net/manual/de/ref.image.php

ka ob es funktioniert.. bei mir aber eigentlich schon

PS: 5.2.4 ist neuer ^^

manuelw
Posts: 63
Joined: 2002-07-08 23:37

Re: mal wieder php5 mit gd und ttf, ich bekomms nicht gebacken

Post by manuelw » 2007-09-14 22:22

habs jetzt so versucht

--with-freetype-dir=/usr --enable-gd-native-ttf --enable-gd-imgstrttf

und phpinfo sagt immer noch nö, kein freetype :(

User avatar
Joe User
Project Manager
Project Manager
Posts: 11134
Joined: 2003-02-27 01:00
Location: Hamburg

Re: mal wieder php5 mit gd und ttf, ich bekomms nicht gebacken

Post by Joe User » 2007-09-14 22:33

Code: Select all

--with-freetype=shared --with-freetype-dir=/usr

synex
Posts: 45
Joined: 2005-06-17 23:00
Location: Möckern

Re: mal wieder php5 mit gd und ttf, ich bekomms nicht gebacken

Post by synex » 2007-09-14 23:23

vlt auch mal beim configure gucken, ob eine meldung beim checken von freetype kommt

ist vlt freetype nicht installiert (bzw. dev pakete etc)?

manuelw
Posts: 63
Joined: 2002-07-08 23:37

Re: mal wieder php5 mit gd und ttf, ich bekomms nicht gebacken

Post by manuelw » 2007-09-15 03:10

nene, das geht alles klar, kommt auch beim configure ein ok.
ich hab das devel auch selber vorher grad installiert.