Probleme bei der Installation von Apache 2.2.6

Apache, Lighttpd, nginx, Cherokee
vivalabam
Posts: 22
Joined: 2007-09-08 23:46

Probleme bei der Installation von Apache 2.2.6

Post by vivalabam » 2007-09-12 02:49

Hi

ich habe ebend versucht meinen jetzigen Apache 2.0.54 auf die neue Version 2.2.6 zu Updaten, dies hat auch funktioniert aber wenn ich den Server neu starten will kommt folgende Fehlermeldung

Code: Select all

"httpd2-prefork: Syntax error on line 112 of /etc/apache2/httpd.conf: Syntax error on line 8 of /etc/apache2/sysconfig.d/loadmodule.conf: API module structure 'perl_module' in file /usr/lib/apache2/mod_perl.so is garbled - expected signature 41503232 but saw 41503230 - perhaps this is not an Apache module DSO, or was compiled for a different Apache version?"
was bedeutet das, habe ich was falsch gemacht ??

Grüße

VivaLaBam

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Probleme bei der Installation von Apache 2.2.6

Post by Joe User » 2007-09-12 10:33

Das bedeutet, dass Dein mod_perl und Dein Apache zueinander inkompatibel sind.

vivalabam
Posts: 22
Joined: 2007-09-08 23:46

Re: Probleme bei der Installation von Apache 2.2.6

Post by vivalabam » 2007-09-12 14:59

Joe User wrote:Das bedeutet, dass Dein mod_perl und Dein Apache zueinander inkompatibel sind.


Danke erstmal für die Antwort, weißt du auch zufällig wo ich am besten ein rpm Paket mit einer kompatiblen mod_perl Version her bekomme !

Meine VPS Konfiguration:

Apache 2.0.54 (habe erstmal wieder diese installiert da ja 2.2.6 nicht startet)
PHP 5.2.4
mod_perl Version 2.0.1
Suse Linux 10.0

Grüße

VivaLaBam

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Probleme bei der Installation von Apache 2.2.6

Post by Joe User » 2007-09-12 15:11

Auf openSUSE 10.2 upgraden (ist eh demnächst fällig) oder mod_perl selbst (re)kompilieren.

vivalabam
Posts: 22
Joined: 2007-09-08 23:46

Re: Probleme bei der Installation von Apache 2.2.6

Post by vivalabam » 2007-09-12 19:52

Joe User wrote:Auf openSUSE 10.2 upgraden (ist eh demnächst fällig) oder mod_perl selbst (re)kompilieren.


Das hatte ich mir auch schon überlegt, da ich leider einen VPS mit Plesk habe weiß ich nicht ob OpenSuse 10.2 kompatibel ist.
Leider hinkt Hosteurope immernoch bei neuen Versionen hinterher und der Support ist eigentlich auch für den ar**** ! .
Ich weiß außerdem auch nicht ob ein Sytemupdate auf meinem VPS möglich ist, mir war es ja nicht mal möglich über YAST ein Kernelupdate einzuspielen.

Gibt es vielleicht eine Anleitung oder Erfahrungsberichte mit einem Systemupdate von SuseLinux 10.0 auf OpenSuse 10.2 mit Plesk auf einem VPS ??

Danke schonmal im Vorraus

VivaLaBam

vivalabam
Posts: 22
Joined: 2007-09-08 23:46

Re: Probleme bei der Installation von Apache 2.2.6

Post by vivalabam » 2007-09-12 22:36

matzewe01 wrote:
VivaLaBam wrote:Gibt es vielleicht eine Anleitung oder Erfahrungsberichte mit einem Systemupdate von SuseLinux 10.0 auf OpenSuse 10.2 mit Plesk auf einem VPS ??


Ja, der Erfahrungsschatz heisst, Plesk runter schmeissen, System upgraden und danach Plesk für opensuse10.2 installiern.
Anders klappt eds auf jeden Fall nicht.


Gruss Matthias


Okay wie bekomme ich Plesk runter und danach wieder druf, habe den VPS noch nicht so lange und kenne mich daher mit Plesk noch nicht so gut aus !

Kurze Anleitung wäre vielleicht nicht schlecht !

Grüße

VivaLaBam

vivalabam
Posts: 22
Joined: 2007-09-08 23:46

Re: Probleme bei der Installation von Apache 2.2.6

Post by vivalabam » 2007-09-13 04:22

matzewe01 wrote:
VivaLaBam wrote:Okay wie bekomme ich Plesk runter und danach wieder druf, habe den VPS noch nicht so lange und kenne mich daher mit Plesk noch nicht so gut aus !

Kurze Anleitung wäre vielleicht nicht schlecht !

Grüße

VivaLaBam


yast starten, software installieren oder deinstalieren.
Danach alle installierten Pakete anzeigen lassen.
RPm Pakete / Installationen mit keinem Eintrag in der Spalte: Verfügb. Vers. können 7 sollten gelöscht werden und stammen weder von suse, noch würden diese aktualisiert werden.

Fertig.

Der andere weg wäre beim upgrade anzuwählen, dass alle Pkete ersetzt werden sollen. Damit sollten auch alte Pakete entfernt werden.

Details zum vorgehen entnimmst Du der Dokumenation.


So hab gerade nach dieser Anleitung(http://www.rootforum.de/wiki/howto/opensuse/upgrade) mein VPS auf OpenSuse 10.2 umgestellt.

Leider konnte ich den Aktuellen Kernel nicht installieren dies ist mit folgender Fehlermeldung abgebrochen

Code: Select all

"Subprocess failed. Error: RPM failed: Setting up /lib/modules/2.6.18.2-34
none already mounted or /sys busy                                     
mount: according to mtab, sysfs is already mounted on /sys                     
yast2xxNo '/' mountpoint specified in /etc/fstab                                  online Update (YOU) Aktualisierungsprogramm                                 
Downlxx/sbin/mkinitrd failed                                                                                                                             
zisofxxerror: %post(kernel-bigsmp-2.6.18.2-34.i586) scriptlet failed, exit status"

Laut der Anleitung musste ich ja Plesk installieren, nur leider habe ich nicht dran gedacht die Sachen zu sichern wie komme ich denn an die Pleskdateien wieder ran und wie kann ich den aktuellen Kernel installieren ??

Grüße

VivaLaBam

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Probleme bei der Installation von Apache 2.2.6

Post by Joe User » 2007-09-13 10:08

Auf einem vServer lässt sich der Kernel meist nicht anpassen/updaten, dafür ist der Anbieter zuständig.

vivalabam
Posts: 22
Joined: 2007-09-08 23:46

Re: Probleme bei der Installation von Apache 2.2.6

Post by vivalabam » 2007-09-13 13:24

matzewe01 wrote:
VivaLaBam wrote:So hab gerade nach dieser Anleitung(http://www.rootforum.de/wiki/howto/opensuse/upgrade) mein VPS auf OpenSuse 10.2 umgestellt.

Leider konnte ich den Aktuellen Kernel nicht installieren dies ist mit folgender Fehlermeldung abgebrochen

Code: Select all

"Subprocess failed. Error: RPM failed: Setting up /lib/modules/2.6.18.2-34
none already mounted or /sys busy                                     
mount: according to mtab, sysfs is already mounted on /sys                     
yast2xxNo '/' mountpoint specified in /etc/fstab                                  online Update (YOU) Aktualisierungsprogramm                                 
Downlxx/sbin/mkinitrd failed                                                                                                                             
zisofxxerror: %post(kernel-bigsmp-2.6.18.2-34.i586) scriptlet failed, exit status"

Laut der Anleitung musste ich ja Plesk installieren, nur leider habe ich nicht dran gedacht die Sachen zu sichern wie komme ich denn an die Pleskdateien wieder ran und wie kann ich den aktuellen Kernel installieren ??

Grüße

VivaLaBam



Bei https://register.swsoft.com/login.php?r ... ge=plesk82
bekommst Du die installationsrpms.

Die alten Daten sollten noch vorhanden sein. schau unter /var/lib/mysql /var/qmail und /srv/www/vhosts.

die Fehlermeldung hat erstmal nichts mit dem Kernel zu tun.
Da komme ich aber später dazu. Suche erstmal Deine Daten und sichere diese weg.
Wieweit bist Du eigentlich gekommen?
Ab welchem Punkt des Howtos ist der Fehler aufgetretten?

Gruss Matthias


Hi Matthias

die Installation hat eigentlich funktioniert nur das ich jetzt halt das Problem habe Plesk zu installieren wo finde ich eigentlich den Plesk Key für meine Lizenz (liegt der auf dem Server??).
Der Fehler selber ist hier aufgetreten
"Wir starten nochmals das Systemupdate. Es werden nun rund 150 Pakete aktualisiert und auch der Kernel sowie filesystem-10.2 fehlerfrei installiert."


Werde jetzt erstmal die besagten Daten sichern !

Grüße

VivaLaBam

vivalabam
Posts: 22
Joined: 2007-09-08 23:46

Re: Probleme bei der Installation von Apache 2.2.6

Post by vivalabam » 2007-09-13 22:28

matzewe01 wrote:
VivaLaBam wrote:Hi Matthias

die Installation hat eigentlich funktioniert nur das ich jetzt halt das Problem habe Plesk zu installieren wo finde ich eigentlich den Plesk Key für meine Lizenz (liegt der auf dem Server??).
Der Fehler selber ist hier aufgetreten
"Wir starten nochmals das Systemupdate. Es werden nun rund 150 Pakete aktualisiert und auch der Kernel sowie filesystem-10.2 fehlerfrei installiert."


Werde jetzt erstmal die besagten Daten sichern !

Grüße

VivaLaBam


Dann wähle den Kernel ab. Da es sich um ein Virtuallen Server handelt, liefert der Kernel Dein Provider.

Die Lizenzdatei solltest Du von Deinem Provider erhalten.
Den Lizenznamen erfährst Du in Plesk unter: Server / Lizenzverwaltung
Ist ein shell Script welches zu ausführen musst.
Wollen wir mal hoffen, dass es sich um keine Virtuozzo umgebung handelt, in der Dein Provider auch gleich die Lizenzdateien und Plesk ausliefert.

Das mit dem virtuellen Server hatte ich leider verpannt.
Ich hoffe mal, dass auf dem System nicht zig Benutzer und Kundendaten liegen. Die Daten selber kann man sichern das anlegen der Accounts etc. beansprucht aber leider einiges an Zeit, da es kein übergreifendes und fehlerfreies Verfahren für einen OS inkl. Plesk Upgrade gibt.
Heisst also leider, alles neu anlegen. Die Passworte etc. bekommt man aber einfach heraus.


Siehe hier:

http://www.rootforum.org/forum/view ... hp?t=46757


Gruss Matthias


So habe nun die Pakete von Plesk geladen für OpenSuse 10.2 und bei mir auf den Server geladen nun wollte ich diese einzeln per "rpm -i" installieren, leider gibt es wieder fehlermeldung "

Code: Select all

rpm -i psa-8.2.0-suse10.2.build82070706.15.i586.rpm
error: Failed dependencies:
        psa-libpam-plesk is needed by psa-8.2.0-suse10.2.build82070706.15.i586
        php-configurator >= 1.2.0 is needed by psa-8.2.0-suse10.2.build82070706.15.i586
        psa-locale-base = 8.2.0 is needed by psa-8.2.0-suse10.2.build82070706.15.i586
        /usr/local/psa/admin/htdocs/locales/default is needed by psa-8.2.0-suse10.2.build82070706.15.i586
        psa-qmail is needed by psa-8.2.0-suse10.2.build82070706.15.i586
        psa-courier-imap-add is needed by psa-8.2.0-suse10.2.build82070706.15.i586
        psa-api is needed by psa-8.2.0-suse10.2.build82070706.15.i586
"

Leider kann ich die Pakete auch nicht einzeln installieren weil es dann wieder Abhänigkeitsfehlermeldungen gibt.
Wie bekomme ich Plesk wieder Ordnungsgemäß auf den Server^^, gibt es vielleicht eine Möglichkeit mit YAST ??

Grüße

VivaLaBam

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Probleme bei der Installation von Apache 2.2.6

Post by Joe User » 2007-09-13 23:02

Grundlagen lernen:

Code: Select all

rpm -ivh psa-*.rpm