richtig update

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
nimda05
Posts: 23
Joined: 2007-05-03 16:03

richtig update

Post by nimda05 »

Hallo!

Ich wollte mal fragen wie ich meinen Apache richtig update(Debian System).
Zur Zeit läuft da ein Apache 2.0.*.

Kann man sowas einfach per apt-get machen?

Danke

Nimda05

Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: richtig update

Post by Roger Wilco »

Nimda05 wrote:Kann man sowas einfach per apt-get machen?
Ja.

http://packages.debian.org/stable/net/apache2

nimda05
Posts: 23
Joined: 2007-05-03 16:03

Re: richtig update

Post by nimda05 »

Hallo!

Mein apt-get spackt leider gerade sehr stark rum.
Ich kann quasi eingeben was ich will:

Code: Select all

Server:/etc# apt-get upgrade apache2
Reading Package Lists... Done
Building Dependency Tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Server:/etc# apt-get upgrade apache2
Reading Package Lists... Done
Building Dependency Tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Server:/etc# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Server:/etc#   
Wodran liegts? Ich hab bei mir debian 3.1 drauf.
Das ist meine sources.list:

Code: Select all

deb ftp://ftp.nl.debian.org/debian/ sarge main non-free contrib
deb-src ftp://ftp.nl.debian.org/debian/ sarge main non-free contrib

deb http://security.debian.org/ sarge/updates main non-free contrib
deb http://www.backports.org/debian/ sarge-backports main contrib non-free
deb-src http://www.backports.org/debian/ sarge-backports main contrib non-free
Danke
Nimda05

sledge0303
Posts: 695
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: richtig update

Post by sledge0303 »

Code: Select all

apt-get update
apt-get upgrade
Wenn neuere Pakete vorliegen, werden diese damit aktualisiert.

User avatar
daemotron
Administrator
Administrator
Posts: 2636
Joined: 2004-01-21 17:44

Re: richtig update

Post by daemotron »

Apache 2.2 ist erst bei etch Standard. RW bezog sich mit stable sicherlich auch auf etch, nicht auf sarge. Führe ein Upgrade auf etch durch; dann stehen die auch aktuelle Apache-Pakete zur Verfügung. Ansonsten musst Du halt an den Sources rumpfuschen.

nimda05
Posts: 23
Joined: 2007-05-03 16:03

Re: richtig update

Post by nimda05 »

Ich hab auf meiner Kiste noch Plesk drauf. Gibt es irgendwelche Probleme wenn ich da einfach ein
apt-get dist-upgrade
mache?

User avatar
daemotron
Administrator
Administrator
Posts: 2636
Joined: 2004-01-21 17:44

Re: richtig update

Post by daemotron »

Ziemlich wahrscheinlich: Ja. Plesk ist sehr penibel, wenn es um die eingesetzten Versionen geht. Mag sogar angehen, dass Plesk explizit auf Apache-2.0.* besteht und die Freundschaft aufkündigt, wenn Du ihm einen anderen unterschieben willst.

nimda05
Posts: 23
Joined: 2007-05-03 16:03

Re: richtig update

Post by nimda05 »

Und was kann ich jetzt machen? Es kursiere schon dieverse nicht öffentliche Apache Exploits... aber auf Plesk kann ich auch nicht verzichten.
Also was tun?

Roger Wilco
Posts: 5923
Joined: 2004-05-23 12:53

Re: richtig update

Post by Roger Wilco »

Debian Sarge wird sicherheitstechnisch noch unterstützt. Wenn der damit ausgelieferte Apache httpd für einen bekannten oder unbekannten Exploit verwundbar ist, stelle einen Bugreport mit den nötigen Informationen, so dass die Maintainer ein neues Paket erstellen können.

nimda05
Posts: 23
Joined: 2007-05-03 16:03

Re: richtig update

Post by nimda05 »

ich habe ja nun den exploit nicht und kenne diese sicherheitslücke auch nicht.
aber was macht man denn jetzt nun in so einer situation?
sprich: wie kann ich den apache auf die neueste version updaten, sodass trotzdem noch plesk läuft?

niko86
Posts: 6
Joined: 2007-03-30 11:53

Re: richtig update

Post by niko86 »

wenn du von <2.2.4 updatest, dann lies dir das vorher durch:
http://www.apache.org/dist/httpd/Announcement2.2.html
es wurden einige module umbenannt und umstruktiert, hat bei mir nach einem "blinden" update für reichlich verwirrung gesorgt.