mysql nimmt RAM nicht

neodg
Posts: 38
Joined: 2005-10-19 08:50

mysql nimmt RAM nicht

Post by neodg »

Folgendes: Dual Opteron, 11 GB Ram, /var/lib/mysql auf extra HDD.

OS: Debian Etch

MySQL Version 5.0.45-Dotdeb_0.dotdeb.1 i486

mysql Config:

Code: Select all

# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "/var/lib/mysql/my.cnf" to set server-specific options or
# - "~/.my.cnf" to set user-specific options.
#
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port            = 3306
socket          = /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket          = /var/run/mysqld/mysqld.sock
nice            = 0

[mysqld]
old_passwords = true # inserted by debconf
#
# * Basic Settings
#
user            = mysql
pid-file        = /var/run/mysqld/mysqld.pid
socket          = /var/run/mysqld/mysqld.sock
port            = 3306
basedir         = /usr
datadir         = /var/lib/mysql
tmpdir          = /tmp
language        = /usr/share/mysql/german
#skip-external-locking
#
# For compatibility to other Debian packages that still use
# libmysqlclient10 and libmysqlclient12.
#
# Instead of skip-networking you can listen only on
# localhost which is more compatible and is not less secure.
#bind-address           = 127.0.0.1
#skip-networking
#
# * Fine Tuning
#
key_buffer_size         = 768M
max_allowed_packet      = 8M

long_query_time = 5

table_cache             = 4096

thread_concurrency      = 2
thread_cache_size       = 128

max_connections = 1000

# Die nachstehenden Buffer sind per-connection und werden
# ggf max_connections mal alloziert
thread_stack            = 128K
join_buffer_size        = 2M
sort_buffer_size        = 2M
read_buffer_size        = 256K
read_rnd_buffer_size    = 512k
myisam_sort_buffer_size = 256M

#bulk_insert_size       = 32M
#max_connection_error   = 10
tmp_table_size          = 4096M
max_heap_table_size     = 4096M

#
# * Query Cache Configuration
#
query_cache_limit       = 2M
query_cache_size        = 16M
query_cache_type        = 1

low_priority_updates    = 1
concurrent_insert       = 2
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log            = /var/log/mysql.log
#log            = /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log-slow-queries       = /var/log/mysql/mysql-slow.log
#long-query-time         = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
#server-id              = 1
#log-bin                        = /var/log/mysql/mysql-bin.log
#expire-logs-days       = 20
#max_binlog_size         = 104857600
#binlog-do-db           = include_database_name
#binlog-ignore-db       = include_database_name
#
# * BerkeleyDB
#
# According to an MySQL employee the use of BerkeleyDB is now discouraged
# and support for it will probably cease in the next versions.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
#
# * Security Features
#
# Read the manual, too, if you want chroot!
#chroot = /var/lib/mysql/
#
# If you want to enable SSL support (recommended) read the manual or my
# HOWTO in /usr/share/doc/mysql-server/SSL-MINI-HOWTO.txt.gz
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem

# Uncomment the following if you are using InnoDB tables
skip-innodb
#innodb_data_home_dir = /var/lib/mysql/
#innodb_data_file_path = ibdata1:2000M;ibdata2:10M:autoextend
#innodb_log_group_home_dir = /var/lib/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#innodb_buffer_pool_size = 384M
#innodb_additional_mem_pool_size = 20M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 100M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

[mysqldump]
quick
quote-names
max_allowed_packet      = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition
prompt = u@h [d]>_

[isamchk]
key_buffer              = 128M
sort_buffer_size        = 128M
read_buffer             = 2M
write_buffer            = 2M

[myisamchk]
key_buffer              = 128M
sort_buffer_size        = 128M
read_buffer             = 2M
write_buffer            = 2M

[mysqlhotcopy]
interactive-timeout

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the ndbd storage daemons,
# not from the ndb_mgmd management daemon.
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1


Das Teil nimmt immer nur 2-4 GB Ram und lässt den Rest links liegen. Die DB die drauf ist hat ca. 4 GB und täglich 1000ende von Zugriffen.

Mem: 11200324k total, 3000272k used, 8200052k free, 15500k buffers
Swap: 3903752k total, 0k used, 3903752k free, 2628444k cached


Warum nimmt er den RAM nicht besser? Die Performance ist nicht schlecht, aber zu Stoßzeiten hat er doch relativ hohe Last und nimmt den Arbeitsspeicher auch nicht mehr.
Top

chrigu
Posts: 14
Joined: 2005-01-28 15:35

Re: mysql nimmt RAM nicht

Post by chrigu »

Hi,
Es ist nur eine Vermutung, aber da du ein 32Bit OS verwendest, kann ein MySQL-Prozess doch gar nicht mehr als 4GB RAM adressieren?

Gruss,
Chrigu
Top

neodg
Posts: 38
Joined: 2005-10-19 08:50

Re: mysql nimmt RAM nicht

Post by neodg »

chrigu wrote:Hi,
Es ist nur eine Vermutung, aber da du ein 32Bit OS verwendest, kann ein MySQL-Prozess doch gar nicht mehr als 4GB RAM adressieren?

Gruss,
Chrigu


Kernel is ein 64 bit, damit er das kann. Und am Anfang hat er auch den ganzen Ram bis auf ~ 1 GB genommen. Ich habe dann die Config nach und nach angepasst, die Last wurde weniger, aber jetzt auf einmal nimmt er den Ram nicht mehr.
Top

chrigu
Posts: 14
Joined: 2005-01-28 15:35

Re: mysql nimmt RAM nicht

Post by chrigu »

neodg wrote:
chrigu wrote:Hi,
Es ist nur eine Vermutung, aber da du ein 32Bit OS verwendest, kann ein MySQL-Prozess doch gar nicht mehr als 4GB RAM adressieren?

Gruss,
Chrigu


Kernel is ein 64 bit, damit er das kann. Und am Anfang hat er auch den ganzen Ram bis auf ~ 1 GB genommen. Ich habe dann die Config nach und nach angepasst, die Last wurde weniger, aber jetzt auf einmal nimmt er den Ram nicht mehr.

Bist du dir sicher, dass der MySQL-Prozess soviel RAM verwendet hat, oder hat der Kernel darin vielleicht Files gecacht?
Top

neodg
Posts: 38
Joined: 2005-10-19 08:50

Re: mysql nimmt RAM nicht

Post by neodg »

chrigu wrote:
neodg wrote:
chrigu wrote:Hi,
Es ist nur eine Vermutung, aber da du ein 32Bit OS verwendest, kann ein MySQL-Prozess doch gar nicht mehr als 4GB RAM adressieren?

Gruss,
Chrigu


Kernel is ein 64 bit, damit er das kann. Und am Anfang hat er auch den ganzen Ram bis auf ~ 1 GB genommen. Ich habe dann die Config nach und nach angepasst, die Last wurde weniger, aber jetzt auf einmal nimmt er den Ram nicht mehr.

Bist du dir sicher, dass der MySQL-Prozess soviel RAM verwendet hat, oder hat der Kernel darin vielleicht Files gecacht?


Es ist wahrscheinlich das Files gecached wurden, aber das tut er ja auch nimma *grml*

Ich habe mich schon mal entschlossen das Betriebssystem auf 64 bit umzustellen, damit das sicher weg ist. Der Server hatte vorher 3 GB Ram und wurde jetzt um 8 GB aufgerüstet.

Wobei ich ja jetzt schon gerne wüsste warum das auf einmal so ist.
Top