Webserver teilweise nicht erreichbar!!

Apache, Lighttpd, nginx, Cherokee
pretender2109
Posts: 6
Joined: 2007-08-20 16:49

Webserver teilweise nicht erreichbar!!

Post by pretender2109 » 2007-08-24 00:00

Hallo liebe Community,
es ist mal wieder so weit, habe mal wieder ein großes Problem!

System:AMD Sem. 2800+ mit 1GB RAM, Debian Sarge /Apache 2.0.55/ PHP4.4.2-1


Problem: Ab und zu geht der Webserver Down, nur das komische an der ganzen Sache ist, das man Ihn anpingen kann, FTP auch geht, nur werden keine Webseiten mehr angezeigt. Die Auswertung der Logdateien zum Zeitpunkt wo die Seiten nicht erreichbar waren, ergab kein erfolg, es wurden keine Fehler/Probleme gefunden.Dann hilft nur ein restart und er rennt wieder.
Bis wieder dieser gewisse Tag kommt wo nichts mehr geht.
Es ist auch kein Zykluss zu ekennen das man dass ganze eingrenzen könnte.
Ich weiss nun echt nicht mehr wo ich den fehler noch suchen soll!!

Ich hoffe es kann mir einer einen Tip geben!

Vielen Dank im Voraus!!

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: Webserver teilweise nicht erreichbar!!

Post by Roger Wilco » 2007-08-24 00:19


pretender2109
Posts: 6
Joined: 2007-08-20 16:49

Re: Webserver teilweise nicht erreichbar!!

Post by pretender2109 » 2007-08-24 11:28

Roger Wilco wrote:Wenn ihr den Apache httpd benutzt habt ihr vermutlich einfach zuwenige Prozesse (prefork) bzw. Threads (worker) gestartet.

Lesestoff:
http://httpd.apache.org/docs/2.2/mod/mpm_common.html
http://httpd.apache.org/docs/2.2/mod/worker.html
http://httpd.apache.org/docs/2.2/mod/prefork.html
http://httpd.apache.org/docs/2.2/mod/mod_status.html


Vielen Dank, werde ich gleich mal testen!

flo
Posts: 2223
Joined: 2002-07-28 13:02
Location: Berlin

Re: Webserver teilweise nicht erreichbar!!

Post by flo » 2007-08-24 20:29

Habt ihr vielleicht auch etwas drauf, was den Webserver gegebenenfalls neu starten möchte? (Plesk, Confixx, o.ä.?)