[Gelöst] Vhost Konfiguration: Apache leitet falsch um. Benötige Denkhilfe!

Apache, Lighttpd, nginx, Cherokee
sascha.koerber
Posts: 4
Joined: 2007-08-03 16:56

[Gelöst] Vhost Konfiguration: Apache leitet falsch um. Benötige Denkhilfe!

Post by sascha.koerber » 2007-08-10 09:13

Hallo Freunde,

ich habe ein Problem beim konfigurieren des Apache (2.0.x) Servers. Speziell beim Verwenden der VHOSTS. Auf dem Server läuft Debian auf aktuellstem Stand.

Ich habe folgendes Problem: in den VHOSTS habe ich eingetragen, das sowohl der Aufruf "www.meinedomain.de" als auch "meinedomain.de" auf die Site ein einem bestimmten Verzeichnis zurückgreift (ServerName http://www.meinedomain.de, ServerAlias meinedomain.de). Rufe ich die Seite http://www.meinedomain.de auf, klappt das auch, rufe ich aber nur meinedomain.de auf (ohne www) dann springt der Apache in das default Verzeichnis (/var/www), obwohl ich das in der Config unterdrückt hatte...

Bei allen anderen VHOSTS die auf dem Server eingerichtet sind, ist das NICHT der Fall. Da funktioniert der Einstig sowohl über den Servernamen, als auch über den Alias. Nur bei der Domain meinedomain.de verhält er sich anders.

Kann mir jemand sagen, woran das liegen könnte? Ich komme da nicht mehr mit und habe die Konfiguration schon 10 Mal durchgesehen.

Hier meine Configs die dazu gehören:

Der default vhost /etc/apache2/sites-available/default

Code: Select all

NameVirtualHost *

<VirtualHost *>

   ServerAdmin webmaster@meinedomain.de
   DocumentRoot /var/www/

   <Directory />
      Options FollowSymLinks
      AllowOverride None
   </Directory>

   <Directory /var/www/>
      Options FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
      # This directive allows us to have apache2's default start page
      # in /apache2-default/, but still have / go to the right place
      # RedirectMatch ^/$ /apache2-default/
   </Directory>

   ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/

   <Directory "/usr/lib/cgi-bin">
      AllowOverride None
      Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all
   </Directory>

   ErrorLog /var/log/apache2/error.log

   # Possible values include: debug, info, notice, warn, error, crit,
   # alert, emerg.

   LogLevel warn

   CustomLog /var/log/apache2/access.log combined
   ServerSignature On

    Alias /doc/ "/usr/share/doc/"

    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>



Die Datei /etc/apache2/sites-available/meinedomain.de:

Code: Select all

<VirtualHost *>

        ServerAdmin webmaster@meinedomain.de
        ServerName www.meinedomain.de
        ServerAlias meinedomain.de
        DocumentRoot /var/www/meinedomain/html/

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/meinedomain_de_access.log combined
        ServerSignature On

</VirtualHost>


Die anderen VHOST-Dateien sind exakt so aufgebaut wie die für meinedomain.de, aber bei denen funktioniert seltsamerweise der www. und auch der aufruf der domain ohne www.

Muss ich das verstehen?

Erbitte kompetente Hilfe! Vielen Dank an Euch fürs Mitdenken! :-)
Last edited by sascha.koerber on 2007-08-10 10:29, edited 1 time in total.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: [Gelöst] Vhost Konfiguration: Apache leitet falsch um. Benötige Denkhilfe!

Post by Joe User » 2007-08-10 10:09

Verpasse dem Default-VHost mal einen ServerName z.B. default.domain.tld

sascha.koerber
Posts: 4
Joined: 2007-08-03 16:56

Re: [Gelöst] Vhost Konfiguration: Apache leitet falsch um. Benötige Denkhilfe!

Post by sascha.koerber » 2007-08-10 10:29

Manchmal liegt die Lösung einem direkt von der Nase, und man sieht und sieht sie nicht. DANKE! Das hat geholfen! :-D