1und1 V-Server Suse Linux 9.3 -> PHP wird nicht mehr übersetzt

Apache, Lighttpd, nginx, Cherokee
exzel
Posts: 5
Joined: 2007-04-28 22:38

1und1 V-Server Suse Linux 9.3 -> PHP wird nicht mehr übersetzt

Post by exzel » 2007-08-09 12:32

Hallo zusammen,

hab' gestern noch erfolgreich eine Datenbankabfrage in PHP programmiert und einwandfrei getestet. Heute morgen wollte ich das ganze nochmals ausprobieren, wurde nur noch ein Downloadfenster für die PHP-Datei angezeigt.


Wie kann das sein?

PS: Serversoftware ist Plesk

bernsteinkater
Posts: 67
Joined: 2006-06-27 11:47

Re: 1und1 V-Server Suse Linux 9.3 -> PHP wird nicht mehr übersetzt

Post by bernsteinkater » 2007-08-09 16:15

Oeffne mal "yast -> Software Management" und guck mals obs da fehlende Abhaengigkeiten gibt. Ich hab in letzter Zeit oefter mal beobachtet, dass eines der letzten SUSE-Updates auf 9.3 (in Kombi mit Plesk) das Paket apache2-mod_php4 durch das Paket mod_php4-apache2 ausgetauscht hat.

Falls also mod_php4-apache2 installiert ist: Deinstallieren und apache2-mod_php4 installieren.

Bitte Feedback obs das war. Danke!

exzel
Posts: 5
Joined: 2007-04-28 22:38

Re: 1und1 V-Server Suse Linux 9.3 -> PHP wird nicht mehr übersetzt

Post by exzel » 2007-08-09 16:18

Hallo und danke für die Antwort,

hab' jetzt die Konfiguration unter Yast -> Network Services -> HTTP Server durchgesehen, wobei mir im Abschnitt Module aufgefallen ist, dass PHP nicht ausgewählt war.

Also wählte ich das Modul aus, ging den Rest der Konfiguration durch und wollte mit sh /etc/init.d/apache2 start den Webserver starten.

Jetzt bekomme ich folgende Fehlermeldung:


Starting httpd2 (prefork) Syntax error on line 13 of /srv/www/vhosts/URL/conf/httpd.include:
Invalid command 'SuexecUserGroup', perhaps mis-spelled or defined by a module not included in the server configuration

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf


Was kann ich tun?

exzel
Posts: 5
Joined: 2007-04-28 22:38

Re: 1und1 V-Server Suse Linux 9.3 -> PHP wird nicht mehr übersetzt

Post by exzel » 2007-08-09 17:04

Jetzt geht's

hab' also das mod_php4-apache2 deinstalliert, nochmals unter Yast -> Network Services -> HTTP Server die Module durchsucht und bin auf das SuexecUserGroup Modul gestoßen, das deaktiviert war.

Nachdem ich es aktiviert hatte, ging es wieder.


Vielen, vielen Dank.