Virtualhost unter XEN nicht erreichbar.

VirtualBox, VMWare, KVM, XEN, OpenVZ, Virtuozzo, etc.
sledge0303
RSAC
Posts: 767
Joined: 2005-09-16 00:06
Location: Berlin-Reinickendorf

Re: Virtualhost unter XEN nicht erreichbar.

Post by sledge0303 » 2007-07-24 07:16

matzewe01 wrote:Hallo,

ich habe vorhin einen Suse XEN Server aufgesetzt. Zusätzlich einen Virtual Host eingerichtet.
Dem Virtual Host habe ich die IP 192.168.115.160 gegeben. Der XEN Host selbst hat die IP 192.168.115.150.

Der Virtuelle Host lässt sich jedoch nicht von aussen und auch nicht vom XEN Host zugreifen.
Vermutlich mache ich was am Routing falsch. Firewall etc. sind nach meinen wissen nicht installiert.

Vieleicht hat ja jemand eine Idee woran es liegen könnte.


Gruss Matthias
Wenn die domU kein Zugang zum Netzwerk hat soll es vorkommen...:D
Löst du das Netzwerk per Bridge oder NAT auf und welches OS soll als Gast laufen?

juelz
Posts: 28
Joined: 2007-05-08 17:48

Re: Virtualhost unter XEN nicht erreichbar.

Post by juelz » 2007-07-24 07:45

Hi,
ich würde dir gerne http://www.pug.org/index.php/Xen-Installation ans Herz legen, speziell den Abschnitt über das Netzwerk/Routing. Denn diese Anleitung ist so aufgebaut, wie man sich das Setup für einen Rootserver beispielsweise wünscht: 1 öffentliche IP, Portweiterleitung per NAT auf die virtuellen Maschinen.

Gruss

juelz
Posts: 28
Joined: 2007-05-08 17:48

Re: Virtualhost unter XEN nicht erreichbar.

Post by juelz » 2007-07-24 17:22

matzewe01 wrote:
juelz wrote:Hi,
ich würde dir gerne http://www.pug.org/index.php/Xen-Installation ans Herz legen, speziell den Abschnitt über das Netzwerk/Routing. Denn diese Anleitung ist so aufgebaut, wie man sich das Setup für einen Rootserver beispielsweise wünscht: 1 öffentliche IP, Portweiterleitung per NAT auf die virtuellen Maschinen.

Gruss

Das Routing kommt für mich nicht in Frage. Die Bridge ist absolut ok.
Hintergrund des vhosts ist ein anderer als ein Rootserver mit einer Ip Adresse.


Gruss Matthas
Achso ok, ich dachte, dass du Xen auf einem Rootserver einsetzen möchtest. Die o.g. Seite ist trotzdem ziemlich nützlich.

juelz
Posts: 28
Joined: 2007-05-08 17:48

Re: Virtualhost unter XEN nicht erreichbar.

Post by juelz » 2007-07-24 22:35

Zeig mal die Ausgabe von

Code: Select all

# brctl show

juelz
Posts: 28
Joined: 2007-05-08 17:48

Re: Virtualhost unter XEN nicht erreichbar.

Post by juelz » 2007-07-25 09:49

bridge name bridge id STP enabled interfaces
xenbr0 8000.000000000 no
Wenn du also deine VM wie einen eigenen Lan-Rechner benutzen möchtest, musst du die VM und dein eth0 an die Bridge anschließen. Zu erledigen sollte das gehen mit:

Code: Select all

# brctl addif xenbr0 eth0
# brctl addif xenbr0 vif9.0

aquajo
RSAC
Posts: 167
Joined: 2003-02-25 21:07

Re: Virtualhost unter XEN nicht erreichbar.

Post by aquajo » 2007-07-25 17:01

Ich habe keine Ahnung was Yast mit der Config anstellt, aber konfigurier doch einfach die IP vom "alten" eth0 auf die Bridge