OpenLDAP Startschwierigkeiten beim lösen von Windows

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
alternativende
Posts: 36
Joined: 2006-10-30 20:00

OpenLDAP Startschwierigkeiten beim lösen von Windows

Post by alternativende » 2007-06-24 19:07

Hallo zusammen,
ich muss derzeit für ca. 1500 user an verschiendenen Standorten DomänenController erstellen und wollte das ganze natürlich gerne mit Linux machen ( Debian Etch).

Ich habe mich an das Howto von http://www.samba-ldap.de gehalten und bisher funktionierte auch alles einigermaßen gut, aber beim entscheidenen Start von slapd bekomme ich folgende Fehlermeldung.

line 90: index attribute "sambaSID" undefined

Wie gesagt habe folgendes Howto verwendet ( http://www.samba-ldap.de/samba-3-pdc-mit-ldap.html )
Der einzige Unterschied ist das ich bdb verwende da ldbm nicht mehr in Etch verwendet wird. Habe alles exakt so wie in dem Howto durchgeführt aber auch nichts zusätzliches gemacht.

Vorher hatte ich keine Fehler abgesehen davon, dass folgender Befehl nicht ausgeführt werden konnte da die Gruppe nicht vorhanden war und ist.

debain-pdc:~# chown :"Domain Users" –R /samba/share/

Habe schon in anderen Foren gefragt aber bisher konnte mir niemand helfen.

Falls ihr weitere Infos braucht sagt Bescheid.

Danke

alternativende
Posts: 36
Joined: 2006-10-30 20:00

Re: OpenLDAP Startschwierigkeiten beim lösen von Windows

Post by alternativende » 2007-06-27 11:13

ich hatte eben endlich einen kleinen Durchbruch und kann schon fast das Licht am Ende des Tunnels sehen ...
Ich habe folgende Anleitung ausprobiert
http://gertranssmb3.berlios.de/output/F ... #fast-ldap
und die slapd.conf aus dieser genommen und durch meine ersetzt. Slapd startet jetzt auch ohne einen Fehler aufzuzeigen.
Nun funktioniert aber leider smbldap-populate noch nicht

Code:

Populating LDAP directory for domain SAMBA-LDAP (S-1-5-21-1765559069-1598711450-3952703467)
(using builtin directory structure)

adding new entry: dc=samba-ldap,dc=local
failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 495, <GEN1> line 2.
adding new entry: ou=Users,dc=samba-ldap,dc=local
failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 495, <GEN1> line 3.
adding new entry: ou=Groups,dc=samba-ldap,dc=local
failed to add entry: no global superior knowledge at /usr/local/sbin/smbldap-populate line 495, <GEN1> line 4.

usw.

Please provide a password for the domain root:
No such object at /usr/local/sbin//smbldap_tools.pm line 353.


In dem anderen Samba Howto steht auch ich solle slapadd -v -l samba-ldap-initdb.ldif ausführen.
Ich bekomme aber daraufhin folgende Fehlermeldung.

Code:

/etc/samba# slapadd -v -l /etc/ldap/samba-ldap-init.ldif
Available database(s) do not allow slapadd


Woran kann das nun liegen ?

Edit: Die Syslog sagt interessanterweise an einer Stelle...
Code:

Jun 26 12:09:01 gsn-samba CRON[2740]: pam_ldap: ldap_simple_bind Can't contact LDAP server

lukewill
Posts: 17
Joined: 2004-08-17 19:34

Re: OpenLDAP Startschwierigkeiten beim lösen von Windows

Post by lukewill » 2007-07-24 18:38

Hallo, hast du das Problem gelöst (ist ja schon was her)? Ich hatte das auch und konnte das Problem lösen, indem ich in der slapd.conf die Parameter:

rootdn "cn=manager,dc=dings,dc=net"
rootpw totalgeheim

eingetragen habe.